summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author William PC2023-03-17 21:52:27 +0100
committer Willy Sudiarto Raharjo2023-03-25 04:01:46 +0100
commit71c83d479bce3dc5c2dbc43740af4109bcfea39a (patch)
tree8c785e876ce07c9f45ca920326ebae077a689422
parent9d96e6be9734294c830364d640301b662ad7b3f6 (diff)
downloadslackbuilds-71c83d479bce3dc5c2dbc43740af4109bcfea39a.tar.gz
libraries/plastid: Added (analysis of sequencing and genomics data)
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/plastid/README3
-rw-r--r--libraries/plastid/plastid.SlackBuild107
-rw-r--r--libraries/plastid/plastid.info10
-rw-r--r--libraries/plastid/slack-desc19
4 files changed, 139 insertions, 0 deletions
diff --git a/libraries/plastid/README b/libraries/plastid/README
new file mode 100644
index 0000000000..2aa7447f1a
--- /dev/null
+++ b/libraries/plastid/README
@@ -0,0 +1,3 @@
+ plastid is a Python library for genomics and sequencing. It includes
+tools for exploratory data analysis (EDA) as well as a handful of
+scripts that implement common tasks.
diff --git a/libraries/plastid/plastid.SlackBuild b/libraries/plastid/plastid.SlackBuild
new file mode 100644
index 0000000000..0c71db68ff
--- /dev/null
+++ b/libraries/plastid/plastid.SlackBuild
@@ -0,0 +1,107 @@
+#!/bin/bash
+
+# Slackware build script for plastid
+
+# Copyright 2023 William PC - Seattle, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=plastid
+VERSION=${VERSION:-0.6.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+COMMIT="d97f239d73b3a7c2eff46f71928b777431891f90"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$COMMIT
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$COMMIT
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+python3 setup.py build
+python3 setup.py install --root=$PKG
+
+
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES.rst LICENSE \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/plastid/plastid.info b/libraries/plastid/plastid.info
new file mode 100644
index 0000000000..0b04f54fd7
--- /dev/null
+++ b/libraries/plastid/plastid.info
@@ -0,0 +1,10 @@
+PRGNAM="plastid"
+VERSION="0.6.1"
+HOMEPAGE="https://github.com/joshuagryphon/plastid"
+DOWNLOAD="https://github.com/joshuagryphon/plastid/archive/d97f239d73b3a7c2eff46f71928b777431891f90/plastid-0.6.1.tar.gz"
+MD5SUM="48a01a3816a787a5fade529fbf1866c7"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysam python3-numpy"
+MAINTAINER="William PC"
+EMAIL="w_calandrini[at]hotmail[dot]com"
diff --git a/libraries/plastid/slack-desc b/libraries/plastid/slack-desc
new file mode 100644
index 0000000000..ce4ffc517c
--- /dev/null
+++ b/libraries/plastid/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+plastid: plastid (Position-wise analysis of sequencing and genomics data)
+plastid:
+plastid:
+plastid:
+plastid: plastid is a Python library for genomics and sequencing. It
+plastid: includes tools for exploratory data analysis (EDA) as well as a
+plastid: handful of scripts that implement common tasks.
+plastid:
+plastid:
+plastid:
+plastid: