summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Bob Funk2022-11-18 07:03:28 +0100
committer Willy Sudiarto Raharjo2022-11-19 04:08:10 +0100
commit76ff721098c72ef69004331e75ca912c43bfa7b6 (patch)
tree5fb388054b3824cb13f8395fd83c8979a0f3839d
parent5a161161957e52013255b3b5b7652c6bde5706fa (diff)
downloadslackbuilds-76ff721098c72ef69004331e75ca912c43bfa7b6.tar.gz
desktop/gnome-shell: Updated for version 41.9.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--desktop/gnome-shell/0001-build-with-gsettings-desktop-schemas-40.patch15
-rw-r--r--desktop/gnome-shell/README7
-rw-r--r--desktop/gnome-shell/doinst.sh11
-rw-r--r--desktop/gnome-shell/douninst.sh11
-rw-r--r--desktop/gnome-shell/gnome-shell.SlackBuild60
-rw-r--r--desktop/gnome-shell/gnome-shell.info10
-rw-r--r--desktop/gnome-shell/gnome-shell.wrap14
7 files changed, 123 insertions, 5 deletions
diff --git a/desktop/gnome-shell/0001-build-with-gsettings-desktop-schemas-40.patch b/desktop/gnome-shell/0001-build-with-gsettings-desktop-schemas-40.patch
new file mode 100644
index 0000000000..b82d0edc5e
--- /dev/null
+++ b/desktop/gnome-shell/0001-build-with-gsettings-desktop-schemas-40.patch
@@ -0,0 +1,15 @@
+# Force gnome-shell-41.9 to build with gsettings-desktop-schemas-40.0, even
+# though it requires 41.0. We will provide the missing lockdown schema via
+# a custom gschema.override file.
+diff -Naur gnome-shell-41.9/meson.build gnome-shell-41.9-patched/meson.build
+--- gnome-shell-41.9/meson.build 2022-11-07 22:12:51.545039805 -0600
++++ gnome-shell-41.9-patched/meson.build 2022-11-07 22:15:40.262049957 -0600
+@@ -28,7 +28,7 @@
+ gtk_req = '>= 3.15.0'
+ mutter_req = '>= 41.0'
+ polkit_req = '>= 0.100'
+-schemas_req = '>= 41.alpha'
++schemas_req = '>= 40.alpha'
+ startup_req = '>= 0.11'
+ ibus_req = '>= 1.5.19'
+ gnome_desktop_req = '>= 3.35.90'
diff --git a/desktop/gnome-shell/README b/desktop/gnome-shell/README
index 1465014d0e..0663a83136 100644
--- a/desktop/gnome-shell/README
+++ b/desktop/gnome-shell/README
@@ -3,3 +3,10 @@ desktop, like switching to windows and launching applications. GNOME
Shell takes advantage of the capabilities of modern graphics hardware
and introduces innovative user interface concepts to provide a visually
attractive and easy to use experience.
+
+Note: This build of gnome-shell includes it own gschema files from
+gsettings-desktop-schemas-41.0, which allows gnome-shell-41 to run on
+Slackware 15.0. These schema files are kept separate from Slackware's
+copy, which are at version 40.0. gnome-shell is made aware of these
+custom built schemas using a wrapper script.
+
diff --git a/desktop/gnome-shell/doinst.sh b/desktop/gnome-shell/doinst.sh
index 401d987795..7cd2b68aa3 100644
--- a/desktop/gnome-shell/doinst.sh
+++ b/desktop/gnome-shell/doinst.sh
@@ -13,3 +13,14 @@ if [ -e usr/share/glib-2.0/schemas ]; then
/usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas >/dev/null 2>&1
fi
fi
+
+# Set the gnome-shell wrapper executable:
+( cd usr/bin ; chmod 0755 gnome-shell )
+
+# Compile our custom provided schemas from gsettings-desktop-schemas-41.0:
+if [ -e usr/share/gnome-shell/gsettings-desktop-schemas/glib-2.0/schemas ]; then
+ if [ -x /usr/bin/glib-compile-schemas ]; then
+ /usr/bin/glib-compile-schemas usr/share/gnome-shell/gsettings-desktop-schemas/glib-2.0/schemas >/dev/null 2>&1
+ fi
+fi
+
diff --git a/desktop/gnome-shell/douninst.sh b/desktop/gnome-shell/douninst.sh
new file mode 100644
index 0000000000..ee92d4eb3c
--- /dev/null
+++ b/desktop/gnome-shell/douninst.sh
@@ -0,0 +1,11 @@
+# The gnome-shell doinst.sh script compiles custom gsettings-schemas
+# in the location /usr/share/gnome-shell/gsettings-desktop-schemas
+#
+# The compiled schemas will remain after package removal, so clean
+# them up:
+
+GSCHEMA_DIR="/usr/share/gnome-shell/gsettings-desktop-schemas"
+if [ -e "$GSCHEMA_DIR" ]; then
+ rm -rf "$GSCHEMA_DIR"
+fi
+
diff --git a/desktop/gnome-shell/gnome-shell.SlackBuild b/desktop/gnome-shell/gnome-shell.SlackBuild
index 81217a529f..06eb31e9e7 100644
--- a/desktop/gnome-shell/gnome-shell.SlackBuild
+++ b/desktop/gnome-shell/gnome-shell.SlackBuild
@@ -22,10 +22,18 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# NOTE: This SlackBuild also builds gsettings-desktop-schemas-41.0 and packages
+# it along with gnome-shell. This allows gnome-shell-41 to work on
+# Slackware-15.0, which comes with gsettings-desktop-schemas-40.0.
+# TO make this work we patch gnome-shell to allow it to build against
+# Slackware's gsettings-desktop-schemas-40.0. Then we install the 41.0 schemas
+# in a alternate location, compile them, and show gnome-shell where they are
+# using XDG_DATA_DIRS at runtime with a wrapper script.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gnome-shell
-VERSION=${VERSION:-40.10}
+VERSION=${VERSION:-41.9}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -67,6 +75,48 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
+
+# Variables for gsettings-desktop-schemas build:
+GDS_NAM="gsettings-desktop-schemas"
+GDS_VER="41.0"
+GDS_DATADIR="/usr/share/$PRGNAM/$GDS_NAM"
+CLEANUP=cleanup
+
+# Build gsettings-desktop-schemas-41.0:
+rm -rf $GDS_NAM-$GDS_VER
+tar xvf $CWD/$GDS_NAM-$GDS_VER.tar.xz
+cd $GDS_NAM-$GDS_VER
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir build
+cd build
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ meson .. \
+ --buildtype=release \
+ --infodir=info \
+ --includedir=$CLEANUP \
+ --libdir=$CLEANUP \
+ --datadir=$GDS_DATADIR \
+ --localedir=$CLEANUP \
+ --localstatedir=/var \
+ --mandir=man \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ -Dstrip=true
+ "${NINJA:=ninja}"
+ DESTDIR=$PKG $NINJA install
+cd ../..
+
+# Remove everything from gsettings-desktop-schemas except the gschema files:
+rm -rf $PKG/usr/$CLEANUP $PKG$GDS_DATADIR/{GConf,gir-1.0,pkgconfig}
+
+# Build gnome-shell:
tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
cd $PRGNAM-$VERSION
chown -R root:root .
@@ -76,6 +126,9 @@ find -L . -prune -name 'subprojects/gvc/.gitlab-ci' \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Patch meson.build to allow gsettings-desktop-schemas-40.0:
+patch -Np1 -i $CWD/0001-build-with-gsettings-desktop-schemas-40.patch
+
mkdir build
cd build
CFLAGS="$SLKCFLAGS" \
@@ -101,6 +154,10 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+# Install the gnome-shell wrapper script:
+mv $PKG/usr/bin/{gnome-shell,gnome-shell-bin}
+cat $CWD/gnome-shell.wrap > $PKG/usr/bin/gnome-shell
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
COPYING HACKING.md NEWS README.md \
@@ -110,6 +167,7 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
+cat $CWD/douninst.sh > $PKG/install/douninst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/desktop/gnome-shell/gnome-shell.info b/desktop/gnome-shell/gnome-shell.info
index 9779d3ba70..11d50d3abb 100644
--- a/desktop/gnome-shell/gnome-shell.info
+++ b/desktop/gnome-shell/gnome-shell.info
@@ -1,10 +1,12 @@
PRGNAM="gnome-shell"
-VERSION="40.10"
+VERSION="41.9"
HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-shell"
-DOWNLOAD="https://download.gnome.org/sources/gnome-shell/40/gnome-shell-40.10.tar.xz"
-MD5SUM="2625d20efa1bcacc4624c5fe9e474a88"
+DOWNLOAD="https://download.gnome.org/sources/gnome-shell/41/gnome-shell-41.9.tar.xz \
+https://download.gnome.org/sources/gsettings-desktop-schemas/41/gsettings-desktop-schemas-41.0.tar.xz"
+MD5SUM="abf21a9bd1b626ed082d404b43145a8a \
+1d39684b07b33d06de7be230a126ca56"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="evolution-data-server gnome-autoar gnome-bluetooth gnome-control-center mutter"
+REQUIRES="adobe-source-code-pro-font evolution-data-server gnome-autoar gnome-bluetooth gnome-control-center mutter"
MAINTAINER="Bob Funk"
EMAIL="bobfunk11@gmail.com"
diff --git a/desktop/gnome-shell/gnome-shell.wrap b/desktop/gnome-shell/gnome-shell.wrap
new file mode 100644
index 0000000000..51efe348f8
--- /dev/null
+++ b/desktop/gnome-shell/gnome-shell.wrap
@@ -0,0 +1,14 @@
+#!/bin/bash
+#
+# gnome-shell wrapper script to include a non-standard gschemas directory.
+#
+
+SYS_DATADIR=/usr/share
+ALT_DATADIR=$SYS_DATADIR/gnome-shell/gsettings-desktop-schemas
+
+# Using XDG_DATA_DIRS, since gnome-shell searches these paths for schemas (in order):
+if [ -e "$ALT_DATADIR" ]; then
+ export XDG_DATA_DIRS=$ALT_DATADIR:$SYS_DATADIR:$XDG_DATA_DIRS
+fi
+
+exec /usr/bin/gnome-shell-bin "$@"