summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Vijay Marcel2022-09-26 19:07:47 +0200
committer Willy Sudiarto Raharjo2022-10-01 04:01:12 +0200
commita3883c9d2ba8a230a5d87dc4811813b0075d0969 (patch)
tree4a462a1fc905bbae4ce29fd55118b10665023cd8
parent112edc21cf3fd32189e27669a3f30e4422efe09f (diff)
downloadslackbuilds-a3883c9d2ba8a230a5d87dc4811813b0075d0969.tar.gz
libraries/libyuv: Added (YUV Scaling Library)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/libyuv/README11
-rw-r--r--libraries/libyuv/libyuv.SlackBuild114
-rw-r--r--libraries/libyuv/libyuv.info10
-rw-r--r--libraries/libyuv/slack-desc19
4 files changed, 154 insertions, 0 deletions
diff --git a/libraries/libyuv/README b/libraries/libyuv/README
new file mode 100644
index 0000000000..1fd5d88abc
--- /dev/null
+++ b/libraries/libyuv/README
@@ -0,0 +1,11 @@
+libyuv is an open source project that includes YUV
+scaling and conversion functionality.It can be used
+to convert to YUV from webcam formats for compression.
+It can convert to RGB formats for rendering/effects.
+Rotate by 90/180/270 degrees to adjust for mobile
+devices in portrait mode.
+
+Note:
+We are downloading from Debian because googlesource
+keeps modifying its md5sum everytime resulting in
+md5sum error.
diff --git a/libraries/libyuv/libyuv.SlackBuild b/libraries/libyuv/libyuv.SlackBuild
new file mode 100644
index 0000000000..e3cdabc767
--- /dev/null
+++ b/libraries/libyuv/libyuv.SlackBuild
@@ -0,0 +1,114 @@
+#!/bin/bash
+
+# Slackware build script for libyuv
+
+# Copyright 2022 Vijay Marcel
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=libyuv
+VERSION=${VERSION:-20220925_84d76f9}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+GITNAM=${GITNAM:-84d76f9b4ef15b282b0b62a3d73f7ab1b7f41f7e}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+trap 'echo "$0 FAILED at line $LINENO!" | tee $OUTPUT/error-${PRGNAM}.log' ERR
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+rm -rf $PRGNAM-$GITNAM
+tar xvf $CWD/$PRGNAM-$GITNAM.tar.gz
+cd $PRGNAM-$GITNAM
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+if [ "$ARCH" = "x86_64" ]; then
+ sed -i 's+DESTINATION lib+DESTINATION lib64+g' $TMP/$PRGNAM-$GITNAM/CMakeLists.txt
+fi
+
+cmake -B build -S $TMP/$PRGNAM-$GITNAM \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR:PATH=/usr/lib${LIBDIRSUFFIX} \
+ -DCMAKE_INSTALL_BINDIR:PATH=/usr/bin \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
+ -DCMAKE_BUILD_TYPE=Release
+
+make -C build
+make -C build install DESTDIR=$PKG
+
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS DEPS LICENSE OWNERS PATENTS README.md README.chromium docs/* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/libyuv/libyuv.info b/libraries/libyuv/libyuv.info
new file mode 100644
index 0000000000..4d39bef24b
--- /dev/null
+++ b/libraries/libyuv/libyuv.info
@@ -0,0 +1,10 @@
+PRGNAM="libyuv"
+VERSION="20220925_84d76f9"
+HOMEPAGE="https://chromium.googlesource.com/libyuv/libyuv/"
+DOWNLOAD="https://salsa.debian.org/debian/libyuv/-/archive/84d76f9b4ef15b282b0b62a3d73f7ab1b7f41f7e/libyuv-84d76f9b4ef15b282b0b62a3d73f7ab1b7f41f7e.tar.gz"
+MD5SUM="95aca9b8e2b7ff5e984b36dec98efb44"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Vijay Marcel"
+EMAIL="vijaymarcel@outlook.com"
diff --git a/libraries/libyuv/slack-desc b/libraries/libyuv/slack-desc
new file mode 100644
index 0000000000..d66c6713c1
--- /dev/null
+++ b/libraries/libyuv/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+libyuv: libyuv (YUV Scaling Library)
+libyuv:
+libyuv: libyuv is an open source project that includes YUV
+libyuv: scaling and conversion functionality.It can be used
+libyuv: to convert to YUV from webcam formats for compression.
+libyuv:
+libyuv: Homepage:https://chromium.googlesource.com/libyuv/libyuv/
+libyuv:
+libyuv:
+libyuv:
+libyuv: