summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo2024-03-31 19:33:40 +0200
committer Willy Sudiarto Raharjo2024-04-05 10:18:09 +0200
commita38020a4ee371629bddb467176a96a874d22b178 (patch)
tree63f11e4e6470ad29ec6ec574fe2db3e1e7ee6ff4
parentfb2073f3f71a127b49ce984358748d3c1cb8ca29 (diff)
downloadslackbuilds-a38020a4ee371629bddb467176a96a874d22b178.tar.gz
development/codespell: Fix PYTHONPATH.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/codespell/codespell.SlackBuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/development/codespell/codespell.SlackBuild b/development/codespell/codespell.SlackBuild
index 0c9ca40879..74ec393dc3 100644
--- a/development/codespell/codespell.SlackBuild
+++ b/development/codespell/codespell.SlackBuild
@@ -58,7 +58,8 @@ find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
# write_to directive is broken, turns out we can do without it.
sed -i '/^write_to/d' pyproject.toml
-export PYTHONPATH=/opt/python3.9/site-packages/
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl