summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2024-03-16 15:28:52 +0100
committer Willy Sudiarto Raharjo2024-03-21 14:19:10 +0100
commit593954e1ecc99ee6530d069fac30d991a040c497 (patch)
treef8258464021d5eff981a8e72e2b1c4501632f15b
parent4920d12c38f40d0e03fdb7649a84ec91a9e5d432 (diff)
downloadslackbuilds-593954e1ecc99ee6530d069fac30d991a040c497.tar.gz
development/protobuf3: Updated for version 26.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/protobuf3/protobuf-21.12-pep517.patch16
-rw-r--r--development/protobuf3/protobuf3.SlackBuild22
-rw-r--r--development/protobuf3/protobuf3.info8
-rw-r--r--development/protobuf3/protobuf3.patch10
4 files changed, 14 insertions, 42 deletions
diff --git a/development/protobuf3/protobuf-21.12-pep517.patch b/development/protobuf3/protobuf-21.12-pep517.patch
deleted file mode 100644
index 51f3f67006..0000000000
--- a/development/protobuf3/protobuf-21.12-pep517.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -ruN a/python/setup.py b/python/setup.py
---- a/python/setup.py 2022-12-13 01:03:12.000000000 +0100
-+++ b/python/setup.py 2023-04-06 22:12:36.199029178 +0200
-@@ -220,10 +220,10 @@
- return False
-
-
--if __name__ == '__main__':
-+if True:
- ext_module_list = []
- warnings_as_errors = '--warnings_as_errors'
-- if GetOptionFromArgv('--cpp_implementation'):
-+ if True:
- # Link libprotobuf.a and libprotobuf-lite.a statically with the
- # extension. Note that those libraries have to be compiled with
- # -fPIC for this to work.
diff --git a/development/protobuf3/protobuf3.SlackBuild b/development/protobuf3/protobuf3.SlackBuild
index 6d7c993407..83a5c11db3 100644
--- a/development/protobuf3/protobuf3.SlackBuild
+++ b/development/protobuf3/protobuf3.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for protobuf3
-# Copyright 2017-2022 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2017-2024 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=protobuf3
-VERSION=${VERSION:-25.3}
+VERSION=${VERSION:-26.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -81,10 +81,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 < $CWD/protobuf3.patch
-patch -p1 < $CWD/protobuf-21.12-pep517.patch
patch -p1 < $CWD/soversion.patch
-sed -e "s|c++14|c++17|" -i python/setup.py
mkdir -p build
cd build
@@ -101,13 +98,14 @@ cd build
make install/strip DESTDIR=$PKG
cd ..
-# Install the python bindings
-cd python
-LDFLAGS+=" -L$TMP/$SRCNAM-$VERSION/build" \
-PROTOC="$TMP/$SRCNAM-$VERSION/build/protoc" \
-python3 -m build --wheel --no-isolation
-python3 -m installer --destdir "$PKG" dist/*.whl
-cd ..
+# Install the python bindings:
+#cd python
+#cp -a dist/setup.py .
+#LDFLAGS+=" -L$TMP/$SRCNAM-$VERSION/build" \
+#PROTOC="$TMP/$SRCNAM-$VERSION/build/protoc" \
+#python3 -m build --wheel --no-isolation
+#python3 -m installer --destdir "$PKG" dist/*.whl
+#cd ..
rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/*.la
diff --git a/development/protobuf3/protobuf3.info b/development/protobuf3/protobuf3.info
index f308e8c863..e95b86e019 100644
--- a/development/protobuf3/protobuf3.info
+++ b/development/protobuf3/protobuf3.info
@@ -1,10 +1,10 @@
PRGNAM="protobuf3"
-VERSION="25.3"
+VERSION="26.0"
HOMEPAGE="https://github.com/google/protobuf"
-DOWNLOAD="https://github.com/google/protobuf/archive/v25.3/protobuf-25.3.tar.gz"
-MD5SUM="5e82b6696d6bcacc2e60313f187f3551"
+DOWNLOAD="https://github.com/google/protobuf/archive/v26.0/protobuf-26.0.tar.gz"
+MD5SUM="44068557aabb2b774a29260740bbccc4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="abseil-cpp python3-build python3-wheel"
+REQUIRES="abseil-cpp"
MAINTAINER="Willy Sudiarto Raharjo"
EMAIL="willysr@slackbuilds.org"
diff --git a/development/protobuf3/protobuf3.patch b/development/protobuf3/protobuf3.patch
deleted file mode 100644
index a69862dd63..0000000000
--- a/development/protobuf3/protobuf3.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- protobuf-3.10.1/src/google/protobuf/text_format.h.orig 2019-10-13 10:42:21.345593616 +0700
-+++ protobuf-3.10.1/src/google/protobuf/text_format.h 2019-10-13 10:42:34.151188015 +0700
-@@ -42,6 +42,7 @@
- #include <memory>
- #include <string>
- #include <vector>
-+#include <cmath>
-
- #include <google/protobuf/stubs/common.h>
- #include <google/protobuf/descriptor.h>