summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Steven Voges2022-09-30 22:37:49 +0200
committer Willy Sudiarto Raharjo2022-10-01 04:01:15 +0200
commit9e8dcb64cba15b3e6e3cbea1395229b17989c313 (patch)
treedfa31d8b671a718f462592e99cc7c36003554881
parentba8f3f0bdba402b73fecf15f30b537bcdbf69d89 (diff)
downloadslackbuilds-9e8dcb64cba15b3e6e3cbea1395229b17989c313.tar.gz
games/rpcs3: Added (Playstation 3 Emulator)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--games/rpcs3/README7
-rw-r--r--games/rpcs3/doinst.sh9
-rw-r--r--games/rpcs3/rpcs3.SlackBuild159
-rw-r--r--games/rpcs3/rpcs3.info34
-rw-r--r--games/rpcs3/slack-desc19
5 files changed, 228 insertions, 0 deletions
diff --git a/games/rpcs3/README b/games/rpcs3/README
new file mode 100644
index 0000000000..a2e2db0978
--- /dev/null
+++ b/games/rpcs3/README
@@ -0,0 +1,7 @@
+The world's first free and open-source PlayStation 3 emulator/debugger,
+written in C++ for Windows, Linux, macOS and FreeBSD.
+
+You can find some basic information on our website. Game info is being
+populated on the Wiki. For discussion about this emulator, PS3
+emulation, and game compatibility reports, please visit our forums and
+our Discord server.
diff --git a/games/rpcs3/doinst.sh b/games/rpcs3/doinst.sh
new file mode 100644
index 0000000000..65c7e2eeb9
--- /dev/null
+++ b/games/rpcs3/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/games/rpcs3/rpcs3.SlackBuild b/games/rpcs3/rpcs3.SlackBuild
new file mode 100644
index 0000000000..5370c82f60
--- /dev/null
+++ b/games/rpcs3/rpcs3.SlackBuild
@@ -0,0 +1,159 @@
+#!/bin/bash
+
+# Slackware build script for rpcs3
+
+# Copyright 2022 Steven Voges <Oregon, USA>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=rpcs3
+VERSION=${VERSION:-0.0.24}
+ASMJIT=${ASMJIT:-06d0badec53710a4f572cf5642881ce570c5d274}
+CUBEB=${CUBEB:-dc511c6b3597b6384d28949285b9289e009830ea}
+FLATBUFFERS=${FLATBUFFERS:-615616cb5549a34bdf288c04bc1b94bd7a65c396}
+GLSLANG=${GLSLANG:-adbf0d3106b26daa237b10b9bf72b1af7c31092d}
+HIDAPI=${HIDAPI:-c2aa9dd37c7b401b918fd56e18a3bac7f8f00ec2}
+ITTAPI=${ITTAPI:-3.18.12}
+LLVM=${LLVM:-5521155be5c869b0b760e1dec86c41cdbb7a75c0}
+SOUNDTOUCH=${SOUNDTOUCH:-83cfba67b6af80bb9bfafc0b324718c4841f2991}
+SPIRVHEADERS=${SPIRVHEADERS:-4995a2f2723c401eb0ea3e10c81298906bf1422b}
+SPIRVTOOLS=${SPIRVTOOLS:-7826e1941eab1aa66fbe84c48b95921bff402a96}
+WOLFSSL=${WOLFSSL:-57aac1c50b45275c7a99eca32ad985998b292dc8}
+YAMLCPP=${YAMLCPP:-0b67821f307e8c6bf0eba9b6d3250e3cf1441450}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+DEPS=$TMP/$PRGNAM-$VERSION/3rdparty
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+mkdir -p $TMP/$PRGNAM-$VERSION/build/3rdparty/llvm_build/ittapi
+tar xvf $CWD/SPIRV-Headers-$SPIRVHEADERS.tar.gz -C \
+ $DEPS/SPIRV/SPIRV-Headers --strip-components 1
+tar xvf $CWD/SPIRV-Tools-$SPIRVTOOLS.tar.gz -C \
+ $DEPS/SPIRV/SPIRV-Tools --strip-components 1
+tar xvf $CWD/asmjit-$ASMJIT.tar.gz -C \
+ $DEPS/asmjit/asmjit --strip-components 1
+tar xvf $CWD/cubeb-$CUBEB.tar.gz -C \
+ $DEPS/cubeb/cubeb --strip-components 1
+tar xvf $CWD/flatbuffers-$FLATBUFFERS.tar.gz -C \
+ $DEPS/flatbuffers --strip-components 1
+tar xvf $CWD/glslang-$GLSLANG.tar.gz -C \
+ $DEPS/glslang/glslang --strip-components 1
+tar xvf $CWD/hidapi-$HIDAPI.tar.gz -C \
+ $DEPS/hidapi/hidapi --strip-components 1
+tar xvf $CWD/ittapi-$ITTAPI.tar.gz -C \
+ $TMP/$PRGNAM-$VERSION/build/3rdparty/llvm_build/ittapi --strip-components 1
+tar xvf $CWD/llvm-mirror-$LLVM.tar.gz -C \
+ $DEPS/../llvm --strip-components 1
+tar xvf $CWD/soundtouch-$SOUNDTOUCH.tar.gz -C \
+ $DEPS/SoundTouch/soundtouch --strip-components 1
+tar xvf $CWD/wolfssl-$WOLFSSL.tar.gz -C \
+ $DEPS/wolfssl/wolfssl --strip-components 1
+tar xvf $CWD/yaml-cpp-$YAMLCPP.tar.gz -C \
+ $DEPS/yaml-cpp/yaml-cpp --strip-components 1
+
+#Bypass git checkout check for ittapi
+sed -i 's/if(NOT GIT_CHECKOUT_RESULT EQUAL "0")/if(GIT_CHECKOUT_RESULT EQUAL "0")/g' \
+ llvm/lib/ExecutionEngine/IntelJITEvents/CMakeLists.txt
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+cd build
+ cmake \
+ -Wno-dev \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_SYSTEM_CURL=ON \
+ -DUSE_SYSTEM_FAUDIO=ON \
+ -DUSE_SYSTEM_FFMPEG=ON \
+ -DUSE_SYSTEM_FLATBUFFERS=OFF \
+ -DUSE_SYSTEM_LIBPNG=ON \
+ -DUSE_SYSTEM_LIBUSB=ON \
+ -DUSE_SYSTEM_PUGIXML=ON \
+ -DUSE_SYSTEM_XXHASH=ON \
+ -DUSE_SYSTEM_ZLIB=ON \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install/strip DESTDIR=$PKG
+cd ..
+
+rm -r $PKG/usr/share/$PRGNAM/git
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/games/rpcs3/rpcs3.info b/games/rpcs3/rpcs3.info
new file mode 100644
index 0000000000..3437b13018
--- /dev/null
+++ b/games/rpcs3/rpcs3.info
@@ -0,0 +1,34 @@
+PRGNAM="rpcs3"
+VERSION="0.0.24"
+HOMEPAGE="https://rpcs3.net"
+DOWNLOAD="UNSUPPORTED"
+MD5SUM=""
+DOWNLOAD_x86_64="https://github.com/RPCS3/rpcs3/archive/v0.0.24/rpcs3-0.0.24.tar.gz \
+ https://github.com/KhronosGroup/SPIRV-Headers/archive/4995a2f2723c401eb0ea3e10c81298906bf1422b/SPIRV-Headers-4995a2f2723c401eb0ea3e10c81298906bf1422b.tar.gz \
+ https://github.com/KhronosGroup/SPIRV-Tools/archive/7826e1941eab1aa66fbe84c48b95921bff402a96/SPIRV-Tools-7826e1941eab1aa66fbe84c48b95921bff402a96.tar.gz \
+ https://github.com/RPCS3/asmjit/archive/06d0badec53710a4f572cf5642881ce570c5d274/asmjit-06d0badec53710a4f572cf5642881ce570c5d274.tar.gz \
+ https://github.com/mozilla/cubeb/archive/dc511c6b3597b6384d28949285b9289e009830ea/cubeb-dc511c6b3597b6384d28949285b9289e009830ea.tar.gz \
+ https://github.com/google/flatbuffers/archive/615616cb5549a34bdf288c04bc1b94bd7a65c396/flatbuffers-615616cb5549a34bdf288c04bc1b94bd7a65c396.tar.gz \
+ https://github.com/KhronosGroup/glslang/archive/adbf0d3106b26daa237b10b9bf72b1af7c31092d/glslang-adbf0d3106b26daa237b10b9bf72b1af7c31092d.tar.gz \
+ https://github.com/RPCS3/hidapi/archive/c2aa9dd37c7b401b918fd56e18a3bac7f8f00ec2/hidapi-c2aa9dd37c7b401b918fd56e18a3bac7f8f00ec2.tar.gz \
+ https://github.com/intel/ittapi/archive/v3.18.12/ittapi-3.18.12.tar.gz \
+ https://github.com/RPCS3/llvm-mirror/archive/5521155be5c869b0b760e1dec86c41cdbb7a75c0/llvm-mirror-5521155be5c869b0b760e1dec86c41cdbb7a75c0.tar.gz \
+ https://github.com/RPCS3/soundtouch/archive/83cfba67b6af80bb9bfafc0b324718c4841f2991/soundtouch-83cfba67b6af80bb9bfafc0b324718c4841f2991.tar.gz \
+ https://github.com/wolfSSL/wolfssl/archive/57aac1c50b45275c7a99eca32ad985998b292dc8/wolfssl-57aac1c50b45275c7a99eca32ad985998b292dc8.tar.gz \
+ https://github.com/RPCS3/yaml-cpp/archive/0b67821f307e8c6bf0eba9b6d3250e3cf1441450/yaml-cpp-0b67821f307e8c6bf0eba9b6d3250e3cf1441450.tar.gz"
+MD5SUM_x86_64="98833dfa6ca8172ffc907be802d3fadc \
+ eabedbd09c8726eccbd33a5a3799c18b \
+ d43ba9484fc29a71c2b2c0e25aecd9b6 \
+ 26455042d0e12b9b4eff611f0767e42e \
+ 5a40e81e1d6b2438c9b618ffcb679430 \
+ 2a6aa61ab2a1502ba1a8d0730d517d13 \
+ f44790bada6e41a57342da30a202e73e \
+ 473c53621d2877e9feef95a0ab617fb3 \
+ 4a5eee8a589fa777f4a6017ab1e6f602 \
+ 8f3b19e15c945229dd9970ee5a834803 \
+ a6e4341748f10956754201939b9936e4 \
+ 1f685fa247737136d31b029870a2b25c \
+ 4ff126bd4f429b86da943a77805dfec8"
+REQUIRES="FAudio pugixml"
+MAINTAINER="Steven Voges"
+EMAIL="svoges.sbo@gmail.com"
diff --git a/games/rpcs3/slack-desc b/games/rpcs3/slack-desc
new file mode 100644
index 0000000000..79070f7342
--- /dev/null
+++ b/games/rpcs3/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+rpcs3: rpcs3 (Playstation 3 Emulator)
+rpcs3:
+rpcs3: PS3 emulator/debugger
+rpcs3:
+rpcs3: Homepage: https://rpcs3.net
+rpcs3:
+rpcs3:
+rpcs3:
+rpcs3:
+rpcs3:
+rpcs3: