summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andrew Clemons2024-03-21 12:52:08 +0100
committer Willy Sudiarto Raharjo2024-03-23 02:17:02 +0100
commit038e42891573f3948e5f5c312d807d784e449fb6 (patch)
tree9fa31b9d5e81bc0bb5c49dc324d70a636ff932d9
parent500c10c29a7bd7d7204a5b323619a81ff44b82e3 (diff)
downloadslackbuilds-038e42891573f3948e5f5c312d807d784e449fb6.tar.gz
python/rfc6555: Use python2 for python 2.x.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/rfc6555/rfc6555.SlackBuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/python/rfc6555/rfc6555.SlackBuild b/python/rfc6555/rfc6555.SlackBuild
index f8a73cbda3..8f04d124dd 100644
--- a/python/rfc6555/rfc6555.SlackBuild
+++ b/python/rfc6555/rfc6555.SlackBuild
@@ -2,7 +2,8 @@
# Slackware build script for rfc6555
-# Copyright 2020-2021 Andrew Clemons, Wellingotn New Zealand
+# Copyright 2020-2021 Andrew Clemons, Wellington New Zealand
+# Copyright 2024 Andrew Clemons, Tokyo Japan
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=rfc6555
VERSION=${VERSION:-0.1.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -65,7 +63,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION