summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Steven Voges2022-09-30 22:50:55 +0200
committer Willy Sudiarto Raharjo2022-10-01 04:01:15 +0200
commit3b5c91d18a154692e3ef1cb98cd39acd1fc9bd12 (patch)
tree46925134a9ffbb3ee117543849b6ecc007ccf193
parent712728415adb9e07b703ac20b66cfd60102e9644 (diff)
downloadslackbuilds-3b5c91d18a154692e3ef1cb98cd39acd1fc9bd12.tar.gz
libraries/gtksourceview5: Added (GTK+ framework for editing source)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/gtksourceview5/README33
-rw-r--r--libraries/gtksourceview5/doinst.sh5
-rw-r--r--libraries/gtksourceview5/gtksourceview5.SlackBuild119
-rw-r--r--libraries/gtksourceview5/gtksourceview5.info10
-rw-r--r--libraries/gtksourceview5/slack-desc19
5 files changed, 186 insertions, 0 deletions
diff --git a/libraries/gtksourceview5/README b/libraries/gtksourceview5/README
new file mode 100644
index 0000000000..df1d59e64b
--- /dev/null
+++ b/libraries/gtksourceview5/README
@@ -0,0 +1,33 @@
+GtkSourceView is a GNOME library that extends GtkTextView, the
+standard GTK+ widget for multiline text editing. GtkSourceView adds
+support for syntax highlighting, undo/redo, file loading and saving,
+search and replace, a completion system, printing, displaying line
+numbers, and other features typical of a source code editor.
+
+Features:
+ * Accurate syntax highlighting for most popular programming languages
+ (C, C++, Java, C#, Fortran, etc.), scripting languages (sh, Python,
+ Perl, Ruby, PHP, TCL, etc.), markup languages (XML, HTML, DocBook,
+ LaTeX, etc.) and many others
+ * Customizable visual style using style schemes
+ * Unlimited Undo/Redo
+ * File loading and saving
+ * Extensible completion framework
+ * Search and replace, with regex support
+ * Line numbers
+ * Line marks (useful for bookmarks, breakpoints, etc.)
+ * Printing through easy integration with the GtkPrintOperation API
+ * Highlight the current line
+ * Highlight the matching bracket
+ * Right margin
+ * Represent whitespace characters with symbols
+ * A minimap, which shows an overview of the text
+ * Extended keyboard navigation (smart Home/End, smart backspace,
+ auto indentation, line moving, etc.)
+ * Can be used from many programming languages. Thanks to GObject
+ Introspection, automatic bindings are available for JavaScript,
+ Python, Vala and others. For C++, there is gtksourceviewmm
+
+If you would like to build the HTML documentation, pass DOCS=true
+to the build script. This introduces dependencies on gi-docgen and
+python-toml.
diff --git a/libraries/gtksourceview5/doinst.sh b/libraries/gtksourceview5/doinst.sh
new file mode 100644
index 0000000000..4110f5514d
--- /dev/null
+++ b/libraries/gtksourceview5/doinst.sh
@@ -0,0 +1,5 @@
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/libraries/gtksourceview5/gtksourceview5.SlackBuild b/libraries/gtksourceview5/gtksourceview5.SlackBuild
new file mode 100644
index 0000000000..ca694aa958
--- /dev/null
+++ b/libraries/gtksourceview5/gtksourceview5.SlackBuild
@@ -0,0 +1,119 @@
+#!/bin/bash
+
+# Slackware build script for gtksourceview5
+
+# Copyright 2022 Steven Voges <Oregon, USA>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=gtksourceview5
+SRCNAM=gtksourceview
+VERSION=${VERSION:-5.4.2}
+DOCS=${DOCS:-false}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.xz
+cd $SRCNAM-$VERSION
+sed -i "s/gtk_req_version = '4.5'/gtk_req_version = '4.4'/g" meson.build
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir build
+cd build
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ meson .. \
+ --buildtype=release \
+ --infodir=/usr/info \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ -Dgtk_doc=$DOCS \
+ -Dstrip=true
+ "${NINJA:=ninja}"
+ DESTDIR=$PKG $NINJA install
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS COPYING HACKING NEWS README.md docs/*.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+if [ "$DOCS" = "true" ]; then
+ mv $PKG/usr/share/doc/$PRGNAM $PKG/usr/doc/$PRGNAM-$VERSION/html
+ rmdir $PKG/usr/share/doc
+fi
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/gtksourceview5/gtksourceview5.info b/libraries/gtksourceview5/gtksourceview5.info
new file mode 100644
index 0000000000..58cd3fd2a9
--- /dev/null
+++ b/libraries/gtksourceview5/gtksourceview5.info
@@ -0,0 +1,10 @@
+PRGNAM="gtksourceview5"
+VERSION="5.4.2"
+HOMEPAGE="https://wiki.gnome.org/Projects/GtkSourceView"
+DOWNLOAD="https://download.gnome.org/sources/gtksourceview/5.4/gtksourceview-5.4.2.tar.xz"
+MD5SUM="f0cba1f8f0552cb98f0b247bea3b1651"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Steven Voges"
+EMAIL="svoges.sbo@gmail.com"
diff --git a/libraries/gtksourceview5/slack-desc b/libraries/gtksourceview5/slack-desc
new file mode 100644
index 0000000000..69e0f1ed98
--- /dev/null
+++ b/libraries/gtksourceview5/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+gtksourceview5: gtksourceview5 (GTK+ framework for source code editing)
+gtksourceview5:
+gtksourceview5: GtkSourceView is a GNOME library that extends GtkTextView, the
+gtksourceview5: standard GTK+ widget for multiline text editing. GtkSourceView adds
+gtksourceview5: support for syntax highlighting, undo/redo, file loading and saving,
+gtksourceview5: search and replace, a completion system, printing, displaying line
+gtksourceview5: numbers, and other features typical of a source code editor.
+gtksourceview5:
+gtksourceview5: Homepage: https://wiki.gnome.org/Projects/GtkSourceView
+gtksourceview5:
+gtksourceview5: