summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu2022-09-26 21:44:55 +0200
committer Willy Sudiarto Raharjo2022-10-01 04:01:19 +0200
commit1d28f5ff9ee4cdcbf895361ac7bb0b1d18118a0b (patch)
treeb48e7419c32275f07dc233db944540e344257bf4
parente231187b4288383aae5662fa766a15111fed48bc (diff)
downloadslackbuilds-1d28f5ff9ee4cdcbf895361ac7bb0b1d18118a0b.tar.gz
development/jupyter_client: Change build to python3-hatchling.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/jupyter_client/jupyter_client.SlackBuild29
-rw-r--r--development/jupyter_client/jupyter_client.info2
2 files changed, 5 insertions, 26 deletions
diff --git a/development/jupyter_client/jupyter_client.SlackBuild b/development/jupyter_client/jupyter_client.SlackBuild
index 2784ae88d6..9cbd250a83 100644
--- a/development/jupyter_client/jupyter_client.SlackBuild
+++ b/development/jupyter_client/jupyter_client.SlackBuild
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jupyter_client
VERSION=${VERSION:-7.3.5}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,35 +80,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Use this setup.py shim:
-cat << EOF > setup.py
-from setuptools import setup, find_packages
-setup(name='${PRGNAM}',
- version='${VERSION}',
- packages=find_packages(exclude=["docs", "docs.*", "tests", "tests.*"]),
- package_data={'': ['*']},
- entry_points={
- 'console_scripts': [
- 'jupyter-kernelspec = jupyter_client.kernelspecapp:KernelSpecApp.launch_instance',
- 'jupyter-run = jupyter_client.runapp:RunApp.launch_instance',
- 'jupyter-kernel = jupyter_client.kernelapp:main',
- ],
- 'jupyter_client.kernel_provisioners': [
- 'local-provisioner = jupyter_client.provisioning:LocalProvisioner',
- ],
- },
-)
-EOF
-
-# With the shim, it's a good idea to use "unshare -n" to prevent downloading
-# anything extra:
-unshare -n python3 setup.py install --root=$PKG || exit 1
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.md CONTRIBUTING.md README.md RELEASING.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/development/jupyter_client/jupyter_client.info b/development/jupyter_client/jupyter_client.info
index d7e68286cf..eab0595e34 100644
--- a/development/jupyter_client/jupyter_client.info
+++ b/development/jupyter_client/jupyter_client.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/jupyter/jupyter_client/archive/v7.3.5/jupyter_clien
MD5SUM="b1b69ffa692ea6e7ae2eacd0b2a6bd51"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="entrypoints jupyter_core nest_asyncio python3-dateutil python3-pyzmq python3-tornado"
+REQUIRES="entrypoints jupyter_core nest_asyncio python3-dateutil python3-pyzmq python3-tornado python3-hatchling"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu1@isaacyu1.com"