summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Lockywolf2024-04-25 11:47:52 +0200
committer Willy Sudiarto Raharjo2024-04-25 17:25:59 +0200
commit7cb6e8f3c2ca875fade4b5b7947fd73082107f54 (patch)
treeaf0e5c63d948f5981f5dab997d3e83b73f51016c
parent450631cc32bef736cafe23ad4c7cff1888918528 (diff)
downloadslackbuilds-7cb6e8f3c2ca875fade4b5b7947fd73082107f54.tar.gz
python/python3-bsdiff4: Added (binary diffs).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-bsdiff4/README12
-rw-r--r--python/python3-bsdiff4/python3-bsdiff4.SlackBuild102
-rw-r--r--python/python3-bsdiff4/python3-bsdiff4.info10
-rw-r--r--python/python3-bsdiff4/slack-desc19
4 files changed, 143 insertions, 0 deletions
diff --git a/python/python3-bsdiff4/README b/python/python3-bsdiff4/README
new file mode 100644
index 0000000000..88ff0ba161
--- /dev/null
+++ b/python/python3-bsdiff4/README
@@ -0,0 +1,12 @@
+binary diff and patch using the BSDIFF4-format
+
+The code is mostly derived from cx_bsdiff (written by Anthony
+Tuininga, http://cx-bsdiff.sourceforge.net/). The cx_bsdiff code in
+turn was derived from bsdiff, the standalone utility produced for BSD
+which can be found at http://www.daemonology.net/bsdiff. In addition
+to the two functions (diff and patch) cx_bsdiff provides, this package
+includes:
+
+an interface to the BSDIFF4-format
+
+command line interfaces: bsdiff4 and bspatch4
diff --git a/python/python3-bsdiff4/python3-bsdiff4.SlackBuild b/python/python3-bsdiff4/python3-bsdiff4.SlackBuild
new file mode 100644
index 0000000000..749f2e7e39
--- /dev/null
+++ b/python/python3-bsdiff4/python3-bsdiff4.SlackBuild
@@ -0,0 +1,102 @@
+#!/bin/bash
+
+# Slackware build script for python3-bsdiff4
+
+# Copyright 2024, Lockywolf
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-bsdiff4
+VERSION=${VERSION:-1.2.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+TGZNAM=bsdiff4
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $TGZNAM-$VERSION
+tar xvf $CWD/$TGZNAM-$VERSION.tar.gz
+cd $TGZNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-bsdiff4/python3-bsdiff4.info b/python/python3-bsdiff4/python3-bsdiff4.info
new file mode 100644
index 0000000000..c031fc66f7
--- /dev/null
+++ b/python/python3-bsdiff4/python3-bsdiff4.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-bsdiff4"
+VERSION="1.2.4"
+HOMEPAGE="https://pypi.org/project/bsdiff4/"
+DOWNLOAD="https://files.pythonhosted.org/packages/58/b2/ccf01309dda2c08e0600027bc0f5a99534c91f2f8728b5009fc363df6c2c/bsdiff4-1.2.4.tar.gz"
+MD5SUM="ebc06d059f3c4ed4c4a5b952f55ae239"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Lockywolf"
+EMAIL="for_sbo.python3-bsdiff4_2024-04-32@lockywolf.net"
diff --git a/python/python3-bsdiff4/slack-desc b/python/python3-bsdiff4/slack-desc
new file mode 100644
index 0000000000..24299a8e27
--- /dev/null
+++ b/python/python3-bsdiff4/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-bsdiff4: python3-bsdiff4 (binary diff and patch using the BSDIFF4-format)
+python3-bsdiff4:
+python3-bsdiff4: Python binding for bsdiff4.
+python3-bsdiff4:
+python3-bsdiff4:
+python3-bsdiff4:
+python3-bsdiff4:
+python3-bsdiff4:
+python3-bsdiff4:
+python3-bsdiff4:
+python3-bsdiff4: