summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2021-11-26 22:39:43 +0100
committer Willy Sudiarto Raharjo2021-12-04 04:09:02 +0100
commitece05c0dbacce4ca6e8b31ad6770ce9fd4414c6a (patch)
tree9cfed394d5f93d5416092a1590840c8d747edac6
parent50af7ff3b2f9e5c94f2286b3ce6f56260172aab2 (diff)
downloadslackbuilds-ece05c0dbacce4ca6e8b31ad6770ce9fd4414c6a.tar.gz
network/transmission-qt4: Removed (outdated).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--network/transmission-qt4/README10
-rw-r--r--network/transmission-qt4/doinst.sh13
-rw-r--r--network/transmission-qt4/slack-desc19
-rw-r--r--network/transmission-qt4/transmission-qt4.SlackBuild157
-rw-r--r--network/transmission-qt4/transmission-qt4.info10
5 files changed, 0 insertions, 209 deletions
diff --git a/network/transmission-qt4/README b/network/transmission-qt4/README
deleted file mode 100644
index 2fdfaa20f7..0000000000
--- a/network/transmission-qt4/README
+++ /dev/null
@@ -1,10 +0,0 @@
-transmission-qt4 (bittorrent client)
-
-Transmission is a lightweight open source BitTorrent client, providing
-useful functionality without feature bloat. It consists of a daemon, a
-GTK+, Qt and CLI client.
-
-This is an older release of transmission, and only the Qt4 client is
-provided. For the rest of the components (the GTK+ client, the daemon,
-and the command-line client), install the main transmission package.
-It's safe to install both transmission and transmission-qt4.
diff --git a/network/transmission-qt4/doinst.sh b/network/transmission-qt4/doinst.sh
deleted file mode 100644
index 19ad22754d..0000000000
--- a/network/transmission-qt4/doinst.sh
+++ /dev/null
@@ -1,13 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications
-fi
-
-if [ -x /usr/bin/update-mime-database ]; then
- /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
-fi
-
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
- fi
-fi
diff --git a/network/transmission-qt4/slack-desc b/network/transmission-qt4/slack-desc
deleted file mode 100644
index 5dca7159e2..0000000000
--- a/network/transmission-qt4/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-transmission-qt4: transmission-qt4 (bittorrent client)
-transmission-qt4:
-transmission-qt4: Transmission is a lightweight open source BitTorrent client,
-transmission-qt4: providing useful functionality without feature bloat.
-transmission-qt4: It consists of a daemon, a GTK+, Qt and CLI client.
-transmission-qt4:
-transmission-qt4: This is an older release of transmission. Only the Qt4 client is
-transmission-qt4: provided.
-transmission-qt4:
-transmission-qt4: Homepage: http://transmissionbt.com/
-transmission-qt4:
diff --git a/network/transmission-qt4/transmission-qt4.SlackBuild b/network/transmission-qt4/transmission-qt4.SlackBuild
deleted file mode 100644
index 7769893920..0000000000
--- a/network/transmission-qt4/transmission-qt4.SlackBuild
+++ /dev/null
@@ -1,157 +0,0 @@
-#!/bin/bash
-# Slackware build script for transmission
-
-# Copyright 2007 Vasilis Papavasileiou <email removed>
-# Copyright 2008-2011 Iskar Enev <email removed>
-# Copyright 2011-2013 Niels Horn, Rio de Janeiro, Brazil
-# Copyright 2015 B. Watson <yalhcru@gmail.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# 20200525 bkw: new build, forked from the previous
-# transmission.SlackBuild. This will go away when Slack 15 releases.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=transmission-qt4
-VERSION=${VERSION:-2.94}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-SRCNAM=transmission
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-DOCS="AUTHORS COPYING INSTALL NEWS README"
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-mkdir -p $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.xz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-
-sed -i -e 's%-g -O3 -funroll-loops %%g' configure.ac
-sed -i -e 's%-ggdb3 %%g' configure.ac
-
-# fix for -current (does no harm on stable). ref:
-# https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c13b5e88c6e9c7bd2698d844cb5ed127ed809f7e
-rm -f m4/glib-gettext.m4
-
-# Thanks Larry Hajali
-autoreconf -ivf
-
-CC=gcc CXX=g++ \
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --disable-static \
- --verbose \
- --with-gtk=no \
- --disable-cli \
- --disable-daemon \
- --build=$ARCH-slackware-linux \
- --host=$ARCH-slackware-linux
-
-# build libraries (but don't install them). this also wastefully builds
-# the tools, which we aren't going to install.
-make
-
-# build and install the Qt client
-# Fix hard-coded path of man file of Qt client
-sed -i "s|share/man/|man/|" qt/qtr.pro
-
-# Needed when using Qt4
-# https://trac.transmissionbt.com/ticket/5700#comment:2
-echo "QMAKE_CXXFLAGS += -std=c++11" >> qt/qtr.pro
-
-cd qt
- qmake \
- QMAKE_CXXFLAGS+="$SLKCFLAGS" \
- QMAKE_CFLAGS+="$SLKCFLAGS" \
- qtr.pro
- sed -i -e 's% -g % %g' Makefile
- make
-
- make install \
- INSTALL_ROOT=$PKG/usr \
- INSTALL_PROGRAM="install -m0755 -p -s"
- gzip -9 $PKG/usr/man/man1/*.1
-
- mkdir -p $PKG/usr/share/applications $PKG/usr/share/pixmaps
-
- # thanks to b1101 for catching this:
- sed -i '/^Icon/s|transmission$|&-qt|' transmission-qt.desktop
-
- install -m644 transmission-qt.desktop $PKG/usr/share/applications/transmission-qt.desktop
- install -m644 icons/transmission.png $PKG/usr/share/pixmaps/transmission-qt.png
-cd -
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/transmission-qt4/transmission-qt4.info b/network/transmission-qt4/transmission-qt4.info
deleted file mode 100644
index 9d175a2bcc..0000000000
--- a/network/transmission-qt4/transmission-qt4.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="transmission-qt4"
-VERSION="2.94"
-HOMEPAGE="http://www.transmissionbt.com/"
-DOWNLOAD="https://github.com/transmission/transmission-releases/raw/master/transmission-2.94.tar.xz"
-MD5SUM="c92829294edfa391c046407eeb16358a"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"