summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2021-11-19 20:24:37 +0100
committer Willy Sudiarto Raharjo2021-12-04 04:08:56 +0100
commitc6908a839f001b94b432bf071dffc9f4e3fbaa24 (patch)
treede83578924318bfb30f894bdf99a9568405ef1e2
parent34312e7a6e012e51702ed699f7ef4b4abbc8ef98 (diff)
downloadslackbuilds-c6908a839f001b94b432bf071dffc9f4e3fbaa24.tar.gz
games/stratagus: Fix -current build.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--games/stratagus/stratagus.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/games/stratagus/stratagus.SlackBuild b/games/stratagus/stratagus.SlackBuild
index d7aaac7302..0e9f82a12f 100644
--- a/games/stratagus/stratagus.SlackBuild
+++ b/games/stratagus/stratagus.SlackBuild
@@ -43,9 +43,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -85,6 +82,9 @@ find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
# share/doc/$PRGNAM, so:
sed -i "s,share/doc/$PRGNAM,doc/$PRGNAM-$VERSION," CMakeLists.txt
+# 20211119 bkw: fix compile with -current's gcc.
+sed -i 's,"_C_," _C_,' src/ai/ai_plan.cpp src/stratagus/script.cpp
+
mkdir -p build
cd build
cmake \