summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2021-11-30 03:58:10 +0100
committer Willy Sudiarto Raharjo2021-12-04 04:09:06 +0100
commit2fe35f429dffd32f60b502b789b22ad094c0bfe3 (patch)
tree0ea2609627d2b9a2260f08583e8d7b65e6bda5f6
parentacc836eb6f7574b1f6ce7bd15cf635d26959b987 (diff)
downloadslackbuilds-2fe35f429dffd32f60b502b789b22ad094c0bfe3.tar.gz
audio/jkmeter: New-style icons.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--audio/jkmeter/README19
-rw-r--r--audio/jkmeter/doinst.sh6
-rw-r--r--audio/jkmeter/jkmeter.14
-rw-r--r--audio/jkmeter/jkmeter.SlackBuild30
-rw-r--r--audio/jkmeter/jkmeter.desktop4
-rw-r--r--audio/jkmeter/jkmeter.info4
-rw-r--r--audio/jkmeter/slack-desc10
7 files changed, 47 insertions, 30 deletions
diff --git a/audio/jkmeter/README b/audio/jkmeter/README
index daef6793a9..d909de8b28 100644
--- a/audio/jkmeter/README
+++ b/audio/jkmeter/README
@@ -1,18 +1,19 @@
jkmeter (audio level meter for JACK)
-Jkmeter is a horizontal or vertical bargraph level
-meter based on the ideas of mastering guru Bob Katz. See
-<http://www.digido.com/media/articles-and-demos.html> and follow the
-links on 'level practices'.
+Jkmeter is a horizontal or vertical bargraph level meter based
+on the ideas of mastering guru Bob Katz. See:
+
+https://www.aes.org/technical/documentDownloads.cfm?docID=65
This is the type of meter you want for live recording, mixing and
-mastering. It probably makes no sense to use it on all tracks of a DAW,
-where keeping digital level within limits is the main purpose of metering.
+mastering. It probably makes no sense to use it on all tracks of a
+DAW, where keeping digital level within limits is the main purpose of
+metering.
By default, the package is built with '-march=native'. If you need a
-generic package that can be installed on any Slackware machine with the
-same ARCH as the build host, set FORCE_SLACK_CFLAGS=yes in the script's
-environment.
+generic package that can be installed on any Slackware machine with
+the same ARCH as the build host, set FORCE_SLACK_CFLAGS=yes in the
+script's environment.
This package uses POSIX filesystem capabilities to execute with
elevated privileges (required for realtime audio processing). This
diff --git a/audio/jkmeter/doinst.sh b/audio/jkmeter/doinst.sh
index 5fb28930db..3e5691a052 100644
--- a/audio/jkmeter/doinst.sh
+++ b/audio/jkmeter/doinst.sh
@@ -1,3 +1,9 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/audio/jkmeter/jkmeter.1 b/audio/jkmeter/jkmeter.1
index 044a5c2c04..8bc73c8707 100644
--- a/audio/jkmeter/jkmeter.1
+++ b/audio/jkmeter/jkmeter.1
@@ -2,7 +2,7 @@
.\" First parameter, NAME, should be all caps
.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
.\" other parameters are allowed: see man(7), man(1)
-.TH JKMETER 1 "August 3, 2011"
+.TH JKMETER 1 "November 29, 2021"
.\" Please adjust this date whenever revising the manpage.
.\"
.\" Some roff macros, for reference:
@@ -33,7 +33,7 @@ This manual page was written for the Debian distribution because the original pr
.\" TeX users may be more comfortable with the \fB<whatever>\fP and
.\" \fI<whatever>\fP escape sequences to invode bold face and italics,
.\" respectively.
-\fBjkmeter\fP is a horizontal or vertical bargraph level meter based on the ideas of mastering guru Bob Katz. <http://www.digido.com/bob-katz/index.php>
+\fBjkmeter\fP is a horizontal or vertical bargraph level meter based on the ideas of mastering guru Bob Katz. <https://www.aes.org/technical/documentDownloads.cfm?docID=65>
.br
This meter displays both the true RMS level and the digital peak level.
.SH OPTIONS
diff --git a/audio/jkmeter/jkmeter.SlackBuild b/audio/jkmeter/jkmeter.SlackBuild
index ffa5ecfe1a..2e65204bb2 100644
--- a/audio/jkmeter/jkmeter.SlackBuild
+++ b/audio/jkmeter/jkmeter.SlackBuild
@@ -6,13 +6,14 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20211129 bkw: BUILD=2, new-style icons, update Bob Katz link.
# 20201104 bkw: updated for 0.8.0.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jkmeter
VERSION=${VERSION:-0.8.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -24,9 +25,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -64,9 +62,9 @@ find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
if [ "${FORCE_SLACK_CFLAGS:-no}" = "yes" ]; then
sed -i \
- -e '/march=native/d' \
- -e "s,-O2 -ffast-math,$SLKCFLAGS," \
- source/Makefile
+ -e '/march=native/d' \
+ -e "s,-O2 -ffast-math,$SLKCFLAGS," \
+ source/Makefile
fi
sed -i 's,pkgconf,pkg-config,' source/Makefile
@@ -74,12 +72,24 @@ sed -i 's,pkgconf,pkg-config,' source/Makefile
make -C source PREFIX=/usr DESTDIR=$PKG all install
strip $PKG/usr/bin/$PRGNAM
-# man page, icon, and .desktop file came from Debian
-mkdir -p $PKG/usr/man/man1 $PKG/usr/share/pixmaps $PKG/usr/share/applications
+# man page and .desktop file came from Debian
+mkdir -p $PKG/usr/man/man1 $PKG/usr/share/applications
gzip -9c $CWD/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
-cat $CWD/$PRGNAM.xpm > $PKG/usr/share/pixmaps/$PRGNAM.xpm
cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
+# the 32x32 icon comes from Debian.
+# the 48x48 icon is the 32x32 one, centered in a 48x48 transparent PNG.
+mkdir -p $PKG/usr/share/icons/hicolor/{32x32,48x48}/apps
+convert $CWD/$PRGNAM.xpm \
+ $PKG/usr/share/icons/hicolor/32x32/apps/$PRGNAM.png
+convert -background none -extent 48x48 -gravity center \
+ $CWD/$PRGNAM.xpm \
+ $PKG/usr/share/icons/hicolor/48x48/apps/$PRGNAM.png
+
+mkdir -p $PKG/usr/share/pixmaps
+ln -s ../icons/hicolor/48x48/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
+cat $CWD/$PRGNAM.xpm > $PKG/usr/share/pixmaps/$PRGNAM.xpm
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS COPYING README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/audio/jkmeter/jkmeter.desktop b/audio/jkmeter/jkmeter.desktop
index 1f924b4d5a..7df6d28d64 100644
--- a/audio/jkmeter/jkmeter.desktop
+++ b/audio/jkmeter/jkmeter.desktop
@@ -3,7 +3,7 @@ Type=Application
Name=Jkmeter
GenericName=Audio Level Meter
Comment=Audio level meter for JACK
-Icon=jkmeter32x32
-Exec=jkmeter -C -V
+Icon=jkmeter
+Exec=jkmeter -C -V
Terminal=false
Categories=AudioVideo;Audio;
diff --git a/audio/jkmeter/jkmeter.info b/audio/jkmeter/jkmeter.info
index 549880cdca..212789249b 100644
--- a/audio/jkmeter/jkmeter.info
+++ b/audio/jkmeter/jkmeter.info
@@ -1,7 +1,7 @@
PRGNAM="jkmeter"
VERSION="0.8.0"
-HOMEPAGE="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/index.html"
-DOWNLOAD="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/jkmeter-0.8.0.tar.bz2"
+HOMEPAGE="https://kokkinizita.linuxaudio.org/linuxaudio/downloads/index.html"
+DOWNLOAD="https://kokkinizita.linuxaudio.org/linuxaudio/downloads/jkmeter-0.8.0.tar.bz2"
MD5SUM="e5e94c5c39c14acea9154a6780222ae7"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
diff --git a/audio/jkmeter/slack-desc b/audio/jkmeter/slack-desc
index b4afcb54bd..2c25668f2f 100644
--- a/audio/jkmeter/slack-desc
+++ b/audio/jkmeter/slack-desc
@@ -8,12 +8,12 @@
|-----handy-ruler------------------------------------------------------|
jkmeter: jkmeter (audio level meter for JACK)
jkmeter:
-jkmeter: Jkmeter is a horizontal or vertical bargraph level
-jkmeter: meter based on the ideas of mastering guru Bob Katz.
-jkmeter: See <http://www.digido.com/bob-katz/index.php> and
-jkmeter: follow the links on 'level practices'.
-jkmeter:
+jkmeter: Jkmeter is a horizontal or vertical bargraph level meter based
+jkmeter: on the ideas of mastering guru Bob Katz. See:
jkmeter:
+jkmeter: https://www.aes.org/technical/documentDownloads.cfm?docID=65
jkmeter:
+jkmeter: This is the type of meter you want for live recording, mixing and
+jkmeter: mastering.
jkmeter:
jkmeter: