summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2023-05-16 05:46:20 +0200
committer Willy Sudiarto Raharjo2023-05-20 06:17:49 +0200
commit2412df271cd1f0aa573e2e136451178e05fec054 (patch)
treeefba5f450d5094aee6b37c7b335fb857a667bcb5
parent7c10671bcda37e3517e165e3b07b5748cefa4d4b (diff)
downloadslackbuilds-2412df271cd1f0aa573e2e136451178e05fec054.tar.gz
system/supervisor: Align with template.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/supervisor/supervisor.SlackBuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/system/supervisor/supervisor.SlackBuild b/system/supervisor/supervisor.SlackBuild
index 75d08bdd34..3769f38f42 100644
--- a/system/supervisor/supervisor.SlackBuild
+++ b/system/supervisor/supervisor.SlackBuild
@@ -38,16 +38,13 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
TMP=${TMP:-/tmp/SBo}
-PKG=${PKG:-$TMP/package-$SRCNAM}
+PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
set -eu
@@ -70,7 +67,7 @@ rm -f setuptools/*.exe
mkdir -p $PKG/etc
cat $PRGNAM/skel/sample.conf > $PKG/etc/supervisord.conf.new
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a *.txt $PKG/usr/doc/$PRGNAM-$VERSION