summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo2024-03-31 19:33:42 +0200
committer Willy Sudiarto Raharjo2024-04-05 10:18:11 +0200
commita2ddf198d5ca599681d7e81dd4d8b7038a3b0a85 (patch)
treead26fc22708fbc4d1f1fdd48d541d55c28bf0d42
parent2e8c2f60455b34f54ad29bd8e998b60a60cd2a5f (diff)
downloadslackbuilds-a2ddf198d5ca599681d7e81dd4d8b7038a3b0a85.tar.gz
python/pipdeptree: Fix PYTHONPATH.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/pipdeptree/pipdeptree.SlackBuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/python/pipdeptree/pipdeptree.SlackBuild b/python/pipdeptree/pipdeptree.SlackBuild
index 2369d15c15..1f6d8cf8ec 100644
--- a/python/pipdeptree/pipdeptree.SlackBuild
+++ b/python/pipdeptree/pipdeptree.SlackBuild
@@ -69,7 +69,8 @@ find -L . \
# lower version requirement for pip
sed -i 's/pip>=23.1.2/pip>=21.3.1/' pyproject.toml
-export PYTHONPATH=/opt/python3.9/site-packages/
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl