summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Tim Dickson2022-08-06 01:01:35 +0200
committer Willy Sudiarto Raharjo2022-08-06 15:16:10 +0200
commit4af02a9cac817bcb3b37794535cd21b1ea2cb341 (patch)
treecdb4a20377797ce380b0ccd606a5b6f79e89aaa0
parent5d98b1d584308bf7e766a0975f39ee23bc24a555 (diff)
downloadslackbuilds-4af02a9cac817bcb3b37794535cd21b1ea2cb341.tar.gz
libraries/gsm: Updated for version 1.0.22.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/gsm/Makefile.patch36
-rw-r--r--libraries/gsm/gsm-1.0.12-memcpy.patch11
-rw-r--r--libraries/gsm/gsm.SlackBuild26
-rw-r--r--libraries/gsm/gsm.info8
4 files changed, 34 insertions, 47 deletions
diff --git a/libraries/gsm/Makefile.patch b/libraries/gsm/Makefile.patch
index 97bc4758a4..d3061b355d 100644
--- a/libraries/gsm/Makefile.patch
+++ b/libraries/gsm/Makefile.patch
@@ -1,15 +1,15 @@
---- Makefile.orig 2022-07-03 18:49:29.000000000 +0100
-+++ Makefile 2022-07-15 15:06:58.340000000 +0100
-@@ -75,6 +75,8 @@
-
- # What's this release's version? Part of the directory and archive file name.
- VERSION = 1.0-pl20
-+# VER is used as the actual lib version
-+VER ?= 1.0.20
-
- # Where do you want to install the gsm library, header file, and manpages?
- #
-@@ -99,7 +101,7 @@
+--- Makefile.orig 2022-08-04 19:46:46.107815841 +0100
++++ Makefile 2022-08-05 14:43:30.765000000 +0100
+@@ -64,6 +64,8 @@
+ # LDLIB = -lgcc
+ ######### Additional libraries needed by $(LD)
+
++# What's this release's version?.
++VER ?= 1.0.22
+
+ # Where do you want to install libraries, binaries, a header file
+ # and the manual pages?
+@@ -96,7 +98,7 @@
# Other tools
SHELL = /bin/sh
@@ -18,7 +18,7 @@
BASENAME = basename
AR = ar
ARFLAGS = cr
-@@ -143,6 +145,7 @@
+@@ -140,6 +142,7 @@
# Targets
LIBGSM = $(LIB)/libgsm.a
@@ -26,7 +26,7 @@
TOAST = $(BIN)/toast
UNTOAST = $(BIN)/untoast
-@@ -206,24 +209,43 @@
+@@ -203,24 +206,43 @@
# Object files
@@ -88,7 +88,7 @@
TOAST_OBJECTS = $(SRC)/toast.o \
$(SRC)/toast_lin.o \
-@@ -231,7 +253,7 @@
+@@ -228,7 +250,7 @@
$(SRC)/toast_alaw.o \
$(SRC)/toast_audio.o
@@ -97,7 +97,7 @@
# Manuals
-@@ -280,9 +302,12 @@
+@@ -277,9 +299,12 @@
$(CC) $(CFLAGS) $?
@-mv `$(BASENAME) $@` $@ > /dev/null 2>&1
@@ -111,7 +111,7 @@
@-echo $(ROOT): Done.
tst: $(TST)/lin2cod $(TST)/cod2lin $(TOAST) $(TST)/test-result
-@@ -302,24 +327,29 @@
+@@ -299,24 +324,29 @@
# The basic API: libgsm
@@ -146,7 +146,7 @@
# The local bin and lib directories
-@@ -429,7 +459,9 @@
+@@ -426,7 +456,9 @@
clean: semi-clean
-rm $(RMFLAGS) $(LIBGSM) $(ADDTST)/add \
diff --git a/libraries/gsm/gsm-1.0.12-memcpy.patch b/libraries/gsm/gsm-1.0.12-memcpy.patch
deleted file mode 100644
index fc3c1ce232..0000000000
--- a/libraries/gsm/gsm-1.0.12-memcpy.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ur gsm-1.0-pl12.orig/src/code.c gsm-1.0-pl12/src/code.c
---- gsm-1.0-pl12.orig/src/code.c 2006-04-26 22:16:50.000000000 +0300
-+++ gsm-1.0-pl12/src/code.c 2007-08-19 12:18:01.000000000 +0300
-@@ -8,6 +8,7 @@
-
- #include "config.h"
-
-+#include <string.h>
-
- #ifdef HAS_STDLIB_H
- #include <stdlib.h>
diff --git a/libraries/gsm/gsm.SlackBuild b/libraries/gsm/gsm.SlackBuild
index b09b228790..fd369edbbf 100644
--- a/libraries/gsm/gsm.SlackBuild
+++ b/libraries/gsm/gsm.SlackBuild
@@ -32,11 +32,11 @@
#note to self: update patching to sed or similar for next release.
# 20220722 tim dickson: got rm patched added upstream. combined larger patch
# into easier to maintain patch, and a few sed commands.
-
+# 20220904 tim dickson: version bump to 1.0.22 (1.0-pl21). updated patch file.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gsm
-VERSION=${VERSION:-1.0.20}
+VERSION=${VERSION:-1.0.22}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -89,18 +89,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
-#the following patches are required but won't be fixed upstream due
+#the following patch and seds's are required but won't be fixed upstream due
#to the fact that the library supports ancient 16bit processors
-#and he doesn't have all the hardware to test with any more.
-#"shared" patch (modified from a gentoo patch).
+#and the developer doesn't have all the hardware to test with any more.
+#"shared" patch (modified and updated from a gentoo patch).
+#the Makefile patch allowd for static and shared libs.
patch < $CWD/Makefile.patch
-#next shouldn't be needed as config.h defines it (in inc/config.h)
-#patch -p1 < $CWD/patches/gsm-1.0.12-memcpy.patch
-#third patch has been replaced with a couple of sed's
+#these sed's fix 64bit compiling (but will break 16bit compiling)
+#which is only relevant for DOS, so is ok here.
sed -i 's/typedef long/typedef int/g' inc/private.h
sed -i 's/typedef unsigned long/typedef unsigned int/g' inc/private.h
-
mkdir -p $PKG/usr/bin
mkdir -p $PKG/usr/lib$LIBDIRSUFFIX
mkdir -p $PKG/usr/include/{gsm,libgsm}
@@ -115,20 +114,19 @@ make -j1 install \
GSM_INSTALL_INC=$PKG/usr/include/gsm \
GSM_INSTALL_MAN=$PKG/usr/man/man3 \
TOAST_INSTALL_MAN=$PKG/usr/man/man1
-
cp -p lib/libgsm.so.$VERSION $PKG/usr/lib$LIBDIRSUFFIX
( cd $PKG/usr/lib$LIBDIRSUFFIX
ln -s libgsm.so.$VERSION libgsm.so.1
ln -s libgsm.so.$VERSION libgsm.so
) || exit 1
-
# some apps look for this in /usr/include
( cd $PKG/usr/include/libgsm ; ln -s ../gsm/gsm.h gsm.h ) || exit 1
-# Replace hardlinks with softlinks
+# Replace fullpath links with relative links,
+# so autocreated doinst.sh is not broken
( cd $PKG/usr/bin
- rm -f toast ; ln -s tcat toast
- rm -f untoast ; ln -s tcat untoast
+ rm -f tcat; ln -s toast tcat
+ rm -f untoast; ln -s toast untoast
)
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/libraries/gsm/gsm.info b/libraries/gsm/gsm.info
index be9a5a3944..b5400ff6c3 100644
--- a/libraries/gsm/gsm.info
+++ b/libraries/gsm/gsm.info
@@ -1,8 +1,8 @@
PRGNAM="gsm"
-VERSION="1.0.20"
-HOMEPAGE="http://www.quut.com/gsm/"
-DOWNLOAD="http://www.quut.com/gsm/gsm-1.0.20.tar.gz"
-MD5SUM="30d5bbe9d5c761ca0a58e7dd58099aae"
+VERSION="1.0.22"
+HOMEPAGE="https://www.quut.com/gsm/"
+DOWNLOAD="https://www.quut.com/gsm/gsm-1.0.22.tar.gz"
+MD5SUM="fcca74c770a341d78ea4604418c1264b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""