summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu2022-07-30 22:57:33 +0200
committer Willy Sudiarto Raharjo2022-08-06 15:15:59 +0200
commit51642dcdea5637a310a2b2d2c8a3a96544ced661 (patch)
tree807451e7b8a8c64017d82b0b184c3ed3a9cc3548
parentab6a1e3071784fb93d752adebc22a5a691f98ed0 (diff)
downloadslackbuilds-51642dcdea5637a310a2b2d2c8a3a96544ced661.tar.gz
python/argon2-cffi: Updated for version 21.3.0.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/argon2-cffi/argon2-cffi.SlackBuild19
-rw-r--r--python/argon2-cffi/argon2-cffi.info8
2 files changed, 20 insertions, 7 deletions
diff --git a/python/argon2-cffi/argon2-cffi.SlackBuild b/python/argon2-cffi/argon2-cffi.SlackBuild
index a8d6433667..e58bf10373 100644
--- a/python/argon2-cffi/argon2-cffi.SlackBuild
+++ b/python/argon2-cffi/argon2-cffi.SlackBuild
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=argon2-cffi
-VERSION=${VERSION:-21.1.0}
+VERSION=${VERSION:-21.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,14 +80,27 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-ARGON2_CFFI_USE_SYSTEM=1 python3 setup.py install --root=$PKG
+# Use this setup.py shim:
+cat << EOF > setup.py
+from setuptools import setup, find_packages
+setup(name='${PRGNAM}',
+ version='${VERSION}',
+ packages=find_packages(where="src"),
+ package_dir={"": "src"},
+)
+EOF
+
+# With the shim, it's a good idea to use "unshare -n" to prevent downloading
+# anything extra:
+env ARGON2_CFFI_USE_SYSTEM=1 \
+ unshare -n python3 setup.py install --root=$PKG || exit 1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- AUTHORS.rst CHANGELOG.rst FAQ.rst LICENSE README.rst SECURITY.md \
+ AUTHORS.rst CHANGELOG.md FAQ.rst LICENSE README.rst \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/argon2-cffi/argon2-cffi.info b/python/argon2-cffi/argon2-cffi.info
index ca1040162b..014328230e 100644
--- a/python/argon2-cffi/argon2-cffi.info
+++ b/python/argon2-cffi/argon2-cffi.info
@@ -1,10 +1,10 @@
PRGNAM="argon2-cffi"
-VERSION="21.1.0"
+VERSION="21.3.0"
HOMEPAGE="https://argon2-cffi.readthedocs.io/"
-DOWNLOAD="https://github.com/hynek/argon2-cffi/archive/21.1.0/argon2-cffi-21.1.0.tar.gz"
-MD5SUM="648ddcb8583982637c66eac6e0c627b5"
+DOWNLOAD="https://github.com/hynek/argon2-cffi/archive/21.3.0/argon2-cffi-21.3.0.tar.gz"
+MD5SUM="f3a9d1691961b789ca2f7b8a49a4b270"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="argon2-cffi-bindings"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu1@isaacyu1.com"