summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andrew Clemons2024-03-21 12:54:57 +0100
committer Willy Sudiarto Raharjo2024-03-23 02:17:02 +0100
commit6f55a51fecc1a998eb4527dd7711c9c65b3729e5 (patch)
treea760ae5e42424dc0a4e536fd2a6233b929c65a46
parent35e072f7e1a8c508b6d71e8ab01f330fe6da7fd3 (diff)
downloadslackbuilds-6f55a51fecc1a998eb4527dd7711c9c65b3729e5.tar.gz
python/python-axolotl-curve25519: Use python2 for python 2.x.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-axolotl-curve25519/python-axolotl-curve25519.SlackBuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/python/python-axolotl-curve25519/python-axolotl-curve25519.SlackBuild b/python/python-axolotl-curve25519/python-axolotl-curve25519.SlackBuild
index d812627810..98d23126ea 100644
--- a/python/python-axolotl-curve25519/python-axolotl-curve25519.SlackBuild
+++ b/python/python-axolotl-curve25519/python-axolotl-curve25519.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for python-axolotl-curve25519
# Copyright 2016-2018 Andrew Clemons, Wellington New Zealand
+# Copyright 2024 Andrew Clemons, Tokyo Japan
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-axolotl-curve25519
VERSION=${VERSION:-0.4.1.post2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -80,12 +78,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-CFLAGS="$SLKCFLAGS" python setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- CFLAGS="$SLKCFLAGS" python3 setup.py install --root=$PKG
-fi
+CFLAGS="$SLKCFLAGS" python2 setup.py install --root=$PKG
+CFLAGS="$SLKCFLAGS" python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true