summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andrew Clemons2024-03-21 12:53:14 +0100
committer Willy Sudiarto Raharjo2024-03-23 02:17:02 +0100
commit35e072f7e1a8c508b6d71e8ab01f330fe6da7fd3 (patch)
tree61d712f6ecc127056991eee0855a4ac2786f9e6a
parent038e42891573f3948e5f5c312d807d784e449fb6 (diff)
downloadslackbuilds-35e072f7e1a8c508b6d71e8ab01f330fe6da7fd3.tar.gz
python/python-axolotl: Use python2 for python 2.x.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-axolotl/python-axolotl.SlackBuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/python/python-axolotl/python-axolotl.SlackBuild b/python/python-axolotl/python-axolotl.SlackBuild
index ded25a16d0..d113ebda66 100644
--- a/python/python-axolotl/python-axolotl.SlackBuild
+++ b/python/python-axolotl/python-axolotl.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for python-axolotl
# Copyright 2016-2019 Andrew Clemons, Wellington New Zealand
+# Copyright 2024 Andrew Clemons, Tokyo Japan
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-axolotl
VERSION=${VERSION:-0.2.3}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -65,12 +63,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true