summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author S. S. Bolokanar2022-08-05 22:40:05 +0200
committer Willy Sudiarto Raharjo2022-08-06 15:16:08 +0200
commit167875f720988416a7816592c5d85a502e4b8290 (patch)
tree26df5ed8f1a639466fa2136218cdefebeb125314
parent843bc98ccd7f93026ab033a9ecc993acf9363e1b (diff)
downloadslackbuilds-167875f720988416a7816592c5d85a502e4b8290.tar.gz
python/python3-jsonlines: Added (python lib. for jsonlines/ndjson)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-jsonlines/README2
-rw-r--r--python/python3-jsonlines/python3-jsonlines.SlackBuild94
-rw-r--r--python/python3-jsonlines/python3-jsonlines.info10
-rw-r--r--python/python3-jsonlines/slack-desc19
4 files changed, 125 insertions, 0 deletions
diff --git a/python/python3-jsonlines/README b/python/python3-jsonlines/README
new file mode 100644
index 0000000000..a4a566b225
--- /dev/null
+++ b/python/python3-jsonlines/README
@@ -0,0 +1,2 @@
+jsonlines is a Python library to simplify working with jsonlines and
+ndjson data.
diff --git a/python/python3-jsonlines/python3-jsonlines.SlackBuild b/python/python3-jsonlines/python3-jsonlines.SlackBuild
new file mode 100644
index 0000000000..dc28ef765a
--- /dev/null
+++ b/python/python3-jsonlines/python3-jsonlines.SlackBuild
@@ -0,0 +1,94 @@
+#!/bin/bash
+
+# Copyright 2022 S.S. Bolokanar, Bulgaria <sbolokanov@abv.bg>
+# С. С. Болоканаръ, България
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-jsonlines
+SRCNAM=jsonlines
+VERSION=${VERSION:-3.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE* README* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-jsonlines/python3-jsonlines.info b/python/python3-jsonlines/python3-jsonlines.info
new file mode 100644
index 0000000000..c5f4f1539e
--- /dev/null
+++ b/python/python3-jsonlines/python3-jsonlines.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-jsonlines"
+VERSION="3.1.0"
+HOMEPAGE="https://github.com/wbolster/jsonlines"
+DOWNLOAD="https://github.com/wbolster/jsonlines/archive/3.1.0/jsonlines-3.1.0.tar.gz"
+MD5SUM="6873a1a31916e5658e91ea697a9f7107"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="S. S. Bolokanar"
+EMAIL="sbolokanov@abv.bg"
diff --git a/python/python3-jsonlines/slack-desc b/python/python3-jsonlines/slack-desc
new file mode 100644
index 0000000000..cb68c75939
--- /dev/null
+++ b/python/python3-jsonlines/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-jsonlines: python3-jsonlines (a python library for jsonlines and ndjson data)
+python3-jsonlines:
+python3-jsonlines: jsonlines is a Python library to simplify working with jsonlines and
+python3-jsonlines: ndjson data.
+python3-jsonlines:
+python3-jsonlines: Homepage: https://github.com/wbolster/jsonlines
+python3-jsonlines:
+python3-jsonlines:
+python3-jsonlines:
+python3-jsonlines:
+python3-jsonlines: