summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dominik Drobek2022-05-08 00:57:42 +0200
committer Willy Sudiarto Raharjo2022-05-14 14:27:54 +0200
commit8de2e14cd81e78d5046e40b11d9caff6f61a4965 (patch)
tree18a879c961bf88efa0039e6e9714164122a74595
parent509ffb122788a64f92fb286434c4e5602be3f530 (diff)
downloadslackbuilds-8de2e14cd81e78d5046e40b11d9caff6f61a4965.tar.gz
network/SoulseekQt: Updated for version 20180130.
Drop support for 32-bit version, because 32-bit binary is not provided anymore. Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--network/SoulseekQt/README5
-rw-r--r--network/SoulseekQt/SoulseekQt.SlackBuild44
-rw-r--r--network/SoulseekQt/SoulseekQt.info10
-rw-r--r--network/SoulseekQt/SoulseekQt.pngbin905 -> 0 bytes
-rw-r--r--network/SoulseekQt/selinux-stub.c4
5 files changed, 39 insertions, 24 deletions
diff --git a/network/SoulseekQt/README b/network/SoulseekQt/README
index d954cf341f..dbfbd01a9d 100644
--- a/network/SoulseekQt/README
+++ b/network/SoulseekQt/README
@@ -1,5 +1,6 @@
SoulseekQt is the official client software for the Soulseek
peer-to-peer file-sharing network.
-This SlackBuild creates a Slackware package from the 64- or 32-bit
-binary SoulseekQt package from the official website.
+This SlackBuild creates a Slackware package from the 64-bit
+binary SoulseekQt AppImage from the official website. 32-bit
+version is not provided by upstream.
diff --git a/network/SoulseekQt/SoulseekQt.SlackBuild b/network/SoulseekQt/SoulseekQt.SlackBuild
index 313072d15a..ffcf0113b1 100644
--- a/network/SoulseekQt/SoulseekQt.SlackBuild
+++ b/network/SoulseekQt/SoulseekQt.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for SoulseekQt
-# Copyright 2016-2018, 2020 Dominik Drobek <dominik.drobek (at) o2.pl>
+# Copyright 2016-2018, 2020, 2022 Dominik Drobek <dominik.drobek (at) o2.pl>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,12 +25,12 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=SoulseekQt
-VERSION=${VERSION:-20160117}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-20180130}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-FVER="2016-1-17"
+FVER="2018-1-30"
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -40,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -54,8 +51,6 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "x86_64" ]; then
TGZARCH="64bit"
-elif [ "$ARCH" = "i586" ] || [ "$ARCH" = "i686" ]; then
- TGZARCH="32bit"
else
printf "\n$ARCH is unsupported for $PRGNAM, exiting.\n\n"
exit 1
@@ -68,18 +63,33 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
mkdir -p $TMP/$PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$FVER-$TGZARCH.tgz -C $TMP/$PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$FVER-$TGZARCH-appimage.tgz -C $TMP/$PRGNAM-$VERSION
cd $PRGNAM-$VERSION
+./$PRGNAM-$FVER-$TGZARCH.AppImage --appimage-extract
+cd squashfs-root/
chown -R root:root .
-
-install -D -m 755 $PRGNAM-$FVER-$TGZARCH $PKG/opt/$PRGNAM/$PRGNAM
-install -D -m 644 $CWD/$PRGNAM.png -t $PKG/usr/share/pixmaps/
-install -D -m 644 $CWD/$PRGNAM.desktop -t $PKG/usr/share/applications/
-mkdir -p $PKG/usr/bin
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir -p $PKG/{usr/bin,usr/share/applications,usr/share/pixmaps,opt}
+cp -r $TMP/$PRGNAM-$VERSION/squashfs-root/ $PKG/opt/$PRGNAM
+cp soulseek.png $PKG/usr/share/pixmaps/$PRGNAM.png
+cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications/
ln -sf ../../opt/$PRGNAM/$PRGNAM $PKG/usr/bin/$PRGNAM
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# provide mock SELinux library
+gcc -s -shared -Wl,-soname,libselinux.so.1 \
+ $CWD/selinux-stub.c -o $PKG/opt/$PRGNAM/lib/libselinux.so.1
+
+# clean up unnecessary files
+rm $PKG/opt/$PRGNAM/{AppRun,.DirIcon,*.AppImage,default.desktop,soulseek.png}
+#rm $PKG/opt/$PRGNAM/lib/libfreetype.so.6 # Arch Linux PKGBUILD deletes this, not sure why
+
+# fix permissions on installed directories
+find $PKG/opt/$PRGNAM -type d -exec chmod 755 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/network/SoulseekQt/SoulseekQt.info b/network/SoulseekQt/SoulseekQt.info
index 2e54873c6c..96ff443dcb 100644
--- a/network/SoulseekQt/SoulseekQt.info
+++ b/network/SoulseekQt/SoulseekQt.info
@@ -1,10 +1,10 @@
PRGNAM="SoulseekQt"
-VERSION="20160117"
+VERSION="20180130"
HOMEPAGE="https://www.slsknet.org/"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/SoulseekQt-2016-1-17-32bit.tgz"
-MD5SUM="906d99b15ed02d0d66981fffeeea1218"
-DOWNLOAD_x86_64="http://ponce.cc/slackware/sources/repo/SoulseekQt-2016-1-17-64bit.tgz"
-MD5SUM_x86_64="c843e748a129e4ad9461280aeb2b957a"
+DOWNLOAD="UNSUPPORTED"
+MD5SUM=""
+DOWNLOAD_x86_64="https://www.slsknet.org/SoulseekQt/Linux/SoulseekQt-2018-1-30-64bit-appimage.tgz"
+MD5SUM_x86_64="1d98331893bc9b9d45ba34f6523353ab"
REQUIRES=""
MAINTAINER="Dominik Drobek"
EMAIL="dominik.drobek (at) o2.pl"
diff --git a/network/SoulseekQt/SoulseekQt.png b/network/SoulseekQt/SoulseekQt.png
deleted file mode 100644
index 35cc7296f7..0000000000
--- a/network/SoulseekQt/SoulseekQt.png
+++ /dev/null
Binary files differ
diff --git a/network/SoulseekQt/selinux-stub.c b/network/SoulseekQt/selinux-stub.c
new file mode 100644
index 0000000000..c3903e341e
--- /dev/null
+++ b/network/SoulseekQt/selinux-stub.c
@@ -0,0 +1,4 @@
+int is_selinux_enabled(void)
+{
+ return 0;
+}