summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo2022-05-14 03:52:54 +0200
committer Willy Sudiarto Raharjo2022-05-14 14:27:50 +0200
commit3328c5717a6f98e343ac008d58a4f49186e96e90 (patch)
tree8b0951d68bca1d93ebc7b54d1a6613a33f1a81e8
parentcdcb1735df749b0b873a240efa40331cab77a163 (diff)
downloadslackbuilds-3328c5717a6f98e343ac008d58a4f49186e96e90.tar.gz
python/click: Updated for version 8.1.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/click/README7
-rw-r--r--python/click/click.SlackBuild13
-rw-r--r--python/click/click.info10
3 files changed, 18 insertions, 12 deletions
diff --git a/python/click/README b/python/click/README
index 8077ac8c9e..335070ddc9 100644
--- a/python/click/README
+++ b/python/click/README
@@ -8,3 +8,10 @@ sensible defaults out of the box.
It aims to make the process of writing command line tools quick and
fun while also preventing any frustration caused by the inability to
implement an intended CLI API.
+
+NOTE:
+-Use click-legacy7 if you need click<=8 and/or python2 support
+
+IMPORTANT:
+-Conflicts with click-legacy7 and both cannot be installed at the same
+ time.
diff --git a/python/click/click.SlackBuild b/python/click/click.SlackBuild
index ec6d40e3d2..477f06355d 100644
--- a/python/click/click.SlackBuild
+++ b/python/click/click.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for click
+# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
@@ -22,10 +23,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220512 46and2: Updated version, new maintainer.
+# - Removed python2 support
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=click
-VERSION=${VERSION:-7.1.2}
+VERSION=${VERSION:-8.1.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,12 +83,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/click/click.info b/python/click/click.info
index c44f2c5c5f..06bfa6e411 100644
--- a/python/click/click.info
+++ b/python/click/click.info
@@ -1,10 +1,10 @@
PRGNAM="click"
-VERSION="7.1.2"
+VERSION="8.1.3"
HOMEPAGE="https://github.com/mitsuhiko/click"
-DOWNLOAD="https://files.pythonhosted.org/packages/27/6f/be940c8b1f1d69daceeb0032fee6c34d7bd70e3e649ccac0951500b4720e/click-7.1.2.tar.gz"
-MD5SUM="53692f62cb99a1a10c59248f1776d9c0"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/c/click/click-8.1.3.tar.gz"
+MD5SUM="a804b085de7a3ff96968e38e0f6f2e05"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"