summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Damian Perticone2022-05-13 09:24:36 +0200
committer Willy Sudiarto Raharjo2022-05-14 14:28:02 +0200
commit110020d425f3191e7ce5a5cda75a24990d5fbd6d (patch)
treea431b734ecb607aa1e97d22560becee2c7ccabf1
parentfa1692f1a9cb3b7b62dfd91c4820c31265458777 (diff)
downloadslackbuilds-110020d425f3191e7ce5a5cda75a24990d5fbd6d.tar.gz
desktop/labwc: Added (wlroots-based stacking compositor)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--desktop/labwc/README45
-rw-r--r--desktop/labwc/doinst.sh3
-rw-r--r--desktop/labwc/labwc.SlackBuild117
-rw-r--r--desktop/labwc/labwc.info10
-rw-r--r--desktop/labwc/slack-desc19
-rw-r--r--desktop/labwc/use-system-wlroots.patch31
6 files changed, 225 insertions, 0 deletions
diff --git a/desktop/labwc/README b/desktop/labwc/README
new file mode 100644
index 0000000000..ff0fac3134
--- /dev/null
+++ b/desktop/labwc/README
@@ -0,0 +1,45 @@
+Labwc is a wlroots-based stacking compositor aiming to be lightweight
+and independent, with a focus on simply stacking windows well and
+rendering some window decorations. It relies on clients for wallpaper,
+panels, screenshots, and so on to create a full desktop environment.
+Labwc tries to stay in keeping with wlroots and sway in terms of general
+approach and coding style.
+In order to avoid reinventing configuration and theme syntax,
+the openbox-3.4 specification is used. This does not mean that labwc
+is an openbox clone but rather that configuration files will look and
+feel familiar.
+
+labwc supports the following:
+
+•Config files (rc.xml, autostart, environment)
+•Theme files and xbm icons
+•Damage tracking to reduce CPU usage
+•A basic root-menu (configured with menu.xml)
+•HiDPI
+•wlr-output-management protocol
+•layer-shell protocol
+•foreign-toplevel protocol (e.g. to integrate with panels and bars)
+•Optionally xwayland
+
+Labwc uses the files listed below for configuration and theming.
+get them from labwc github web page.
+
+file user over-ride location
+
+•rc.xml ~/.config/labwc/
+•menu.xml ~/.config/labwc/
+•autostart ~/.config/labwc/
+•environment ~/.config/labwc/
+•themerc ~/.local/share/themes/<theme-name>/openbox-3/
+
+Suggested apps to use with labwc:
+
+Suggested apps to use with labwc:
+
+•Screen shooter: grim
+•Screen recorder: wf-recorder
+•Background image: swaybg
+•Panel: waybar, yambar, lavalauncher, sfwbar
+•Launchers: bemenu, fuzzel, wofi
+•Output managers: wlopm, kanshi, wlr-randr
+•Screen locker: swaylock
diff --git a/desktop/labwc/doinst.sh b/desktop/labwc/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/desktop/labwc/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/desktop/labwc/labwc.SlackBuild b/desktop/labwc/labwc.SlackBuild
new file mode 100644
index 0000000000..c96dcf722b
--- /dev/null
+++ b/desktop/labwc/labwc.SlackBuild
@@ -0,0 +1,117 @@
+#!/bin/bash
+
+# Slackware build script for labwc
+
+# Copyright 2022 Damian Perticone, Berisso, Argentina
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=labwc
+VERSION=${VERSION:-0.5.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# use system wlroots
+patch -p1 < $CWD/use-system-wlroots.patch
+
+mkdir build
+cd build
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ meson .. \
+ --buildtype=release \
+ --infodir=/usr/info \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ -Dstrip=true \
+ -Dxwayland=enabled \
+
+ "${NINJA:=ninja}"
+ DESTDIR=$PKG $NINJA install
+
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CONTRIBUTING.md LICENSE NEWS.md README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/desktop/labwc/labwc.info b/desktop/labwc/labwc.info
new file mode 100644
index 0000000000..9eb0843ffd
--- /dev/null
+++ b/desktop/labwc/labwc.info
@@ -0,0 +1,10 @@
+PRGNAM="labwc"
+VERSION="0.5.1"
+HOMEPAGE="https://github.com/labwc/labwc"
+DOWNLOAD="https://github.com/labwc/labwc/archive/0.5.1/labwc-0.5.1.tar.gz"
+MD5SUM="0432008a05f01eb73fe8408d88dc51e8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="wlroots scdoc"
+MAINTAINER="Damian Perticone"
+EMAIL="mjolnirdam@gmail.com"
diff --git a/desktop/labwc/slack-desc b/desktop/labwc/slack-desc
new file mode 100644
index 0000000000..66267c4411
--- /dev/null
+++ b/desktop/labwc/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+labwc: labwc (wlroots-based stacking compositor)
+labwc:
+labwc: Labwc s a wlroots-based stacking compositor aiming to be lightweight
+labwc: and independent, with a focus on simply stacking windows well and
+labwc: rendering some window decorations.
+labwc:
+labwc:
+labwc:
+labwc:
+labwc: Home: https://github.com/labwc/labwc
+labwc:
diff --git a/desktop/labwc/use-system-wlroots.patch b/desktop/labwc/use-system-wlroots.patch
new file mode 100644
index 0000000000..3da8758174
--- /dev/null
+++ b/desktop/labwc/use-system-wlroots.patch
@@ -0,0 +1,31 @@
+--- a/meson.build 2022-04-08 17:44:37.000000000 -0300
++++ b/meson.build 2022-05-11 01:37:46.655283415 -0300
+@@ -37,22 +37,14 @@
+ endif
+ add_project_arguments('-DLABWC_VERSION=@0@'.format(version), language: 'c')
+
+-wlroots_version = ['>=0.15.0', '<0.16.0']
+-wlroots_proj = subproject(
+- 'wlroots',
+- default_options: ['default_library=static', 'examples=false'],
+- required: false,
+- version: wlroots_version,
++wlroots = dependency(
++ 'wlroots',
++default_options: ['default_library=static', 'examples=false'],
++version: ['>=0.15.0', '<0.16.0'],
+ )
+
+-if wlroots_proj.found()
+- wlroots = wlroots_proj.get_variable('wlroots')
+- wlroots_conf = wlroots_proj.get_variable('conf_data')
+- wlroots_has_xwayland = wlroots_conf.get('WLR_HAS_XWAYLAND') == 1
+-else
+- wlroots = dependency('wlroots', version: wlroots_version)
+- wlroots_has_xwayland = cc.get_define('WLR_HAS_XWAYLAND', prefix: '#include <wlr/config.h>', dependencies: wlroots) == '1'
+-endif
++wlroots_has_xwayland = wlroots.get_variable('have_xwayland') == 'true'
++
+ wayland_server = dependency('wayland-server', version: '>=1.19.0')
+ wayland_protos = dependency('wayland-protocols')
+ xkbcommon = dependency('xkbcommon')