summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author bpribula2022-05-03 21:52:44 +0200
committer Willy Sudiarto Raharjo2022-05-07 08:59:24 +0200
commit93038946c5ed2861d7b36cdcaa93a9ab1c258de5 (patch)
tree6c354ab3ce42c1a518851b9f2f028e339135b4aa
parentc33d009e8a96136c8462bdc164529b220e2c4203 (diff)
downloadslackbuilds-93038946c5ed2861d7b36cdcaa93a9ab1c258de5.tar.gz
system/bitrot: Updated for version 1.0.0.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/bitrot/bitrot.SlackBuild14
-rw-r--r--system/bitrot/bitrot.info6
-rw-r--r--system/bitrot/slack-desc2
3 files changed, 10 insertions, 12 deletions
diff --git a/system/bitrot/bitrot.SlackBuild b/system/bitrot/bitrot.SlackBuild
index d7cca1c342..17c9a3cfd4 100644
--- a/system/bitrot/bitrot.SlackBuild
+++ b/system/bitrot/bitrot.SlackBuild
@@ -2,6 +2,8 @@
# Slackware build script for bitrot
+# Copyright 2022 Brandon Pribula, BC Canada
+
# Copyright 2018 Donald Cooley South Haven, Indiana USA
# All rights reserved.
#
@@ -25,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=bitrot
-VERSION=${VERSION:-0.9.2}
+VERSION=${VERSION:-1.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -79,15 +78,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/system/bitrot/bitrot.info b/system/bitrot/bitrot.info
index 981beac662..f37f731d6a 100644
--- a/system/bitrot/bitrot.info
+++ b/system/bitrot/bitrot.info
@@ -1,8 +1,8 @@
PRGNAM="bitrot"
-VERSION="0.9.2"
+VERSION="1.0.0"
HOMEPAGE="https://github.com/ambv/bitrot"
-DOWNLOAD="https://github.com/ambv/bitrot/archive/0.9.2/bitrot-0.9.2.tar.gz"
-MD5SUM="ff3f84fee6f2b543b8e89ec306e2353e"
+DOWNLOAD="https://github.com/ambv/bitrot/archive/refs/tags/1.0.0/bitrot-1.0.0.tar.gz"
+MD5SUM="3bbed70851ce97b0736c062e20864235"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/system/bitrot/slack-desc b/system/bitrot/slack-desc
index f0b85c20ec..bf299a99d1 100644
--- a/system/bitrot/slack-desc
+++ b/system/bitrot/slack-desc
@@ -15,5 +15,5 @@ bitrot:
bitrot:
bitrot:
bitrot:
+bitrot: Homepage: https://github.com/ambv/bitrot
bitrot:
-bitrot: https://github.com/ambv/bitrot