summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2022-05-06 16:44:56 +0200
committer Matteo Bernardini2022-05-07 09:35:09 +0200
commit75cf99eedcc2f0607b021d85b6311b28a41bee0b (patch)
tree9b095cd2ca06d3caf511f1bc089581a66a59d1fc
parentcb87f53f3b17656fd91a90629b55e84b6e162641 (diff)
downloadslackbuilds-75cf99eedcc2f0607b021d85b6311b28a41bee0b.tar.gz
development/Sphinx: Removed (added to Slackware).
...as python-sphinx Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--development/Sphinx/README5
-rw-r--r--development/Sphinx/Sphinx.SlackBuild84
-rw-r--r--development/Sphinx/Sphinx.info10
-rw-r--r--development/Sphinx/slack-desc19
4 files changed, 0 insertions, 118 deletions
diff --git a/development/Sphinx/README b/development/Sphinx/README
deleted file mode 100644
index e3f923a7f7..0000000000
--- a/development/Sphinx/README
+++ /dev/null
@@ -1,5 +0,0 @@
-Sphinx is a tool that translates a set of reStructuredText
-source files into various output formats, including HTML, ePub,
-LaTeX and plain text. Sphinx was originally created for the Python
-documentation, but it has excellent facilities for the documentation
-of software projects in a range of languages.
diff --git a/development/Sphinx/Sphinx.SlackBuild b/development/Sphinx/Sphinx.SlackBuild
deleted file mode 100644
index 87caf8736b..0000000000
--- a/development/Sphinx/Sphinx.SlackBuild
+++ /dev/null
@@ -1,84 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for Sphinx
-
-# Copyright 2013 Mikko Värri, Finland
-# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=Sphinx
-VERSION=${VERSION:-4.2.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS CHANGES EXAMPLES LICENSE README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/Sphinx/Sphinx.info b/development/Sphinx/Sphinx.info
deleted file mode 100644
index f2c4274ca9..0000000000
--- a/development/Sphinx/Sphinx.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="Sphinx"
-VERSION="4.2.0"
-HOMEPAGE="http://www.sphinx-doc.org"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/S/Sphinx/Sphinx-4.2.0.tar.gz"
-MD5SUM="6af34550e36dd6d58a496e47ec67280f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="alabaster imagesize python3-babel snowballstemmer sphinxcontrib-applehelp sphinxcontrib-devhelp sphinxcontrib-htmlhelp sphinxcontrib-jsmath sphinxcontrib-qthelp sphinxcontrib-serializinghtml"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/development/Sphinx/slack-desc b/development/Sphinx/slack-desc
deleted file mode 100644
index 403648f0ae..0000000000
--- a/development/Sphinx/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-Sphinx: Sphinx (Documentation generator)
-Sphinx:
-Sphinx: Sphinx is a tool that translates a set of reStructuredText source
-Sphinx: files into various output formats, including HTML, ePub, LaTeX and
-Sphinx: plain text. Sphinx was originally created for the Python
-Sphinx: documentation, but it has excellent facilities for the documentation
-Sphinx: of software projects in a range of languages.
-Sphinx:
-Sphinx:
-Sphinx:
-Sphinx: