summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dave Woodfall2022-05-07 05:03:47 +0200
committer Willy Sudiarto Raharjo2022-05-07 08:59:36 +0200
commit6ac863a7045b79663732f9f0e8fd90add2cadb6b (patch)
tree7ec169a13d25644548f242df9ceb81db4c6a1583
parent47632469f318844772e2e24cc0f7a5c12d2c884c (diff)
downloadslackbuilds-6ac863a7045b79663732f9f0e8fd90add2cadb6b.tar.gz
python/distorm: Removed. (Renamed to python/python2-distorm).
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/distorm/README9
-rw-r--r--python/distorm/distorm.SlackBuild95
-rw-r--r--python/distorm/distorm.info10
-rw-r--r--python/distorm/slack-desc19
4 files changed, 0 insertions, 133 deletions
diff --git a/python/distorm/README b/python/distorm/README
deleted file mode 100644
index c1cc597f8f..0000000000
--- a/python/distorm/README
+++ /dev/null
@@ -1,9 +0,0 @@
-distorm (Disassembler Library for x86/AMD64 binary streams)
-
-diStorm is really a decomposer, which means it takes an
-instruction and returns a binary structure which describes
-it rather than static text, which is great for advanced
-binary code analysis.
-
-diStorm is super lightweight (~45KB), ultra fast and easy
-to use (a single API)!
diff --git a/python/distorm/distorm.SlackBuild b/python/distorm/distorm.SlackBuild
deleted file mode 100644
index 4f5f4610aa..0000000000
--- a/python/distorm/distorm.SlackBuild
+++ /dev/null
@@ -1,95 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for distorm
-# Copyright 2014-2019 Barry Grundy <bgrundy[at]linuxleo.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
-# Updated v3.4.1 March 2019
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=distorm
-VERSION=${VERSION:-3.4.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
-\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/distorm/distorm.info b/python/distorm/distorm.info
deleted file mode 100644
index ebfab369a6..0000000000
--- a/python/distorm/distorm.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="distorm"
-VERSION="3.4.1"
-HOMEPAGE="https://github.com/gdabah/distorm"
-DOWNLOAD="https://github.com/gdabah/distorm/archive/v3.4.1/distorm-3.4.1.tar.gz"
-MD5SUM="f7a0c999e70bda01ded3f45f5ac827d4"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Barry J. Grundy"
-EMAIL="bgrundy AT linuxleo.com"
diff --git a/python/distorm/slack-desc b/python/distorm/slack-desc
deleted file mode 100644
index 5f93b59c86..0000000000
--- a/python/distorm/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-distorm: distorm (Disassembler Library for x86/AMD64 binary streams)
-distorm:
-distorm: The goal of diStorm is to decode x86/AMD64 binary streams and return
-distorm: a structure that describes each instruction.
-distorm:
-distorm: The package includes Python Bindings
-distorm:
-distorm:
-distorm:
-distorm:
-distorm: