summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Juan M. Lasca2022-04-26 15:51:05 +0200
committer Willy Sudiarto Raharjo2022-04-30 08:52:06 +0200
commit90974cc45a715d26c4d070e3a7dc1c1032313a9a (patch)
tree3756f389f5c566988745960cb291902fdaf3040b
parent68aa541132254bf06c3a6018c19fe6268893d877 (diff)
downloadslackbuilds-90974cc45a715d26c4d070e3a7dc1c1032313a9a.tar.gz
development/recutils: Added (tools/libraries to access recfiles).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/recutils/README10
-rw-r--r--development/recutils/configure.ac.patch4
-rw-r--r--development/recutils/mdb2rec.c.patch9
-rw-r--r--development/recutils/recutils.SlackBuild122
-rw-r--r--development/recutils/recutils.info10
-rw-r--r--development/recutils/slack-desc19
6 files changed, 174 insertions, 0 deletions
diff --git a/development/recutils/README b/development/recutils/README
new file mode 100644
index 0000000000..980d7dd9a8
--- /dev/null
+++ b/development/recutils/README
@@ -0,0 +1,10 @@
+GNU Recutils is a set of tools and libraries to access human-editable,
+plain text databases called recfiles. The data is stored as a sequence
+of records, each record containing an arbitrary number of named fields.
+
+mdbutils is an optional dependency (autodetected) required to build the
+mdb2rec utility (will patch the source and run autoreconf).
+If you already have the mdbutils package installed, but do not want the
+mdb2rec utility, set the MDB2REC environment variable to "no" before
+executing the script, e.g.
+ MDB2REC="no" ./recutils.SlackBuild
diff --git a/development/recutils/configure.ac.patch b/development/recutils/configure.ac.patch
new file mode 100644
index 0000000000..e82f4ae6e9
--- /dev/null
+++ b/development/recutils/configure.ac.patch
@@ -0,0 +1,4 @@
+126c126
+< AC_CHECK_LIB([mdb],[mdb_init],[have_mdb=yes],)
+---
+> AC_CHECK_LIB([mdb],[mdb_get_version],[have_mdb=yes],)
diff --git a/development/recutils/mdb2rec.c.patch b/development/recutils/mdb2rec.c.patch
new file mode 100644
index 0000000000..5b6798b51d
--- /dev/null
+++ b/development/recutils/mdb2rec.c.patch
@@ -0,0 +1,9 @@
+391a392,393
+> col = g_ptr_array_index (table->columns, i);
+> column_name = col->name;
+431,432d432
+< mdb_init();
+< mdb_set_date_fmt ("%Y-%m-%dT%H:%M:%S%z"); /* ISO 8601 */
+441a442,443
+>
+> mdb_set_date_fmt (mdb, "%Y-%m-%dT%H:%M:%S%z"); /* ISO 8601 */
diff --git a/development/recutils/recutils.SlackBuild b/development/recutils/recutils.SlackBuild
new file mode 100644
index 0000000000..df8a919102
--- /dev/null
+++ b/development/recutils/recutils.SlackBuild
@@ -0,0 +1,122 @@
+#!/bin/bash
+
+# Slackware build script for recutils
+
+# Copyright 2022 Juan M. Lasca <juanmlasca@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=recutils
+VERSION=${VERSION:-1.9}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# If libmdb (mdbtools) is present and the user did not disable the build of
+# the `mdb2rec` utility, patch the source tree and run `atoreconf`.
+if [ "${MDB2REC:-yes}" != "no" ] && [ -f /usr/lib${LIBDIRSUFFIX}/libmdb.so ]; then
+ patch configure.ac $CWD/configure.ac.patch
+ patch utils/mdb2rec.c $CWD/mdb2rec.c.patch
+ autoreconf -f -i
+fi;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-static=no \
+ --build=$ARCH-slackware-linux
+
+make
+make install-strip DESTDIR=$PKG
+
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+rm -f $PKG/usr/info/dir
+gzip -9 $PKG/usr/info/*.info*
+
+gzip -9 ChangeLog
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README COPYING NEWS AUTHORS ChangeLog.gz \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/recutils/recutils.info b/development/recutils/recutils.info
new file mode 100644
index 0000000000..f2105dfe15
--- /dev/null
+++ b/development/recutils/recutils.info
@@ -0,0 +1,10 @@
+PRGNAM="recutils"
+VERSION="1.9"
+HOMEPAGE="https://www.gnu.org/software/recutils/"
+DOWNLOAD="https://mirror.cedia.org.ec/gnu/recutils/recutils-1.9.tar.gz"
+MD5SUM="ee5da209df9a1f80e65c9739a814ce34"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Juan M. Lasca"
+EMAIL="juanmlasca@gmail.com"
diff --git a/development/recutils/slack-desc b/development/recutils/slack-desc
new file mode 100644
index 0000000000..762869c1cb
--- /dev/null
+++ b/development/recutils/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+recutils: recutils (tools and libraries to access recfiles)
+recutils:
+recutils: GNU Recutils is a set of tools and libraries to access
+recutils: human-editable, plain text databases called recfiles. The data is
+recutils: stored as a sequence of records, each record containing an arbitrary
+recutils: number of named fields.
+recutils:
+recutils: https://www.gnu.org/software/recutils/
+recutils:
+recutils:
+recutils: