summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author toolonely2022-04-23 04:49:27 +0200
committer Willy Sudiarto Raharjo2022-04-23 20:47:12 +0200
commit41841a8d7da9d713f89c7e2dbc8e484a83ef0ab6 (patch)
tree8ad65780da6c5236f9bb4d56980721846b8cec18
parent1d820f5274135cb2d0992df807e51745ef6a9f2a (diff)
downloadslackbuilds-41841a8d7da9d713f89c7e2dbc8e484a83ef0ab6.tar.gz
python/python3-pytest-cov: Added (coverage plugin for pytest)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-pytest-cov/README15
-rw-r--r--python/python3-pytest-cov/python3-pytest-cov.SlackBuild101
-rw-r--r--python/python3-pytest-cov/python3-pytest-cov.info10
-rw-r--r--python/python3-pytest-cov/slack-desc19
4 files changed, 145 insertions, 0 deletions
diff --git a/python/python3-pytest-cov/README b/python/python3-pytest-cov/README
new file mode 100644
index 0000000000..0e37bd4e57
--- /dev/null
+++ b/python/python3-pytest-cov/README
@@ -0,0 +1,15 @@
+This pytest plugin produces coverage reports. Compared to just
+using coverage run this plugin does some extras:
+
+- Subprocess support: you can fork or run stuff in a subprocess
+ and will get covered without any fuss.
+- Xdist support: you can use all of pytest-xdist’s features and
+ still get coverage.
+- Consistent pytest behavior. If you run coverage run -m pytest you
+ will have slightly different sys.path (CWD will be in it, unlike
+ when running pytest).
+
+All features offered by the coverage package should work, either
+through pytest-cov’s command line options or through coverage’s
+config file.
+
diff --git a/python/python3-pytest-cov/python3-pytest-cov.SlackBuild b/python/python3-pytest-cov/python3-pytest-cov.SlackBuild
new file mode 100644
index 0000000000..01a20d94a5
--- /dev/null
+++ b/python/python3-pytest-cov/python3-pytest-cov.SlackBuild
@@ -0,0 +1,101 @@
+#!/bin/bash
+
+# Slackware build script for python3-pytest-cov
+
+# Copyright 2022 toolonely <lonely_@tutanota.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-pytest-cov
+VERSION=${VERSION:-3.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=pytest-cov
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ *.rst \
+ LICENSE \
+ PKG-INFO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-pytest-cov/python3-pytest-cov.info b/python/python3-pytest-cov/python3-pytest-cov.info
new file mode 100644
index 0000000000..85c036bb38
--- /dev/null
+++ b/python/python3-pytest-cov/python3-pytest-cov.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-pytest-cov"
+VERSION="3.0.0"
+HOMEPAGE="https://github.com/pytest-dev/pytest-cov"
+DOWNLOAD="https://files.pythonhosted.org/packages/61/41/e046526849972555928a6d31c2068410e47a31fb5ab0a77f868596811329/pytest-cov-3.0.0.tar.gz"
+MD5SUM="334699c80f86308f4781b14179321812"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-pytest coverage"
+MAINTAINER="toolonely"
+EMAIL="lonely_@tutanota.com"
diff --git a/python/python3-pytest-cov/slack-desc b/python/python3-pytest-cov/slack-desc
new file mode 100644
index 0000000000..86ffe5d014
--- /dev/null
+++ b/python/python3-pytest-cov/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-pytest-cov: python3-pytest-cov (coverage plugin for pytest)
+python3-pytest-cov:
+python3-pytest-cov: This pytest plugin produces coverage reports
+python3-pytest-cov:
+python3-pytest-cov:
+python3-pytest-cov:
+python3-pytest-cov:
+python3-pytest-cov:
+python3-pytest-cov:
+python3-pytest-cov:
+python3-pytest-cov: