summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author K. Eugene Carlson2022-04-19 16:39:37 +0200
committer Willy Sudiarto Raharjo2022-04-23 20:47:20 +0200
commit156bc869c0cf8e0c82519c2d4cde1ff3ea66074a (patch)
treeee8a983fd06fcc9f4aa786d5202204b4458038f7
parentb6e849d013e72834d3158a20e7b82a0aa4a9a1d3 (diff)
downloadslackbuilds-156bc869c0cf8e0c82519c2d4cde1ff3ea66074a.tar.gz
system/pcem: update to version f4a1ab9.20220418
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/pcem/README2
-rw-r--r--system/pcem/pcem.SlackBuild40
-rw-r--r--system/pcem/pcem.info6
-rw-r--r--system/pcem/plugins.diff13
4 files changed, 22 insertions, 39 deletions
diff --git a/system/pcem/README b/system/pcem/README
index 9d781f8022..de8f64e305 100644
--- a/system/pcem/README
+++ b/system/pcem/README
@@ -19,7 +19,7 @@ Aside from BUILD and VERSION, the following options are available when
calling pcem.SlackBuild:
ALSA=yes # Use ALSA for MIDI output
- NETWORKING=yes # Enable network connectivity
+ NETWORKING=no # Disable network connectivity
PCAP=no # Disable PCAP networking (no effect without networking)
PLUGINS=yes # Build the plugin engine
diff --git a/system/pcem/pcem.SlackBuild b/system/pcem/pcem.SlackBuild
index f3fa93810a..7549ecbf5a 100644
--- a/system/pcem/pcem.SlackBuild
+++ b/system/pcem/pcem.SlackBuild
@@ -25,28 +25,28 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pcem
-VERSION=${VERSION:-965ea55.20220306}
-SRCVERSION=${SRCVERSION:-965ea55331e7c1c5a3ca169e006150615cb65776}
+VERSION=${VERSION:-f4a1ab9.20220418}
+SRCVERSION=${SRCVERSION:-f4a1ab9c5193ebeaa5ab7da3b613dc78a5614550}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
# Use ALSA=yes to output MIDI with ALSA.
unset USE_ALSA
-[ ${ALSA:-no} = yes ] && USE_ALSA="-Duse-alsa=true"
+[ ${ALSA:-no} = yes ] && USE_ALSA="-DUSE_ALSA=ON"
-# Use NETWORKING=yes to enable networking.
-unset USE_NETWORKING
-[ ${NETWORKING:-no} = yes ] && USE_NETWORKING="-Duse-networking=true"
+# Use NETWORKING=no to disable networking.
+USE_NETWORKING="-DUSE_NETWORKING=ON"
+[ ${NETWORKING:-yes} = no ] && USE_NETWORKING="-DUSE_NETWORKING=OFF"
# Use PCAP=no to disable PCAP networking. Has no effect unless networking is
# turned on.
unset NO_PCAP
-[ ${PCAP:-yes} = no ] && NO_PCAP="-Duse-pcap-networking=false"
+[ ${PCAP:-yes} = no ] && NO_PCAP="-DUSE_PCAP_NETWORKING=OFF"
# Use PLUGINS=yes to build the plugin engine.
unset USE_PLUGINS
-[ ${PLUGINS:-no} = yes ] && USE_PLUGINS="-Duse-plugin-engine=true"
+[ ${PLUGINS:-no} = yes ] && USE_PLUGINS="-DPLUGIN_ENGINE=ON"
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -91,9 +91,6 @@ rm -rf $PRGNAM-$SRCVERSION
unzip $CWD/$PRGNAM-$SRCVERSION.zip
cd $PRGNAM-$SRCVERSION
-# Fix building the plugin engine with meson
-patch -p1 < $CWD/plugins.diff
-
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -105,29 +102,28 @@ mkdir build
cd build
CXXFLAGS="$SLKCFLAGS" \
CFLAGS="$SLKCFLAGS" \
-meson \
- --buildtype release \
+cmake -G "Ninja" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DPCEM_LIB_DIR=/usr/lib$LIBDIRSUFFIX \
$USE_ALSA \
$USE_NETWORKING \
$NO_PCAP \
$USE_PLUGINS \
- --prefix=/usr \
- --libdir=/usr/lib$LIBDIRSUFFIX \
- --mandir=/usr/man \
..
ninja
-meson install --destdir=$PKG
+DESTDIR=$PKG ninja install/strip
cd ..
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mv $PKG/usr/man/man1/pcem.man.1 $PKG/usr/man/man1/pcem.1
+mkdir -p $PKG/usr/man/man1
+mv $PKG/usr/share/man/man1/pcem.man/pcem.man.1 $PKG/usr/man/man1/pcem.1
+rm -r $PKG/usr/share/man
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
# The text files saying "roms go here" aren't really necessary.
find $PKG/usr/share/pcem/roms -name roms.txt -delete
+rm -f $PKG/usr/share/pcem/configs/configs.txt
# File included in error.
rm -f $PKG/usr/share/pcem/roms/mda.rom
@@ -136,7 +132,7 @@ rm -f $PKG/usr/share/pcem/roms/mda.rom
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- tested.html \
+ TESTED.md \
README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat COPYING > $PKG/usr/doc/$PRGNAM-$VERSION/LICENSE
diff --git a/system/pcem/pcem.info b/system/pcem/pcem.info
index 5eb31dd41c..1479a26337 100644
--- a/system/pcem/pcem.info
+++ b/system/pcem/pcem.info
@@ -1,8 +1,8 @@
PRGNAM="pcem"
-VERSION="965ea55.20220306"
+VERSION="f4a1ab9.20220418"
HOMEPAGE="http://pcem-emulator.co.uk/"
-DOWNLOAD="https://github.com/sarah-walker-pcem/pcem/archive/965ea55331e7c1c5a3ca169e006150615cb65776/pcem-965ea55331e7c1c5a3ca169e006150615cb65776.zip"
-MD5SUM="2606944e16aa39a0c1cf4e14599c9ca2"
+DOWNLOAD="https://github.com/sarah-walker-pcem/pcem/archive/f4a1ab9c5193ebeaa5ab7da3b613dc78a5614550/pcem-f4a1ab9c5193ebeaa5ab7da3b613dc78a5614550.zip"
+MD5SUM="22c4288f0f40a4e42644f97b51f94d07"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="wxGTK3"
diff --git a/system/pcem/plugins.diff b/system/pcem/plugins.diff
deleted file mode 100644
index 565e55487e..0000000000
--- a/system/pcem/plugins.diff
+++ /dev/null
@@ -1,13 +0,0 @@
---- pcem-965ea55331e7c1c5a3ca169e006150615cb65776.orig/src/plugin-api/meson.build 2022-03-19 19:19:47.223202352 +0900
-+++ pcem-965ea55331e7c1c5a3ca169e006150615cb65776/src/plugin-api/meson.build 2022-03-19 19:20:10.085117202 +0900
-@@ -26,7 +26,9 @@
- )
-
- if get_option('use-plugin-engine')
-- pcem_plugin_api = shared_library('pcem', sources: pcem_pluginapi_src, dependencies: pcem_dependencies, include_directories: pcem_include_dirs, install: true)
-+ libdl = compiler.find_library('dl', required: false)
-+ pcem_dependencies += libdl
-+ pcem_plugin_api = shared_library('pcem-plugin-api', sources: pcem_pluginapi_src, dependencies: pcem_dependencies, include_directories: pcem_include_dirs, install: true)
- pcem_project_libraries += pcem_plugin_api
- else
- pcem_src += pcem_pluginapi_src