summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andrew Clemons2022-03-25 08:00:16 +0100
committer Willy Sudiarto Raharjo2022-03-25 19:20:19 +0100
commit7b9eeeb131b967c9d1cb8907e6bc3dc6c315a443 (patch)
tree35464e0e6e453729cf70e5c9b4466259bc69cc5c
parent8ef08c0691d77e4915e634c27dec69c6a5256cf0 (diff)
downloadslackbuilds-7b9eeeb131b967c9d1cb8907e6bc3dc6c315a443.tar.gz
development/perf: Fix build with x86 -smp kernel.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/perf/perf.SlackBuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/development/perf/perf.SlackBuild b/development/perf/perf.SlackBuild
index 10bf118b94..b67fa20209 100644
--- a/development/perf/perf.SlackBuild
+++ b/development/perf/perf.SlackBuild
@@ -88,11 +88,11 @@ EOF
case "$KERNEL" in
# if unset, use the running kernel:
- "") SRCDIR="/usr/src/linux-$( uname -r )" ;;
+ "") SRCDIR="/usr/src/linux-$( uname -r )" ; SRCDIR=${SRCDIR%-smp} ;;
# if it's an absolute path, use it as-is:
/*) SRCDIR="$KERNEL" ;;
# otherwise assume it's a version number:
- *) SRCDIR="/usr/src/linux-$KERNEL" ;;
+ *) KERNEL=${KERNEL%-smp} ; SRCDIR="/usr/src/linux-$KERNEL" ;;
esac
[ -f "$SRCDIR/Makefile" ] || die "Can't find kernel source in \"$SRCDIR\""