summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author klaatu2022-03-06 07:10:56 +0100
committer Willy Sudiarto Raharjo2022-03-07 02:38:02 +0100
commitc952507e7f591796d2986112ec6e3633d91144fd (patch)
tree65ff2f6fd7c4edba0c3085446d07ba134c33042c
parentc249864ba5785fb7ef99f11623da4972196ffa37 (diff)
downloadslackbuilds-c952507e7f591796d2986112ec6e3633d91144fd.tar.gz
games/antimicrox: renamed and updated for version 3.2.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--games/antimicro/README16
-rw-r--r--games/antimicro/antimicro.info10
-rw-r--r--games/antimicrox/README19
-rw-r--r--games/antimicrox/antimicrox.SlackBuild (renamed from games/antimicro/antimicro.SlackBuild)39
-rw-r--r--games/antimicrox/antimicrox.desktop (renamed from games/antimicro/antimicro.desktop)10
-rw-r--r--games/antimicrox/antimicrox.info10
-rw-r--r--games/antimicrox/doinst.sh (renamed from games/antimicro/doinst.sh)0
-rw-r--r--games/antimicrox/slack-desc (renamed from games/antimicro/slack-desc)22
8 files changed, 63 insertions, 63 deletions
diff --git a/games/antimicro/README b/games/antimicro/README
deleted file mode 100644
index 399fbaa113..0000000000
--- a/games/antimicro/README
+++ /dev/null
@@ -1,16 +0,0 @@
-Antimicro is a GUI application to intercept gamepad signals and
-translate them to keyboard and mouse events, so that you can use a
-gamepad with games that do not have native (or poor) gamepad support.
-
-It works for games you're playing on Linux or with WINE. It works with
-Steam or stand-alone games.
-
-Profiles
---------
-
-Some pre-built game controller profiles are available here:
-
-https://github.com/AntiMicro/antimicro-profiles
-
-These allow you to download button mappings for popular games so that
-you don't have to configure them yourself.
diff --git a/games/antimicro/antimicro.info b/games/antimicro/antimicro.info
deleted file mode 100644
index 5e7c0e2abb..0000000000
--- a/games/antimicro/antimicro.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="antimicro"
-VERSION="2.23"
-HOMEPAGE="https://github.com/AntiMicro/antimicro"
-DOWNLOAD="https://github.com/AntiMicro/antimicro/archive/2.23/antimicro-2.23.tar.gz"
-MD5SUM="b63397e9e6d0bb06d98b0931a86b3427"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="qt4"
-MAINTAINER="Klaatu"
-EMAIL="klaatu@member.fsf.org"
diff --git a/games/antimicrox/README b/games/antimicrox/README
new file mode 100644
index 0000000000..49dc09275f
--- /dev/null
+++ b/games/antimicrox/README
@@ -0,0 +1,19 @@
+AntiMicroX is a fork of AntiMicro, a GUI application to intercept
+gamepad signals and translate them to keyboard and mouse events.
+Use it so you can play games with a gamepad that have poor or no
+native gamepad support.
+
+It works for games you're playing on Linux or with WINE. It works with
+Steam or stand-alone games. (Note that Steam does a pretty good job
+of translating most controllers even for games without gamepad support,
+so you may not need AntiMicroX).
+
+Profiles
+--------
+
+Some pre-built game controller profiles are available here:
+
+https://github.com/AntiMicro/antimicro-profiles
+
+These allow you to download button mappings for popular games so that
+you don't have to configure them yourself.
diff --git a/games/antimicro/antimicro.SlackBuild b/games/antimicrox/antimicrox.SlackBuild
index 293f8938cd..a9797f8d97 100644
--- a/games/antimicro/antimicro.SlackBuild
+++ b/games/antimicrox/antimicrox.SlackBuild
@@ -1,5 +1,5 @@
#!/bin/bash
-# Slackware build script for antimicro
+# Slackware build script for antimicrox
# Copyright 2015-2016 Klaatu Wellington, NZ
#
# GNU All-Permissive License
@@ -15,8 +15,8 @@
cd $(dirname $0) ; CWD=$(pwd)
-PRGNAM=antimicro
-VERSION=${VERSION:-2.23}
+PRGNAM=antimicrox
+VERSION=${VERSION:-3.2.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -71,35 +71,32 @@ find -L . \
# 20220219 bkw: ordered comparison of pointer with integer... this is
# really a bit too picky, IMO.
-sed -i '/if *(joysticks *>/s, *> *0 *),),' src/mainwindow.cpp
+sed -i '/if *(joysticks *>/s, *> *0 *),),' src/gui/mainwindow.cpp
-# 20220219 bkw: put man page in right place.
-sed -i 's,share/man,man,' other/CMakeLists.txt
+# fix hardcoded path
+sed -i 's,/usr/lib/udev,/etc/udev,' CMakeLists.txt
mkdir -p build
cd build
-QT_SELECT=4 cmake \
+cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DUSE_SDL_2=ON \
+ -DAPPDATA=OFF \
+ -DCMAKE_INSTALL_MANDIR=$MANDIR \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release ..
- make
- make install/strip DESTDIR=$PKG
-cd ..
-
-# 20220219 bkw: binary stripped, man page already gzipped.
-# 20220219 bkw: .desktop file needs absolute path to binary (because
-# /usr/games might not be in someone's $PATH) and icon (because it's
-# not in /usr/share/icons).
-cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
+# fix hardcoded path
+sed -i 's,share/man,man,' other/cmake_install.cmake
+make
+make install/strip DESTDIR=$PKG
+cd ..
mkdir -p $PKG/$DOCDIR/$PRGNAM-$VERSION
-cp -a README.md BuildOptions.md gpl.txt Resources.txt \
- ProfileTips.md other/40-uinput.rules \
- $PKG/$DOCDIR/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/$DOCDIR/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cp -a README.md BUILDING.md CHANGELOG.md LICENSE \
+ ProfileTips.md $PKG/$DOCDIR/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > \
+ $PKG/$DOCDIR/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/games/antimicro/antimicro.desktop b/games/antimicrox/antimicrox.desktop
index 857a322dce..6c3cb497d2 100644
--- a/games/antimicro/antimicro.desktop
+++ b/games/antimicrox/antimicrox.desktop
@@ -1,15 +1,15 @@
[Desktop Entry]
-Name=AntiMicro
+Name=AntiMicroX
Comment=Use a gamepad to control a variety of programs
Name[sr]=Анти-микро
Comment[sr]=Користите џојстик или играћу тастатуру за управљање различитим програмима
-Name[fr]=AntiMicro
+Name[fr]=AntiMicroX
Comment[fr]=Utilisez une manette de jeu pour commander un logiciel
-Name[de]=AntiMicro
+Name[de]=AntiMicroX
Comment[de]=Nutze das Gamepad um Programme/Spiele zu steuern
Comment[uk]=Використовуйте ігровий маніпулятор для керування програмами
-Exec=/usr/games/antimicro
-Icon=/usr/share/pixmaps/antimicro.png
+Exec=/usr/games/antimicrox
+Icon=/usr/share/pixmaps/antimicrox.png
StartupNotify=true
Terminal=false
Type=Application
diff --git a/games/antimicrox/antimicrox.info b/games/antimicrox/antimicrox.info
new file mode 100644
index 0000000000..d400c2e064
--- /dev/null
+++ b/games/antimicrox/antimicrox.info
@@ -0,0 +1,10 @@
+PRGNAM="antimicrox"
+VERSION="2.23"
+HOMEPAGE="https://github.com/AntiMicroX"
+DOWNLOAD="https://github.com/AntiMicroX/antimicrox/archive/3.2.2/antimicrox-3.2.2.tar.gz"
+MD5SUM=""
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Klaatu"
+EMAIL="klaatu@member.fsf.org"
diff --git a/games/antimicro/doinst.sh b/games/antimicrox/doinst.sh
index 9a8ded3c60..9a8ded3c60 100644
--- a/games/antimicro/doinst.sh
+++ b/games/antimicrox/doinst.sh
diff --git a/games/antimicro/slack-desc b/games/antimicrox/slack-desc
index b2e069eb29..e1afc20a65 100644
--- a/games/antimicro/slack-desc
+++ b/games/antimicrox/slack-desc
@@ -6,14 +6,14 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-antimicro: antimicro (gamepad to keypress)
-antimicro:
-antimicro: Antimicro is a graphical program used to map keyboard keys and mouse
-antimicro: controls to a gamepad. Useful for playing PC games with no gamepad
-antimicro: or poor gamepad support.
-antimicro:
-antimicro: http://github.com/AntiMicro/antimicro
-antimicro:
-antimicro:
-antimicro:
-antimicro:
+antimicrox: antimicrox (gamepad to keypress)
+antimicrox:
+antimicrox: AntimicroX is a graphical program that maps keyboard keys and mouse
+antimicrox: controls to a gamepad. Useful for playing PC games with no gamepad
+antimicrox: or poor gamepad support.
+antimicrox:
+antimicrox: http://github.com/AntiMicroX/antimicrox
+antimicrox:
+antimicrox:
+antimicrox:
+antimicrox: