summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Lenard Spencer2022-03-06 09:13:31 +0100
committer Willy Sudiarto Raharjo2022-03-07 02:45:30 +0100
commit2902feffcd8486c9a4e9ff0b79573c762e5b3721 (patch)
tree39dc78cc4aeb2c76063e78f1117003c519ccb737
parentd669a20950165c47afe9c1280e7155295d6808e4 (diff)
downloadslackbuilds-2902feffcd8486c9a4e9ff0b79573c762e5b3721.tar.gz
development/openjdk6: Added (re-added + new maint).
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/openjdk6/README27
-rw-r--r--development/openjdk6/cacertsbin0 -> 192567 bytes
-rw-r--r--development/openjdk6/openjdk6-slackware15.patch48
-rw-r--r--development/openjdk6/openjdk6.SlackBuild160
-rw-r--r--development/openjdk6/openjdk6.info12
-rw-r--r--development/openjdk6/profile.d/openjdk6.csh4
-rw-r--r--development/openjdk6/profile.d/openjdk6.sh4
-rw-r--r--development/openjdk6/slack-desc19
8 files changed, 274 insertions, 0 deletions
diff --git a/development/openjdk6/README b/development/openjdk6/README
new file mode 100644
index 0000000000..d50875ff71
--- /dev/null
+++ b/development/openjdk6/README
@@ -0,0 +1,27 @@
+OpenJDK 6 is an open source implementation of version 6 of the
+Java Development Kit, Standard Edition. It includes tools for
+developing, testing, and running programs written in Java.
+
+This build requires both apache-ant and gcc5. You do NOT need to
+install Oracle's jdk, as apache-ant will work just fine with the jvm
+tools in gcc5.
+
+To build with pulseaudio support, pass PULSE=yes to the script.
+Please note that pulseaudio support was removed from later versions.
+
+Before installing this package please consider any other jdk's/jre's
+that you have already installed as they may cause conflicts with the
+PATH, JAVA_HOME and MANPATH variables.
+
+After installing the package you will need to logout/login to your
+machine as it will add new files to the /etc/profile.d folder.
+
+This script may take a couple of hours to complete and will require
+about 8 GB of disk space for its temporary directory. It defaults to
+"/tmp/SBo" and you may redefine it like this:
+
+TMP=/your/temporary/dir ./openjdk6.SlackBuild
+
+The 'cacerts' binary is a keystore containing CA certificates which
+are used by Java applications. It is taken from the CentOS package
+'ca-certificates-2015.2.4-65.0.1.el6_6.noarch.rpm'.
diff --git a/development/openjdk6/cacerts b/development/openjdk6/cacerts
new file mode 100644
index 0000000000..3c6ae3e526
--- /dev/null
+++ b/development/openjdk6/cacerts
Binary files differ
diff --git a/development/openjdk6/openjdk6-slackware15.patch b/development/openjdk6/openjdk6-slackware15.patch
new file mode 100644
index 0000000000..aac64cd362
--- /dev/null
+++ b/development/openjdk6/openjdk6-slackware15.patch
@@ -0,0 +1,48 @@
+diff -Naur icedtea6-1.13.13.orig/Makefile.am icedtea6-1.13.13/Makefile.am
+--- icedtea6-1.13.13.orig/Makefile.am 2017-01-04 15:22:49.112782727 -0500
++++ icedtea6-1.13.13/Makefile.am 2021-05-29 23:06:16.902186221 -0400
+@@ -328,6 +328,7 @@
+ $(UPSTREAMED_PATCHES) \
+ patches/openjdk/6733501-icedtea_lcms_test.patch \
+ $(LCMS_PATCHES) \
++ patches/openjdk/removed-sysctl-h.patch \
+ patches/openjdk/7018912-potential_buffer_overruns_in_jpeg.patch \
+ patches/openjdk/6989760-native_warnings.patch \
+ patches/openjdk/7013519-integer_overflows.patch \
+diff -Naur icedtea6-1.13.13.orig/Makefile.in icedtea6-1.13.13/Makefile.in
+--- icedtea6-1.13.13.orig/Makefile.in 2017-01-04 15:23:00.576597287 -0500
++++ icedtea6-1.13.13/Makefile.in 2021-05-29 23:06:15.712176245 -0400
+@@ -782,6 +782,7 @@
+ $(UPSTREAMED_PATCHES) \
+ patches/openjdk/6733501-icedtea_lcms_test.patch \
+ $(LCMS_PATCHES) \
++ patches/openjdk/removed-sysctl-h.patch \
+ patches/openjdk/7018912-potential_buffer_overruns_in_jpeg.patch \
+ patches/openjdk/6989760-native_warnings.patch \
+ patches/openjdk/7013519-integer_overflows.patch \
+diff -Naur icedtea6-1.13.13.orig/patches/openjdk/removed-sysctl-h.patch icedtea6-1.13.13/patches/openjdk/removed-sysctl-h.patch
+--- icedtea6-1.13.13.orig/patches/openjdk/removed-sysctl-h.patch 1969-12-31 19:00:00.000000000 -0500
++++ icedtea6-1.13.13/patches/openjdk/removed-sysctl-h.patch 2021-05-29 22:22:09.410666831 -0400
+@@ -0,0 +1,22 @@
++diff -Naur openjdk/jdk/src/solaris/native/java/net/PlainDatagramSocketImpl.c openjdk.new/jdk/src/solaris/native/java/net/PlainDatagramSocketImpl.c
++--- openjdk/jdk/src/solaris/native/java/net/PlainDatagramSocketImpl.c 2016-12-29 23:30:19.000000000 -0500
+++++ openjdk.new/jdk/src/solaris/native/java/net/PlainDatagramSocketImpl.c 2021-05-29 22:20:40.679916383 -0400
++@@ -35,7 +35,6 @@
++ #endif
++ #ifdef __linux__
++ #include <unistd.h>
++-#include <sys/sysctl.h>
++ #include <sys/utsname.h>
++ #include <netinet/ip.h>
++
++diff -Naur openjdk/jdk/src/solaris/native/java/net/PlainSocketImpl.c openjdk.new/jdk/src/solaris/native/java/net/PlainSocketImpl.c
++--- openjdk/jdk/src/solaris/native/java/net/PlainSocketImpl.c 2016-12-29 23:30:19.000000000 -0500
+++++ openjdk.new/jdk/src/solaris/native/java/net/PlainSocketImpl.c 2021-05-29 22:20:23.242768734 -0400
++@@ -43,7 +43,6 @@
++ #endif
++ #ifdef __linux__
++ #include <unistd.h>
++-#include <sys/sysctl.h>
++ #endif
++
++ #include "jvm.h"
diff --git a/development/openjdk6/openjdk6.SlackBuild b/development/openjdk6/openjdk6.SlackBuild
new file mode 100644
index 0000000000..8339569f56
--- /dev/null
+++ b/development/openjdk6/openjdk6.SlackBuild
@@ -0,0 +1,160 @@
+#!/bin/bash
+
+# Slackware build script for openjdk6
+
+# Copyright 2017 Strahil Yordanov, Sofia, Bulgaria
+# Copyright 2021 Lenard Spencer, Orlando, Florida, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=openjdk6
+VERSION=${VERSION:-6b41}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+DVER=1.6.0_${VERSION#6}
+ICEDTEA=icedtea6-1.13.13
+OPENJDK_DATE=04_jan_2017
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm; echo "Unsupported arch $ARCH"; exit 1;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+BUILD_DIR=$TMP/$PRGNAM
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "x86_64" ]; then
+ LIB_ARCH=amd64
+ LIBDIRSUFFIX="64"
+else
+ LIB_ARCH=i386
+ LIBDIRSUFFIX=""
+fi
+
+# Check for the gcc5 package, and abort if not found:
+if [ ! -x /usr/bin/gcc-5 ]; then
+ echo "This requires the gcc5 package to build."
+ echo "Please install gcc5 and rerun this script."
+ exit 1
+else
+ source /etc/profile.d/gcc5.sh # Set the environment
+fi
+
+BOOT_JAVA=/usr/lib${LIBDIRSUFFIX}/jvm
+
+set -e
+
+rm -rf $BUILD_DIR $PKG
+mkdir -p $TMP $BUILD_DIR $PKG $OUTPUT
+cd $BUILD_DIR
+
+tar -xvf $CWD/${ICEDTEA}.tar.xz
+
+# Alter freetypeversion.patch:
+sed -i "s/2.2.1/2.11.0/" ${ICEDTEA}/patches/freetypeversion.patch
+
+# Patch for Slackware(64)-15.0:
+patch -p0 < $CWD/openjdk6-slackware15.patch
+
+mkdir icedtea-build
+cd icedtea-build
+
+# Enable the pulseaudio driver (defaults to no)
+if [ "${PULSE:-no}" = "yes" ]; then
+ PULSEJAVA="--enable-pulse-java"
+else
+ PULSEJAVA=""
+fi
+# Disable kerberos
+if [ "${KERBEROS:-yes}" = "no" ]; then
+ KRB="--disable-system-kerberos"
+else
+ KRB=""
+fi
+
+# Set JAVA_HOME in order to avoid conflictis with other already installed JVMs.
+# cacerts taken from this CentOS package:
+# http://mirror.centos.org/centos/6/os/x86_64/Packages/ca-certificates-2015.2.4-65.0.1.el6_6.noarch.rpm
+
+JAVA_HOME=${BOOT_JAVA} PATH=${BOOT_JAVA}/bin:$PATH ../$ICEDTEA/configure \
+ --with-jdk-home=${BOOT_JAVA} \
+ --with-gcj \
+ --disable-docs \
+ --disable-downloading \
+ --without-rhino \
+ $KRB \
+ --enable-nss \
+ $PULSEJAVA \
+ --with-openjdk-src-zip="$CWD/openjdk-6-src-${VERSION#6}-${OPENJDK_DATE}.tar.xz"
+
+echo \
+ "sed -i '/^ *@Override *$/ d' openjdk/jdk/src/share/classes/javax/management/remote/rmi/RMIJRMPServerImpl.java" \
+ >> fsg.sh
+DISABLE_HOTSPOT_OS_VERSION_CHECK=ok \
+JAVA_HOME=${BOOT_JAVA} PATH=${BOOT_JAVA}/bin:$PATH LOG=trace make
+
+mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}
+cd $PKG/usr/lib${LIBDIRSUFFIX}
+cp -av $BUILD_DIR/icedtea-build/openjdk.build/j2sdk-image/ $PRGNAM
+ln -sf $PRGNAM ${PRGNAM}${DVER}
+ln -sf ./$PRGNAM/jre/lib/${LIB_ARCH}/server/libjvm.so .
+
+cp "$CWD/cacerts" $PRGNAM/jre/lib/security
+
+chown -R root.root $PKG
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir -p $PKG/etc/profile.d
+for file in $(ls "$CWD/profile.d/${PRGNAM}"*) ; do
+ cat $file | sed -e "s#lib/openjdk#lib${LIBDIRSUFFIX}/openjdk#" \
+ > $PKG/etc/profile.d/$(basename $file)
+done
+chmod 755 $PKG/etc/profile.d/*
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $PKG/usr/lib${LIBDIRSUFFIX}/$PRGNAM/{THIRD_PARTY_README,LICENSE,ASSEMBLY_EXCEPTION} \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/openjdk6/openjdk6.info b/development/openjdk6/openjdk6.info
new file mode 100644
index 0000000000..9b2c5762a3
--- /dev/null
+++ b/development/openjdk6/openjdk6.info
@@ -0,0 +1,12 @@
+PRGNAM="openjdk6"
+VERSION="6b41"
+HOMEPAGE="https://openjdk.java.net"
+DOWNLOAD="https://icedtea.classpath.org/download/source/icedtea6-1.13.13.tar.xz \
+ https://ponce.cc/slackware/sources/repo/openjdk-6-src-b41-04_jan_2017.tar.xz"
+MD5SUM="338c09785299e0240bef044464fc3dfc \
+ cee9838d359a9910f98b5c413d381cd1"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="apache-ant gcc5"
+MAINTAINER="Lenard Spencer"
+EMAIL="lenardrspencer@gmail.com"
diff --git a/development/openjdk6/profile.d/openjdk6.csh b/development/openjdk6/profile.d/openjdk6.csh
new file mode 100644
index 0000000000..2a4264d8c3
--- /dev/null
+++ b/development/openjdk6/profile.d/openjdk6.csh
@@ -0,0 +1,4 @@
+#!/bin/csh
+setenv JAVA_HOME /usr/lib/openjdk6
+setenv MANPATH ${MANPATH}:${JAVA_HOME}/man
+setenv PATH ${PATH}:${JAVA_HOME}/bin:${JAVA_HOME}/jre/bin
diff --git a/development/openjdk6/profile.d/openjdk6.sh b/development/openjdk6/profile.d/openjdk6.sh
new file mode 100644
index 0000000000..69d2dd977d
--- /dev/null
+++ b/development/openjdk6/profile.d/openjdk6.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+export JAVA_HOME=/usr/lib/openjdk6
+export MANPATH="${MANPATH}:${JAVA_HOME}/man"
+export PATH="${PATH}:${JAVA_HOME}/bin:${JAVA_HOME}/jre/bin"
diff --git a/development/openjdk6/slack-desc b/development/openjdk6/slack-desc
new file mode 100644
index 0000000000..0765304aec
--- /dev/null
+++ b/development/openjdk6/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+openjdk6: openjdk6 (Open Implementation of JDK)
+openjdk6:
+openjdk6: OpenJDK 6 is an open source implementation of version 6 of the
+openjdk6: Java Development Kit, Standard Edition. It includes tools for
+openjdk6: developing, testing, and running programs written in Java.
+openjdk6:
+openjdk6:
+openjdk6:
+openjdk6:
+openjdk6:
+openjdk6: