summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andrew Clemons2022-02-20 06:41:52 +0100
committer Willy Sudiarto Raharjo2022-02-20 09:13:29 +0100
commite3e9c7414cb0e6750e181514fd9e0cfad1ade688 (patch)
tree53f0a9b9c1660e8d310700af764b30654fe036b3
parentd6c86638a72edbb7f1ef1c57b0b4e25ed33b6741 (diff)
downloadslackbuilds-e3e9c7414cb0e6750e181514fd9e0cfad1ade688.tar.gz
gis/python-mapnik: Updated for version git4a6f35d.
Fix build with newer boost on 15.0. Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--gis/python-mapnik/python-mapnik.SlackBuild20
-rw-r--r--gis/python-mapnik/python-mapnik.info6
2 files changed, 17 insertions, 9 deletions
diff --git a/gis/python-mapnik/python-mapnik.SlackBuild b/gis/python-mapnik/python-mapnik.SlackBuild
index 772cb0f010..0da411b95e 100644
--- a/gis/python-mapnik/python-mapnik.SlackBuild
+++ b/gis/python-mapnik/python-mapnik.SlackBuild
@@ -24,7 +24,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-mapnik
-VERSION=${VERSION:-3.0.16}
+GITREV=${GITREV:-7da019cf9eb12af8f8aa88b7d75789dfcd1e901b}
+VERSION=${VERSION:-git$(echo "$GITREV" | sed 's/^\(.\{7\}\).*$/\1/')}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -68,9 +69,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xzvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$GITREV
+tar xvf $CWD/$PRGNAM-$GITREV.tar.gz
+cd $PRGNAM-$GITREV
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -78,8 +79,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
-#python3 setup.py install --root=$PKG # only works on -current, where boost has libboost_python3x.so
+BOOST_PYTHON_LIB="boost_python$(python -c 'import sys; print("{}{}".format(sys.version_info.major, sys.version_info.minor))')"
+export BOOST_PYTHON_LIB
+export BOOST_THREAD_LIB="boost_thread"
+export BOOST_SYSTEM_LIB="boost_system"
+python setup.py install --root=$PKG
+
+BOOST_PYTHON_LIB="boost_python$(python3 -c 'import sys; print("{}{}".format(sys.version_info.major, sys.version_info.minor))')"
+export BOOST_PYTHON_LIB
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/gis/python-mapnik/python-mapnik.info b/gis/python-mapnik/python-mapnik.info
index 17dffb195e..24c2ce6bae 100644
--- a/gis/python-mapnik/python-mapnik.info
+++ b/gis/python-mapnik/python-mapnik.info
@@ -1,8 +1,8 @@
PRGNAM="python-mapnik"
-VERSION="3.0.16"
+VERSION="git7da019c"
HOMEPAGE="https://mapnik.org"
-DOWNLOAD="https://github.com/mapnik/python-mapnik/archive/v3.0.16/python-mapnik-3.0.16.tar.gz"
-MD5SUM="1a23274f810812791af163d3806792a2"
+DOWNLOAD="https://github.com/mapnik/python-mapnik/archive/7da019cf9eb12af8f8aa88b7d75789dfcd1e901b/python-mapnik-7da019cf9eb12af8f8aa88b7d75789dfcd1e901b.tar.gz"
+MD5SUM="88fa158fec168c4a54f5b1010849af85"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="mapnik"