summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2022-02-15 05:53:12 +0100
committer Willy Sudiarto Raharjo2022-02-16 02:20:05 +0100
commit655c98da598f2430493eeb59f6ecc04abcd4b6e7 (patch)
treed420cf9ee674cc75fa7433f608b6e2e6791f68f1
parent52dc75ef226ec6d98d7e53c737e6af2820872876 (diff)
downloadslackbuilds-655c98da598f2430493eeb59f6ecc04abcd4b6e7.tar.gz
libraries/wxPython3: Fix build (ignore /usr/bin/wx-config).
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/wxPython3/wxPython3.SlackBuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/libraries/wxPython3/wxPython3.SlackBuild b/libraries/wxPython3/wxPython3.SlackBuild
index b9fe787df5..4985e03db0 100644
--- a/libraries/wxPython3/wxPython3.SlackBuild
+++ b/libraries/wxPython3/wxPython3.SlackBuild
@@ -23,6 +23,10 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220214 bkw: Modified by SlackBuilds.org: make the build succeed
+# when wxPython and wxGTK3 are both installed, regardless of which one
+# was installed first.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=wxPython3
@@ -40,9 +44,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -85,21 +86,21 @@ cd $SRCNAM-src-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
cd wxPython
python2 setup.py \
WXPORT=gtk3 \
UNICODE=1 \
- WX_CONFIG=/usr/bin/wx-config \
+ WX_CONFIG=/usr/lib64/wx/config/gtk3-unicode-3.0 \
build
python2 setup.py \
WXPORT=gtk3 \
UNICODE=1 \
- WX_CONFIG=/usr/bin/wx-config \
+ WX_CONFIG=/usr/lib64/wx/config/gtk3-unicode-3.0 \
install --root=$PKG
mkdir -p $PKG/usr/share/{applications,pixmaps} $PKG/usr/share/icons/hicolor/{16x16,32x32}/apps