summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2021-12-29 21:10:08 +0100
committer Willy Sudiarto Raharjo2022-01-04 01:55:38 +0100
commit835e8dfd2e344d50719e9553831a3fe55d8dec9f (patch)
tree5de73929cb9ded1b33e52124928a87ad37ea4918
parentef26b1634c71f8c180fb73faa6d16bc37903c5cb (diff)
downloadslackbuilds-835e8dfd2e344d50719e9553831a3fe55d8dec9f.tar.gz
python/python3-sge: Added (2d game engine).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-sge/README15
-rw-r--r--python/python3-sge/python3-sge.SlackBuild105
-rw-r--r--python/python3-sge/python3-sge.info12
-rw-r--r--python/python3-sge/slack-desc19
4 files changed, 151 insertions, 0 deletions
diff --git a/python/python3-sge/README b/python/python3-sge/README
new file mode 100644
index 0000000000..d1ff7dae0d
--- /dev/null
+++ b/python/python3-sge/README
@@ -0,0 +1,15 @@
+python3-sge (2d game engine for python3 and pygame)
+
+The Seclusion Game Engine ("SGE", pronounced like "sage") is a
+general-purpose libre open source 2-D game engine for Python. It
+takes care of several details for you so you can focus on the game
+itself. This makes more rapid game development possible, and it also
+makes the SGE easy to learn.
+
+SGE was formerly known as "Stellar Game Engine" and "sge-python".
+
+This build of SGE also includes the xSGE extensions.
+
+Optional build-time dependency: Sphinx. If this is installed, the SGE
+API documentation will be included in the package. You only need this
+if you're developing your own game that uses SGE.
diff --git a/python/python3-sge/python3-sge.SlackBuild b/python/python3-sge/python3-sge.SlackBuild
new file mode 100644
index 0000000000..355f2dc418
--- /dev/null
+++ b/python/python3-sge/python3-sge.SlackBuild
@@ -0,0 +1,105 @@
+#!/bin/bash
+
+# Slackware build script for python3-sge
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-sge
+VERSION=${VERSION:-2.0.post0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+SRCNAM=sge
+XVER=2021.10.11
+
+fixperms() {
+ chown -R root:root .
+ find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+}
+
+# First, sge itself...
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+fixperms
+
+python3 setup.py install --root=$PKG
+
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC/html
+
+# only build the HTML docs if Sphinx is installed.
+HASDOC="does NOT include"
+if type -p sphinx-build &>/dev/null; then
+ HASDOC="includes"
+ make -C doc-src html
+ cp -a doc/html $PKGDOC/html/sge
+fi
+
+cp -a README* WHATS* VERS* examples $SRCNAM/COPY* $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
+
+# Now the extensions (xsge).
+cd $TMP
+rm -rf xsge-$XVER
+tar xvf $CWD/xsge-$XVER.tar.gz
+cd xsge-$XVER
+fixperms
+
+python3 setup.py install --root=$PKG
+
+# HTML docs for xsge are prebuilt.
+for i in */; do
+ cp -a $i/doc/html $PKGDOC/html/$i
+done
+
+cp -a README $PKGDOC/README.xsge
+
+mkdir -p $PKG/install
+sed "s,@HASDOC@,$HASDOC," $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-sge/python3-sge.info b/python/python3-sge/python3-sge.info
new file mode 100644
index 0000000000..298c6a2d63
--- /dev/null
+++ b/python/python3-sge/python3-sge.info
@@ -0,0 +1,12 @@
+PRGNAM="python3-sge"
+VERSION="2.0.post0"
+HOMEPAGE="https://python-sge.github.io/"
+DOWNLOAD="https://github.com/python-sge/sge/archive/v2.0.post0/sge-2.0.post0.tar.gz \
+ https://github.com/python-sge/xsge/releases/download/v2021.10.11/xsge-2021.10.11.tar.gz"
+MD5SUM="bc6363ad02da7c015d46fabb5367b2a7 \
+ 58fb4b439d420f48706e7a3de01de81d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pygame"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
diff --git a/python/python3-sge/slack-desc b/python/python3-sge/slack-desc
new file mode 100644
index 0000000000..8c656152a7
--- /dev/null
+++ b/python/python3-sge/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-sge: python3-sge (2d game engine for python3 and pygame)
+python3-sge:
+python3-sge: The Seclusion Game Engine ("SGE", pronounced like "sage") is a
+python3-sge: general-purpose libre open source 2-D game engine for Python. It
+python3-sge: takes care of several details for you so you can focus on the game
+python3-sge: itself. This makes more rapid game development possible, and it also
+python3-sge: makes the SGE easy to learn.
+python3-sge:
+python3-sge: SGE was formerly known as "Stellar Game Engine" and "sge-python".
+python3-sge:
+python3-sge: This package @HASDOC@ the SGE API documentation.