summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu2022-02-14 00:20:32 +0100
committer Willy Sudiarto Raharjo2022-02-14 06:46:39 +0100
commit077c4d91b32cf040334acd203602273713b4aa12 (patch)
tree57d7f3e497761150c35f11a0a4adfe26bbdf61e5
parent85dd12d322de44a31e3356c8f2e35438d2e0dc22 (diff)
downloadslackbuilds-077c4d91b32cf040334acd203602273713b4aa12.tar.gz
python/et_xmlfile: Update for 1.1.0
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/et_xmlfile/et_xmlfile.SlackBuild10
-rw-r--r--python/et_xmlfile/et_xmlfile.info6
2 files changed, 8 insertions, 8 deletions
diff --git a/python/et_xmlfile/et_xmlfile.SlackBuild b/python/et_xmlfile/et_xmlfile.SlackBuild
index 5fa8074e16..f1e4095ae9 100644
--- a/python/et_xmlfile/et_xmlfile.SlackBuild
+++ b/python/et_xmlfile/et_xmlfile.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/bash
+#!/bin/sh
# Slackware build script for et_xmlfile
-# Copyright 2020 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2020-2022 Isaac Yu <isaacyu1@isaacyu1.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=et_xmlfile
-VERSION=${VERSION:-1.0.1}
+VERSION=${VERSION:-1.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -65,7 +65,7 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-VERSION
+rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
@@ -76,7 +76,7 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Python 2 and Python 3 support
-python2 setup.py install --root=$PKG
+python setup.py install --root=$PKG
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/python/et_xmlfile/et_xmlfile.info b/python/et_xmlfile/et_xmlfile.info
index 1211f171af..bd534b1624 100644
--- a/python/et_xmlfile/et_xmlfile.info
+++ b/python/et_xmlfile/et_xmlfile.info
@@ -1,8 +1,8 @@
PRGNAM="et_xmlfile"
-VERSION="1.0.1"
+VERSION="1.1.0"
HOMEPAGE="https://et-xmlfile.readthedocs.io/en/latest/"
-DOWNLOAD="https://pypi.python.org/packages/source/e/et_xmlfile/et_xmlfile-1.0.1.tar.gz"
-MD5SUM="f47940fd9d556375420b2e276476cfaf"
+DOWNLOAD="https://pypi.python.org/packages/source/e/et_xmlfile/et_xmlfile-1.1.0.tar.gz"
+MD5SUM="8fbae9b969eac28c02f5073febefc445"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="lxml"