summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Heinz Wiesinger2021-09-26 18:07:16 +0200
committer Willy Sudiarto Raharjo2021-10-02 11:50:36 +0200
commit683429feac1d178ce48849a588d56201d360bfdc (patch)
treea997b38e2e3a95ec1691ac0a7a4902eba43094bb
parent38068c6727703048e17687ab4ea1bf525ff5297b (diff)
downloadslackbuilds-683429feac1d178ce48849a588d56201d360bfdc.tar.gz
python/python2-gattlib: Updated for version 0.20200121
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python2-gattlib/dont_hardcode_python_versions.patch19
-rw-r--r--python/python2-gattlib/python2-gattlib.SlackBuild30
-rw-r--r--python/python2-gattlib/python2-gattlib.info8
-rw-r--r--python/python2-gattlib/slack-desc2
4 files changed, 21 insertions, 38 deletions
diff --git a/python/python2-gattlib/dont_hardcode_python_versions.patch b/python/python2-gattlib/dont_hardcode_python_versions.patch
deleted file mode 100644
index 0e11e85d18..0000000000
--- a/python/python2-gattlib/dont_hardcode_python_versions.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Matteo Bernardini <ponce@slackbuilds.org>
----
-Don't hardcode python versions
-
-diff -Naur gattlib-0.20150805.orig/setup.py gattlib-0.20150805/setup.py
---- gattlib-0.20150805.orig/setup.py 2015-08-05 15:16:56.000000000 +0200
-+++ gattlib-0.20150805/setup.py 2018-05-02 09:45:04.625893000 +0200
-@@ -19,9 +19,9 @@
- glib_libs = [x.strip() for x in glib_libs if x]
-
- if sys.version_info.major == 3:
-- boost_libs = ["boost_python-py34"]
-+ boost_libs = ["boost_python3"+str(sys.version_info.minor)]
- else:
-- boost_libs = ["boost_python"]
-+ boost_libs = ["boost_python2"+str(sys.version_info.minor)]
- extension_modules = [
- Extension(
- 'gattlib',
diff --git a/python/python2-gattlib/python2-gattlib.SlackBuild b/python/python2-gattlib/python2-gattlib.SlackBuild
index fe1a8c7263..0ac11a3705 100644
--- a/python/python2-gattlib/python2-gattlib.SlackBuild
+++ b/python/python2-gattlib/python2-gattlib.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-gattlib
-# Copyright 2017 Heinz Wiesinger, Amsterdam, The Netherlands
+# Copyright 2017-2021 Heinz Wiesinger, Amsterdam, The Netherlands
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -11,22 +11,22 @@
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python2-gattlib
-VERSION=${VERSION:-0.20150805}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-0.20200121}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -67,7 +67,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 < $CWD/dont_hardcode_python_versions.patch
+# Point to correct version of boost-python
+sed -i 's/\["boost_python"\]/\["boost_python2"+str(sys.version_info.minor)\]/' \
+ ./setup.py
python2 setup.py install --root=$PKG
diff --git a/python/python2-gattlib/python2-gattlib.info b/python/python2-gattlib/python2-gattlib.info
index 4be50e3354..a918a9ca8c 100644
--- a/python/python2-gattlib/python2-gattlib.info
+++ b/python/python2-gattlib/python2-gattlib.info
@@ -1,8 +1,8 @@
PRGNAM="python2-gattlib"
-VERSION="0.20150805"
-HOMEPAGE="https://bitbucket.org/OscarAcena/pygattlib"
-DOWNLOAD="https://pypi.python.org/packages/be/2f/5b1aecec551b42b59d8b399ad444b5672972efb590ca83d784dbe616a3e1/gattlib-0.20150805.tar.gz"
-MD5SUM="f620eca190bb7acd67c7aafecaedb6c2"
+VERSION="0.20200121"
+HOMEPAGE="https://github.com/oscaracena/pygattlib"
+DOWNLOAD="https://files.pythonhosted.org/packages/04/df/9c6346358a2131a38cb4eec81d28ede43fa7895945c842e1d249722c94f7/gattlib-0.20200121.tar.gz"
+MD5SUM="85231ae76b301d63b1fd2abe71a39d43"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/python/python2-gattlib/slack-desc b/python/python2-gattlib/slack-desc
index b9d149dfab..a03d7fe0ee 100644
--- a/python/python2-gattlib/slack-desc
+++ b/python/python2-gattlib/slack-desc
@@ -12,7 +12,7 @@ python2-gattlib: This is a Python library to use the GATT Protocol for Bluetooth
python2-gattlib: devices. It is a wrapper around the implementation used by gatttool
python2-gattlib: in bluez package.
python2-gattlib:
-python2-gattlib: Homepage: https://bitbucket.org/OscarAcena/pygattlib
+python2-gattlib: Homepage: https://github.com/oscaracena/pygattlib
python2-gattlib:
python2-gattlib:
python2-gattlib: