summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Heinz Wiesinger2021-09-05 16:13:32 +0200
committer Willy Sudiarto Raharjo2021-09-06 03:50:27 +0200
commitb1f9c9c4cb66a4fe98ffe9025733fde7e0f7fcad (patch)
tree5dfa1d95f7502342ff03ce8f4f8b9dc4ae094509
parentcafdf433942d7d38bf492495abbb870389bbfe07 (diff)
downloadslackbuilds-b1f9c9c4cb66a4fe98ffe9025733fde7e0f7fcad.tar.gz
system/virtualbox-addons: Updated for version 6.1.26
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/virtualbox-addons/LocalConfig.kmk2
-rw-r--r--system/virtualbox-addons/README.SLACKWARE10
-rw-r--r--system/virtualbox-addons/kded5rc2
-rw-r--r--system/virtualbox-addons/kwin_blacklist_vbox.sh8
-rw-r--r--system/virtualbox-addons/kwinrc2
-rw-r--r--system/virtualbox-addons/plasma_disable_kscreen.sh3
-rw-r--r--system/virtualbox-addons/rc.vboxadd.diff280
-rw-r--r--system/virtualbox-addons/vbox-uninstall-guest-additions2
-rw-r--r--system/virtualbox-addons/virtualbox-addons.SlackBuild83
-rw-r--r--system/virtualbox-addons/virtualbox-addons.info6
-rw-r--r--system/virtualbox-addons/virtualbox_plasma_disable_kscreen.upd6
11 files changed, 43 insertions, 361 deletions
diff --git a/system/virtualbox-addons/LocalConfig.kmk b/system/virtualbox-addons/LocalConfig.kmk
index 3a2f6880d3..9a5a3df598 100644
--- a/system/virtualbox-addons/LocalConfig.kmk
+++ b/system/virtualbox-addons/LocalConfig.kmk
@@ -7,7 +7,5 @@ KBUILD_MSG_STYLE := brief
VBOX_OSE := 1
-VBOX_WITH_PAM =
-
# do not fail on warning
VBOX_WITH_WARNINGS_AS_ERRORS :=
diff --git a/system/virtualbox-addons/README.SLACKWARE b/system/virtualbox-addons/README.SLACKWARE
index 2def33125c..0c7eb9a867 100644
--- a/system/virtualbox-addons/README.SLACKWARE
+++ b/system/virtualbox-addons/README.SLACKWARE
@@ -1,10 +1,5 @@
You'll need to add the following lines to /etc/rc.d/rc.local:
- # Start vboxadd
- if [ -x /etc/rc.d/rc.vboxadd ]; then
- /etc/rc.d/rc.vboxadd start
- fi
-
# Start vboxadd-service
if [ -x /etc/rc.d/rc.vboxadd-service ]; then
/etc/rc.d/rc.vboxadd-service start
@@ -15,11 +10,6 @@ configuration for VirtualBox.
You should then add the following to /etc/rc.d/rc.local_shutdown:
- # Stop vboxadd
- if [ -x /etc/rc.d/rc.vboxadd ]; then
- /etc/rc.d/rc.vboxadd stop
- fi
-
# Stop vboxadd-service
if [ -x /etc/rc.d/rc.vboxadd-service ]; then
/etc/rc.d/rc.vboxadd-service stop
diff --git a/system/virtualbox-addons/kded5rc b/system/virtualbox-addons/kded5rc
new file mode 100644
index 0000000000..f86038454f
--- /dev/null
+++ b/system/virtualbox-addons/kded5rc
@@ -0,0 +1,2 @@
+[Module-kscreen]
+autoload=false
diff --git a/system/virtualbox-addons/kwin_blacklist_vbox.sh b/system/virtualbox-addons/kwin_blacklist_vbox.sh
deleted file mode 100644
index ed7d07fe1d..0000000000
--- a/system/virtualbox-addons/kwin_blacklist_vbox.sh
+++ /dev/null
@@ -1,8 +0,0 @@
-while read line; do
- echo $line
-done
-
-echo ""
-echo "[Compositing]"
-echo "OpenGLIsUnsafe=true"
-echo ""
diff --git a/system/virtualbox-addons/kwinrc b/system/virtualbox-addons/kwinrc
deleted file mode 100644
index 6f70d2c9d3..0000000000
--- a/system/virtualbox-addons/kwinrc
+++ /dev/null
@@ -1,2 +0,0 @@
-[Compositing]
-OpenGLIsUnsafe=true
diff --git a/system/virtualbox-addons/plasma_disable_kscreen.sh b/system/virtualbox-addons/plasma_disable_kscreen.sh
new file mode 100644
index 0000000000..9971e631e1
--- /dev/null
+++ b/system/virtualbox-addons/plasma_disable_kscreen.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+kwriteconfig5 --file kded5rc --group "Module-kscreen" --key autoload --type bool false
diff --git a/system/virtualbox-addons/rc.vboxadd.diff b/system/virtualbox-addons/rc.vboxadd.diff
deleted file mode 100644
index f0b3acddd0..0000000000
--- a/system/virtualbox-addons/rc.vboxadd.diff
+++ /dev/null
@@ -1,280 +0,0 @@
---- vboxadd.sh.orig 2016-11-23 16:24:46.000000000 +0100
-+++ vboxadd.sh 2016-12-27 16:06:46.413895799 +0100
-@@ -154,42 +154,9 @@
-
- dev=/dev/vboxguest
- userdev=/dev/vboxuser
--config=/var/lib/VBoxGuestAdditions/config
- owner=vboxadd
- group=1
-
--test_for_gcc_and_make()
--{
-- which make > /dev/null 2>&1 || printf "\nThe make utility was not found. If the following module compilation fails then\nthis could be the reason and you should try installing it.\n"
-- which gcc > /dev/null 2>&1 || printf "\nThe gcc utility was not found. If the following module compilation fails then\nthis could be the reason and you should try installing it.\n"
--}
--
--test_sane_kernel_dir()
--{
-- KERN_VER=`uname -r`
-- KERN_DIR="/lib/modules/$KERN_VER/build"
-- if [ -d "$KERN_DIR" ]; then
-- KERN_REL=`make -sC $KERN_DIR --no-print-directory kernelrelease 2>/dev/null || true`
-- if [ -z "$KERN_REL" -o "x$KERN_REL" = "x$KERN_VER" ]; then
-- return 0
-- fi
-- fi
-- printf "\nThe headers for the current running kernel were not found. If the following\nmodule compilation fails then this could be the reason.\n"
-- if [ "$system" = "redhat" ]; then
-- if echo "$KERN_VER" | grep -q "uek"; then
-- printf "The missing package can be probably installed with\nyum install kernel-uek-devel-$KERN_VER\n"
-- else
-- printf "The missing package can be probably installed with\nyum install kernel-devel-$KERN_VER\n"
-- fi
-- elif [ "$system" = "suse" ]; then
-- KERN_VER_SUSE=`echo "$KERN_VER" | sed 's/.*-\([^-]*\)/\1/g'`
-- KERN_VER_BASE=`echo "$KERN_VER" | sed 's/\(.*\)-[^-]*/\1/g'`
-- printf "The missing package can be probably installed with\nzypper install kernel-$KERN_VER_SUSE-devel-$KERN_VER_BASE\n"
-- elif [ "$system" = "debian" ]; then
-- printf "The missing package can be probably installed with\napt-get install linux-headers-$KERN_VER\n"
-- fi
--}
--
- running_vboxguest()
- {
- lsmod | grep -q "vboxguest[^_-]"
-@@ -261,13 +228,6 @@
- start()
- {
- begin "Starting the VirtualBox Guest Additions ";
-- if test -r $config; then
-- . $config
-- else
-- fail "Configuration file $config not found"
-- fi
-- test -n "$INSTALL_DIR" -a -n "$INSTALL_VER" ||
-- fail "Configuration file $config not complete"
- uname -r | grep -q -E '^2\.6|^3|^4' 2>/dev/null &&
- ps -A -o comm | grep -q '/*udevd$' 2>/dev/null ||
- no_udev=1
-@@ -378,218 +338,16 @@
- return 0
- }
-
--## Update the initramfs. Debian and Ubuntu put the graphics driver in, and
--# need the touch(1) command below. Everyone else that I checked just need
--# the right module alias file from depmod(1) and only use the initramfs to
--# load the root filesystem, not the boot splash. update-initramfs works
--# for the first two and dracut for every one else I checked. We are only
--# interested in distributions recent enough to use the KMS vboxvideo driver.
--## @param $1 kernel version to update for.
--update_module_dependencies()
--{
-- depmod "${1}"
-- rm -f "/lib/modules/${1}/initrd/vboxvideo"
-- test -d "/lib/modules/${1}/initrd" &&
-- test -f "/lib/modules/${1}/misc/vboxvideo.ko" &&
-- touch "/lib/modules/${1}/initrd/vboxvideo"
-- test -n "${QUICKSETUP}" && return
-- if type dracut >/dev/null 2>&1; then
-- dracut -f "/boot/initramfs-${1}.img" "${1}"
-- elif type update-initramfs >/dev/null 2>&1; then
-- update-initramfs -u -k "${1}"
-- fi
--}
--
--# Remove any existing VirtualBox guest kernel modules from the disk, but not
--# from the kernel as they may still be in use
--cleanup_modules()
--{
-- if [ -n "$(which dkms 2>/dev/null)" ]; then
-- begin "Removing existing VirtualBox DKMS kernel modules"
-- $DODKMS uninstall $OLDMODULES > $LOG
-- succ_msg
-- fi
-- begin "Removing existing VirtualBox non-DKMS kernel modules"
-- for i in $OLDMODULES; do
-- find /lib/modules -name $i\* | xargs rm 2>/dev/null
-- done
-- succ_msg
--}
--
--# Build and install the VirtualBox guest kernel modules
--setup_modules()
--{
-- # don't stop the old modules here -- they might be in use
-- cleanup_modules
-- begin "Building the VirtualBox Guest Additions kernel modules"
--
-- # Short cut out if a dkms build succeeds
-- if [ -n "$(which dkms 2>/dev/null)" ] &&
-- $DODKMS install vboxguest $INSTALL_VER >> $LOG 2>&1; then
-- succ_msg
-- return 0
-- fi
--
-- test_for_gcc_and_make
-- test_sane_kernel_dir
--
-- echo
-- begin "Building the main Guest Additions module"
-- if ! $BUILDINTMP \
-- --save-module-symvers /tmp/vboxguest-Module.symvers \
-- --module-source $MODULE_SRC/vboxguest \
-- --no-print-directory install >> $LOG 2>&1; then
-- show_error "Look at $LOG to find out what went wrong"
-- return 1
-- fi
-- succ_msg
-- begin "Building the shared folder support module"
-- if ! $BUILDINTMP \
-- --use-module-symvers /tmp/vboxguest-Module.symvers \
-- --module-source $MODULE_SRC/vboxsf \
-- --no-print-directory install >> $LOG 2>&1; then
-- show_error "Look at $LOG to find out what went wrong"
-- return 1
-- fi
-- succ_msg
-- begin "Building the graphics driver module"
-- if ! $BUILDINTMP \
-- --use-module-symvers /tmp/vboxguest-Module.symvers \
-- --module-source $MODULE_SRC/vboxvideo \
-- --no-print-directory install >> $LOG 2>&1; then
-- show_error "Look at $LOG to find out what went wrong"
-- fi
-- succ_msg
-- update_module_dependencies "${KERN_VER}"
-- return 0
--}
--
--# Do non-kernel bits needed for the kernel modules to work properly (user
--# creation, udev, mount helper...)
--extra_setup()
--{
-- begin "Doing non-kernel setup of the Guest Additions"
-- echo "Creating user for the Guest Additions." >> $LOG
-- # This is the LSB version of useradd and should work on recent
-- # distributions
-- useradd -d /var/run/vboxadd -g 1 -r -s /bin/false vboxadd >/dev/null 2>&1
-- # And for the others, we choose a UID ourselves
-- useradd -d /var/run/vboxadd -g 1 -u 501 -o -s /bin/false vboxadd >/dev/null 2>&1
--
-- # Add a group "vboxsf" for Shared Folders access
-- # All users which want to access the auto-mounted Shared Folders have to
-- # be added to this group.
-- groupadd -r -f vboxsf >/dev/null 2>&1
--
-- # Create udev description file
-- if [ -d /etc/udev/rules.d ]; then
-- echo "Creating udev rule for the Guest Additions kernel module." >> $LOG
-- udev_call=""
-- udev_app=`which udevadm 2> /dev/null`
-- if [ $? -eq 0 ]; then
-- udev_call="${udev_app} version 2> /dev/null"
-- else
-- udev_app=`which udevinfo 2> /dev/null`
-- if [ $? -eq 0 ]; then
-- udev_call="${udev_app} -V 2> /dev/null"
-- fi
-- fi
-- udev_fix="="
-- if [ "${udev_call}" != "" ]; then
-- udev_out=`${udev_call}`
-- udev_ver=`expr "$udev_out" : '[^0-9]*\([0-9]*\)'`
-- if [ "$udev_ver" = "" -o "$udev_ver" -lt 55 ]; then
-- udev_fix=""
-- fi
-- fi
-- ## @todo 60-vboxadd.rules -> 60-vboxguest.rules ?
-- echo "KERNEL=${udev_fix}\"vboxguest\", NAME=\"vboxguest\", OWNER=\"vboxadd\", MODE=\"0660\"" > /etc/udev/rules.d/60-vboxadd.rules
-- echo "KERNEL=${udev_fix}\"vboxuser\", NAME=\"vboxuser\", OWNER=\"vboxadd\", MODE=\"0666\"" >> /etc/udev/rules.d/60-vboxadd.rules
-- fi
--
-- # Put mount.vboxsf in the right place
-- ln -sf "$lib_path/$PACKAGE/mount.vboxsf" /sbin
-- # And an rc file to re-build the kernel modules and re-set-up the X server.
-- ln -sf "$lib_path/$PACKAGE/vboxadd" /sbin/rcvboxadd
-- ln -sf "$lib_path/$PACKAGE/vboxadd-x11" /sbin/rcvboxadd-x11
-- # SELinux security context for the mount helper.
-- if test -e /etc/selinux/config; then
-- # This is correct. semanage maps this to the real path, and it aborts
-- # with an error, telling you what you should have typed, if you specify
-- # the real path. The "chcon" is there as a back-up in case this is
-- # different on old guests.
-- semanage fcontext -a -t mount_exec_t "/usr/lib/$PACKAGE/mount.vboxsf"
-- chcon -t mount_exec_t "$lib_path/$PACKAGE/mount.vboxsf"
-- fi
-- succ_msg
--}
--
- # setup_script
- setup()
- {
-- if test -r $config; then
-- . $config
-- else
-- fail "Configuration file $config not found"
-- fi
-- test -n "$INSTALL_DIR" -a -n "$INSTALL_VER" ||
-- fail "Configuration file $config not complete"
-- export BUILD_TYPE
-- export USERNAME
--
-- rm -f $LOG
-- MODULE_SRC="$INSTALL_DIR/src/vboxguest-$INSTALL_VER"
-- BUILDINTMP="$MODULE_SRC/build_in_tmp"
-- DODKMS="$MODULE_SRC/do_dkms"
-- chcon -t bin_t "$BUILDINTMP" > /dev/null 2>&1
-- chcon -t bin_t "$DODKMS" > /dev/null 2>&1
--
-- setup_modules
-- mod_succ="$?"
-- extra_setup
-- if [ "$mod_succ" -eq "0" ]; then
-- if running_vboxguest || running_vboxadd; then
-- printf "You should restart your guest to make sure the new modules are actually used\n\n"
-- else
-- start
-- fi
-- fi
-+ echo "Not implemented! Please use the virtualbox-kernel-addons.SlackBuild available at SlackBuilds.org instead."
- }
-
- # cleanup_script
- cleanup()
- {
-- if test -r $config; then
-- . $config
-- test -n "$INSTALL_DIR" -a -n "$INSTALL_VER" ||
-- fail "Configuration file $config not complete"
-- DODKMS="$INSTALL_DIR/src/vboxguest-$INSTALL_VER/do_dkms"
-- elif test -x ./do_dkms; then # Executing as part of the installer...
-- DODKMS=./do_dkms
-- else
-- fail "Configuration file $config not found"
-- fi
--
-- # Delete old versions of VBox modules.
-- cleanup_modules
-- for i in /lib/modules/*; do
-- update_module_dependencies "${i#/lib/modules/}"
-- done
--
-- # Remove old module sources
-- for i in $OLDMODULES; do
-- rm -rf /usr/src/$i-*
-- done
--
-- # Clean-up X11-related bits
-- /sbin/rcvboxadd-x11 cleanup
--
-- # Remove other files
-- rm /sbin/mount.vboxsf 2>/dev/null
-- rm /sbin/rcvboxadd 2>/dev/null
-- rm /sbin/rcvboxadd-x11 2>/dev/null
-- rm /etc/udev/rules.d/60-vboxadd.rules 2>/dev/null
-- rm -f /lib/modules/*/initrd/vboxvideo
-+ echo "Not implemented! Please use removepkg or pkgtool to remove virtualbox-addons and/or virtualbox-kernel-addons instead."
- }
-
- dmnstatus()
diff --git a/system/virtualbox-addons/vbox-uninstall-guest-additions b/system/virtualbox-addons/vbox-uninstall-guest-additions
index afa4e98ccd..71555a6a51 100644
--- a/system/virtualbox-addons/vbox-uninstall-guest-additions
+++ b/system/virtualbox-addons/vbox-uninstall-guest-additions
@@ -7,4 +7,4 @@
# provided by the distribution kernel package in place is acceptable if the
# location does not clash with the VirtualBox-provided module location (misc).
-/sbin/removepkg virtualbox-addons virtualbox-kernel-addons
+/sbin/removepkg virtualbox-addons
diff --git a/system/virtualbox-addons/virtualbox-addons.SlackBuild b/system/virtualbox-addons/virtualbox-addons.SlackBuild
index 951494fb7a..4d5f5b002c 100644
--- a/system/virtualbox-addons/virtualbox-addons.SlackBuild
+++ b/system/virtualbox-addons/virtualbox-addons.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for virtualbox-addons
-# Copyright 2008-2017 Heinz Wiesinger, Amsterdam, The Netherlands
+# Copyright 2008-2021 Heinz Wiesinger, Amsterdam, The Netherlands
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -11,22 +11,22 @@
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=virtualbox-addons
SRCNAM=VirtualBox
-VERSION=${VERSION:-5.0.40}
+VERSION=${VERSION:-6.1.26}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -60,11 +60,8 @@ fi
# kmk doesn't support MAKEFLAGS, so we use JOBS here
JOBS=${JOBS:-3}
-# set xorg-server version
-XSERVER=$(X -version 2>&1 | grep Server | cut -d " " -f 4 | sed "s/\.//" | cut -d "." -f 1)
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
TARGET="x86"
elif [ "$ARCH" = "i686" ]; then
@@ -92,13 +89,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# We don't want an init-script building kernel modules.
-# Use virtualbox-kernel-addons.SlackBuild for this.
-patch -d src/VBox/Additions/linux/installer/ -i $CWD/rc.vboxadd.diff
-
-# Cheat!
-sed -i "s|cc_maj -gt 7|cc_maj -gt 9|" configure
-
./configure \
--only-additions \
--disable-kmods \
@@ -106,27 +96,23 @@ sed -i "s|cc_maj -gt 7|cc_maj -gt 9|" configure
. ./env.sh
-OPENSSL=$(grep openssl src/libs/Makefile.kmk | cut -d "/" -f 2)
-
-mkdir -p src/libs/$OPENSSL
-touch src/libs/$OPENSSL/Makefile.kmk
-
kmk -j ${JOBS} LOCALCFG=$CWD/LocalConfig.kmk
mkdir -p $PKG/lib/udev/rules.d $PKG/sbin \
- $PKG/etc/{xdg/autostart,rc.d} \
- $PKG/usr/{src,bin,sbin,share/autostart} \
- $PKG/usr/lib$LIBDIRSUFFIX/xorg/modules/drivers
+ $PKG/lib$LIBDIRSUFFIX/security \
+ $PKG/etc/rc.d \
+ $PKG/usr/{bin,sbin}
-cp -f src/VBox/Additions/linux/installer/vboxadd.sh \
- $PKG/etc/rc.d/rc.vboxadd.new
cp -f src/VBox/Additions/linux/installer/vboxadd-service.sh \
$PKG/etc/rc.d/rc.vboxadd-service.new
+mkdir -p $PKG/etc/xdg/autostart \
+ $PKG/usr/share/autostart
cp -f src/VBox/Additions/x11/Installer/vboxclient.desktop \
$PKG/etc/xdg/autostart/
cp -f src/VBox/Additions/x11/Installer/vboxclient.desktop \
$PKG/usr/share/autostart/
+
install -m 755 src/VBox/Additions/x11/Installer/98vboxadd-xclient \
$PKG/usr/bin/VBoxClient-all
@@ -136,35 +122,22 @@ echo "KERNEL==\"vboxuser\", NAME=\"vboxuser\", OWNER=\"vboxadd\", MODE=\"0666\""
>> $PKG/lib/udev/rules.d/60-vboxadd.rules
cd out/linux.$TARGET/release/bin/additions
- cp -rf src/vboxguest $PKG/usr/src/vboxguest-$VERSION
- cp -rf src/vboxsf $PKG/usr/src/vboxsf-$VERSION
- cp -rf src/vboxvideo $PKG/usr/src/vboxvideo-$VERSION
install -m 755 VBoxControl $PKG/usr/bin/
install -m 755 VBoxClient $PKG/usr/bin/
+ install -m 4755 VBoxDRMClient $PKG/usr/bin/
install -m 755 VBoxService $PKG/usr/sbin/
install -m 4755 mount.vboxsf $PKG/sbin/mount.vboxsf
- install -m 644 vboxvideo_drv_$XSERVER.so \
- $PKG/usr/lib$LIBDIRSUFFIX/xorg/modules/drivers/vboxvideo_drv.so
-
- install -m 644 VBoxOGLcrutil.so $PKG/usr/lib$LIBDIRSUFFIX
- install -m 644 VBoxOGLerrorspu.so $PKG/usr/lib$LIBDIRSUFFIX
- install -m 644 VBoxOGLarrayspu.so $PKG/usr/lib$LIBDIRSUFFIX
- install -m 644 VBoxOGLfeedbackspu.so $PKG/usr/lib$LIBDIRSUFFIX
- install -m 644 VBoxOGLpackspu.so $PKG/usr/lib$LIBDIRSUFFIX
- install -m 644 VBoxOGLpassthroughspu.so $PKG/usr/lib$LIBDIRSUFFIX
- install -m 644 VBoxOGL.so $PKG/usr/lib$LIBDIRSUFFIX
+ install -m 755 pam_vbox.so $PKG/lib$LIBDIRSUFFIX/security/pam_vbox.so
install -m 755 $CWD/vbox-uninstall-guest-additions $PKG/usr/sbin/
-
- mkdir -p $PKG/usr/lib$LIBDIRSUFFIX/xorg/modules/dri
- ln -s /usr/lib$LIBDIRSUFFIX/VBoxOGL.so \
- $PKG/usr/lib$LIBDIRSUFFIX/xorg/modules/dri/vboxvideo_dri.so
cd -
-# kconf_update script to disable OpenGL within KDE
-mkdir -p $PKG/usr/share/apps/kconf_update $PKG/usr/share/config/
-install -m 644 $CWD/kwin_blacklist_vbox.sh $PKG/usr/share/apps/kconf_update/
-install -m 644 $CWD/kwinrc $PKG/usr/share/config/
+# kconf_update script to disable kscreen within KDE
+# See bug at https://bugs.kde.org/show_bug.cgi?id=407058
+mkdir -p $PKG/usr/share/kconf_update $PKG/etc/kde/xdg
+install -m 755 $CWD/plasma_disable_kscreen.sh $PKG/usr/share/kconf_update/
+install -m 644 $CWD/virtualbox_plasma_disable_kscreen.upd $PKG/usr/share/kconf_update/
+install -m 644 $CWD/kded5rc $PKG/etc/kde/xdg/
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/system/virtualbox-addons/virtualbox-addons.info b/system/virtualbox-addons/virtualbox-addons.info
index abee88d08e..4e8e1aefde 100644
--- a/system/virtualbox-addons/virtualbox-addons.info
+++ b/system/virtualbox-addons/virtualbox-addons.info
@@ -1,8 +1,8 @@
PRGNAM="virtualbox-addons"
-VERSION="5.0.40"
+VERSION="6.1.26"
HOMEPAGE="https://www.virtualbox.org"
-DOWNLOAD="http://download.virtualbox.org/virtualbox/5.0.40/VirtualBox-5.0.40.tar.bz2"
-MD5SUM="53b259e48a137b0185c169590e2dcb77"
+DOWNLOAD="http://download.virtualbox.org/virtualbox/6.1.26/VirtualBox-6.1.26.tar.bz2"
+MD5SUM="fce04bbef244b4df1a50e53d132d3e6f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/system/virtualbox-addons/virtualbox_plasma_disable_kscreen.upd b/system/virtualbox-addons/virtualbox_plasma_disable_kscreen.upd
new file mode 100644
index 0000000000..d1706fdbf3
--- /dev/null
+++ b/system/virtualbox-addons/virtualbox_plasma_disable_kscreen.upd
@@ -0,0 +1,6 @@
+Version=5
+
+# Disable kscreen inside virtualbox
+Id=virtualbox-plasma-disable-kscreen
+File=kded5rc
+Script=plasma_disable_kscreen.sh,sh