summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2021-08-29 19:17:46 +0200
committer Willy Sudiarto Raharjo2021-08-30 01:55:50 +0200
commit505267dac8cfd2710863a98143169ddf36ea21c8 (patch)
tree89330bfce34b773d63d8477886637d37fd114171
parent03d2fa026f845aaf749dce68a74065e491d25434 (diff)
downloadslackbuilds-505267dac8cfd2710863a98143169ddf36ea21c8.tar.gz
libraries/mathgl: Updated for version 2.4.4, use qt5.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/mathgl/mathgl.SlackBuild14
-rw-r--r--libraries/mathgl/mathgl.info6
2 files changed, 12 insertions, 8 deletions
diff --git a/libraries/mathgl/mathgl.SlackBuild b/libraries/mathgl/mathgl.SlackBuild
index a99f45ed6b..3527625222 100644
--- a/libraries/mathgl/mathgl.SlackBuild
+++ b/libraries/mathgl/mathgl.SlackBuild
@@ -18,14 +18,14 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=mathgl
-VERSION=${VERSION:-2.3.3}
+VERSION=${VERSION:-2.4.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -43,8 +43,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -93,6 +93,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+sed -i CMakeLists.txt \
+ -e "s|lib/cmake/mathgl|lib$LIBDIRSUFFIX/cmake/mathgl|" \
+ -e "s|\"lib\"|\"lib$LIBDIRSUFFIX\"|"
+
mkdir -p build
cd build
cmake -D CMAKE_C_FLAGS="$SLKCFLAGS" \
@@ -115,7 +119,7 @@ cd build
-D enable-octave:BOOL=$OCTAVE_FLAG \
-D enable-opengl:BOOL=ON \
-D enable-wx:BOOL=ON \
- -D enable-qt4:BOOL=ON \
+ -D enable-qt5:BOOL=ON \
-D CMAKE_BUILD_TYPE:STRING=$ARCH-slackware-linux .. -L
make
make install DESTDIR=$PKG
diff --git a/libraries/mathgl/mathgl.info b/libraries/mathgl/mathgl.info
index df540155a2..e231aa108f 100644
--- a/libraries/mathgl/mathgl.info
+++ b/libraries/mathgl/mathgl.info
@@ -1,8 +1,8 @@
PRGNAM="mathgl"
-VERSION="2.3.3"
+VERSION="2.4.4"
HOMEPAGE="http://mathgl.sourceforge.net"
-DOWNLOAD="http://downloads.sourceforge.net/mathgl/mathgl-2.3.3.tar.gz"
-MD5SUM="c37d6f42d4897675bf89fae635aa6868"
+DOWNLOAD="http://downloads.sourceforge.net/mathgl/mathgl-2.4.4.tar.gz"
+MD5SUM="cbf9bcb4db6c78bda7902d36b9843d7b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libharu wxPython"