summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Alexander Verbovetsky2021-08-08 03:04:15 +0200
committer Willy Sudiarto Raharjo2021-08-14 16:18:02 +0200
commite42dacf3c4103684927bca1363ce0551bf2b619b (patch)
tree343c3873da847f373083fc23d8895303c655930a
parentd7bb682fd76fc1d93ffdade3ccf9c3074d19de5c (diff)
downloadslackbuilds-e42dacf3c4103684927bca1363ce0551bf2b619b.tar.gz
libraries/libbson: Removed (no longer needed)
This was used by desktop/fvwm3/ but is not any more. Signed-off-by: Robby Workman <rworkman@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/libbson/README10
-rw-r--r--libraries/libbson/libbson.SlackBuild130
-rw-r--r--libraries/libbson/libbson.info10
-rw-r--r--libraries/libbson/slack-desc19
4 files changed, 0 insertions, 169 deletions
diff --git a/libraries/libbson/README b/libraries/libbson/README
deleted file mode 100644
index 151c173687..0000000000
--- a/libraries/libbson/README
+++ /dev/null
@@ -1,10 +0,0 @@
-A cross platform BSON Library for C
-
-libbson builds, parses, and iterates BSON documents, the native data
-format of MongoDB. It also converts BSON to and from JSON, and provides
-a platform compatibility layer for the MongoDB C Driver.
-
-libbson conflicts with mongo-c-driver.
-
-To build the libbson documentation, install Sphinx and set
-DOCS=yes
diff --git a/libraries/libbson/libbson.SlackBuild b/libraries/libbson/libbson.SlackBuild
deleted file mode 100644
index da0982fa2c..0000000000
--- a/libraries/libbson/libbson.SlackBuild
+++ /dev/null
@@ -1,130 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for libbson
-
-# Copyright 2020, Alexander Verbovetsky, Moscow, Russia
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=libbson
-SRCNAM=mongo-c-driver
-VERSION=${VERSION:-1.17.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $TMP/$PKGNAM-$VERSION $PKG
-mkdir -p $TMP/$PKGNAM-$VERSION $PKG $OUTPUT
-cd $TMP/$PKGNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-PDOCS=""
-MkDOCS=""
-if [ "${DOCS:-no}" = "yes" ]; then
- PDOCS="-DENABLE_MAN_PAGES=ON -DENABLE_HTML_DOCS=ON"
- MkDOCS="bson-doc"
-fi
-
-cd $SRCNAM-$VERSION/build
- cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DENABLE_STATIC=OFF \
- -DENABLE_TESTS=OFF \
- -DENABLE_AUTOMATIC_INIT_AND_CLEANUP=OFF \
- -DENABLE_MONGOC=OFF \
- $PDOCS \
- -DCMAKE_BUILD_TYPE=Release ..
- make $MkDOCS
- make install DESTDIR=$PKG
-cd ..
-
-rm -rf $PKG/usr/share
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-
-if [ "${DOCS:-no}" = "yes" ]; then
- mkdir -p $PKG/usr/man
- cd src/$PRGNAM/doc
- rm -f {html,man}/CMakeLists.txt
- mv man $PKG/usr/man/man3
- mv html $PKG/usr/doc/$PRGNAM-$VERSION
- cd ../../..
-
- find $PKG/usr/man -type f -exec gzip -9 {} \;
- for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-fi
-
-cp -a NEWS THIRD_PARTY_NOTICES README.rst CONTRIBUTING.md \
- src/libbson/examples $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/libbson/libbson.info b/libraries/libbson/libbson.info
deleted file mode 100644
index 91ce2421d6..0000000000
--- a/libraries/libbson/libbson.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="libbson"
-VERSION="1.17.3"
-HOMEPAGE="https://mongoc.org/libbson/current/index.html"
-DOWNLOAD="https://github.com/mongodb/mongo-c-driver/releases/download/1.17.3/mongo-c-driver-1.17.3.tar.gz"
-MD5SUM="9babfd9883e7c02bd0d7624ea286ee82"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Alexander Verbovetsky"
-EMAIL="alik@ejik.org"
diff --git a/libraries/libbson/slack-desc b/libraries/libbson/slack-desc
deleted file mode 100644
index 291f5fe177..0000000000
--- a/libraries/libbson/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-libbson: libbson (a cross platform BSON Library for C)
-libbson:
-libbson: libbson builds, parses, and iterates BSON documents, the native data
-libbson: format of MongoDB. It also converts BSON to and from JSON, and
-libbson: provides a platform compatibility layer for the MongoDB C Driver.
-libbson:
-libbson: Homepage: https://mongoc.org/libbson/current/index.html
-libbson:
-libbson:
-libbson:
-libbson: