summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andrew Clemons2021-12-19 00:47:21 +0100
committer Willy Sudiarto Raharjo2021-12-27 10:20:29 +0100
commit9777a7d2e185b5547d9d166fdf23c875ac07b6fd (patch)
tree1099c60cc42e42b3a146d10814a9c6c0ee5ee240
parentf8e4e9d86950fcca1acc70b330ec18ba6d8c2d1d (diff)
downloadslackbuilds-9777a7d2e185b5547d9d166fdf23c875ac07b6fd.tar.gz
python/python-css-parser: Duplicate of css-parser.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-css-parser/README1
-rw-r--r--python/python-css-parser/python-css-parser.SlackBuild99
-rw-r--r--python/python-css-parser/python-css-parser.info10
-rw-r--r--python/python-css-parser/slack-desc19
4 files changed, 0 insertions, 129 deletions
diff --git a/python/python-css-parser/README b/python/python-css-parser/README
deleted file mode 100644
index bab8811f67..0000000000
--- a/python/python-css-parser/README
+++ /dev/null
@@ -1 +0,0 @@
-python-css-parser - A Cascading Style Sheets library for Python
diff --git a/python/python-css-parser/python-css-parser.SlackBuild b/python/python-css-parser/python-css-parser.SlackBuild
deleted file mode 100644
index d139fff641..0000000000
--- a/python/python-css-parser/python-css-parser.SlackBuild
+++ /dev/null
@@ -1,99 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python-css-parser
-
-# Copyright 2021 Andrew Clemons, Wellington New Zealand
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python-css-parser
-SRCNAM=css-parser
-VERSION=${VERSION:-1.0.6}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- COPYING.LESSER PKG-INFO README.md \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python-css-parser/python-css-parser.info b/python/python-css-parser/python-css-parser.info
deleted file mode 100644
index ae26bab96f..0000000000
--- a/python/python-css-parser/python-css-parser.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-css-parser"
-VERSION="1.0.6"
-HOMEPAGE="https://github.com/ebook-utils/css-parser"
-DOWNLOAD="https://files.pythonhosted.org/packages/79/a5/4c11875f4adc8a3a37b79546dcba6304efdf1ca944e390aeb0fced4ee2ff/css-parser-1.0.6.tar.gz"
-MD5SUM="ee8837d255391101f00cf88bd3ea84a2"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Andrew Clemons"
-EMAIL="andrew.clemons@gmail.com"
diff --git a/python/python-css-parser/slack-desc b/python/python-css-parser/slack-desc
deleted file mode 100644
index 9e5d5cc78d..0000000000
--- a/python/python-css-parser/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-css-parser: python-css-parser (Cascading Style Sheets library for Python)
-python-css-parser:
-python-css-parser: A fork of the cssutils project based on version 1.0.2. This fork
-python-css-parser: includes general bug fixes and extensions specific to editing and
-python-css-parser: working with ebooks.
-python-css-parser:
-python-css-parser: https://github.com/ebook-utils/css-parser
-python-css-parser:
-python-css-parser:
-python-css-parser:
-python-css-parser: