summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2021-12-13 20:25:13 +0100
committer Willy Sudiarto Raharjo2021-12-27 10:20:25 +0100
commit8d61cecb26caf2dcae7542c7eb15d94af9d03f0c (patch)
tree6e514e24563983c9db40ce12903b745da89e8dbb
parent2338b8ba1927ca01a0ee9945cfac6d63d8b5cf5e (diff)
downloadslackbuilds-8d61cecb26caf2dcae7542c7eb15d94af9d03f0c.tar.gz
audio/grip2: Removed (replaced with grip).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--audio/grip2/README18
-rw-r--r--audio/grip2/doinst.sh10
-rw-r--r--audio/grip2/dot.grip.sample55
-rw-r--r--audio/grip2/grip2.SlackBuild116
-rw-r--r--audio/grip2/grip2.desktop7
-rw-r--r--audio/grip2/grip2.info10
-rw-r--r--audio/grip2/patches/grip2-nptl.diff12
-rw-r--r--audio/grip2/patches/grip2.diff18
-rw-r--r--audio/grip2/patches/system_cdparanoia_libs.diff44
-rw-r--r--audio/grip2/slack-desc19
10 files changed, 0 insertions, 309 deletions
diff --git a/audio/grip2/README b/audio/grip2/README
deleted file mode 100644
index 4cf5e11247..0000000000
--- a/audio/grip2/README
+++ /dev/null
@@ -1,18 +0,0 @@
-Grip is a gtk-based cd-player and cd-ripper. It has the ripping
-capabilities of cdparanoia builtin, but can also use external rippers
-(such as cdda2wav).
-
-This is an older version of Grip that does not require GNOME. If you're
-looking for a modern version of Grip, see the package "grip".
-
-By default, it is safe to install grip2 and grip at the same time,
-although not particularly useful. If you don't plan to install both,
-pass SMYLINKS=yes to the build script. This will allow you to run
-"grip" and/or "gcd" (instead of having to say "grip2" and "gcd2"). Note
-that with SMYLINKS=yes, this package will conflict with the regular
-grip package.
-
-Before running grip2 for the first time, you may want to copy the file
-"/usr/doc/grip2-2.96/dot.grip.sample" to "$HOME/.grip". This sets the
-default encoder to oggenc, and puts the track number at the front of
-each output filename.
diff --git a/audio/grip2/doinst.sh b/audio/grip2/doinst.sh
deleted file mode 100644
index d6430a30c5..0000000000
--- a/audio/grip2/doinst.sh
+++ /dev/null
@@ -1,10 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications &> /dev/null
-fi
-
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
- fi
-fi
-
diff --git a/audio/grip2/dot.grip.sample b/audio/grip2/dot.grip.sample
deleted file mode 100644
index 4daca9a89a..0000000000
--- a/audio/grip2/dot.grip.sample
+++ /dev/null
@@ -1,55 +0,0 @@
-GRIP 1
-ripexename /usr/bin/cdparanoia
-ripcmdline -d %c %t:[.%b]-%t:[.%e] %f
-wav_filter_cmd
-mp3exename /usr/bin/oggenc
-mp3cmdline -o %o -a "%A" -l "%d" -t "%n" %f
-dbserver freedb.freedb.org
-ripfileformat ~/mp3/%a/%d/%n.wav
-mp3fileformat ~/mp3/%a/%d/%n.ogg
-m3ufileformat ~/mp3/%a-%d.m3u
-delete_wavs 1
-add_m3u 1
-rel_m3u 1
-add_to_db 0
-outputdir
-use_proxy 0
-proxy_name
-proxy_port 8000
-cdupdate
-user_email nobody@example.com
-ripnice 0
-mp3nice 0
-doid3 1
-max_wavs 99
-auto_rip 0
-eject_after_rip 0
-eject_delay 0
-beep_after_rip 0
-faulty_eject 0
-use_proxy_env 0
-db_cgi ~cddb/cddb.cgi
-cddb_submit_email freedb-submit@freedb.org
-dbserver2
-db2_cgi ~cddb/cddb.cgi
-no_interrupt 0
-stop_first 0
-play_first 1
-automatic_cddb 1
-automatic_reshuffle 1
-no_lower_case 0
-no_underscore 0
-allow_high_bits 0
-allow_these_chars
-keep_min_size 1
-num_cpu 1
-kbits_per_sec 128
-selected_encoder 6
-selected_ripper 0
-disable_paranoia 0
-disable_extra_paranoia 0
-disable_scratch_detect 0
-disable_scratch_repair 0
-play_mode 0
-playloop 1
-volume 255
diff --git a/audio/grip2/grip2.SlackBuild b/audio/grip2/grip2.SlackBuild
deleted file mode 100644
index c418dd33e0..0000000000
--- a/audio/grip2/grip2.SlackBuild
+++ /dev/null
@@ -1,116 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for grip
-
-# Written by B. Watson (yalhcru@gmail.com)
-
-# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=grip2
-SRCNAM=grip
-VERSION=${VERSION:-2.96}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tgz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-SLKCFLAGS="$SLKCFLAGS -std=gnu89"
-
-# Slack 12.2 and up keeps cdda headers in /usr/include/cdda, 12.1 has them
-# in /usr/include itself. Be adaptable.
-if [ -r /usr/include/cdda/cdda_interface.h ]; then
- SLKCFLAGS="$SLKCFLAGS -I/usr/include/cdda"
-fi
-
-# Patch to use system-installed cdparanoia libs:
-patch -p1 --verbose < $CWD/patches/system_cdparanoia_libs.diff
-
-# Patch to fix a compile issue with threads (probably came from gentoo):
-patch -p1 --verbose < $CWD/patches/grip2-nptl.diff
-
-# Patch to install binaries/manpages as grip2 and gcd2 (so as not to conflict
-# with the grip 3.x package).
-patch -p1 --verbose < $CWD/patches/grip2.diff
-
-# The Makefile ignores any CFLAGS we pass in, so:
-perl -i.bak -pe 's,(CFLAGS\s*=\s*),$1 '"$SLKCFLAGS"' ,' Makefile
-
-make EXE_SUFFIX=2
-
-# DESTDIR not supported.
-make install PREFIX=$PKG/usr EXE_SUFFIX=2
-
-strip --strip-unneeded $PKG/usr/bin/*
-
-rm -f $PKG/usr/man/man1/gcd*
-gzip $PKG/usr/man/man1/$PRGNAM.1
-( cd $PKG/usr/man/man1 && ln -s $PRGNAM.1.gz gcd2.1.gz )
-
-# Why does it create an empty usr/lib dir?
-rm -rf $PKG/usr/lib
-
-mkdir -p $PKG/usr/share/{applications,pixmaps}
-cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications
-cp pixmaps/$SRCNAM.xpm $PKG/usr/share/pixmaps/$PRGNAM.xpm
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- $CWD/dot.grip.sample CHANGES CREDITS LICENSE README TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-chown -R root:root $PKG/usr/doc ; chmod 0644 $PKG/usr/doc/$PRGNAM-$VERSION/*
-
-if [ "${SYMLINKS:-no}" = "yes" ]; then
- ln -s grip2 $PKG/usr/bin/grip
- ln -s gcd2 $PKG/usr/bin/gcd
- ln -s grip2.1.gz $PKG/usr/man/man1/grip.1.gz
- ln -s grip2.1.gz $PKG/usr/man/man1/gcd.1.gz
-fi
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/audio/grip2/grip2.desktop b/audio/grip2/grip2.desktop
deleted file mode 100644
index 98d09d00ab..0000000000
--- a/audio/grip2/grip2.desktop
+++ /dev/null
@@ -1,7 +0,0 @@
-[Desktop Entry]
-Name=Grip 2
-Exec=grip2
-Type=Application
-Icon=grip2
-GenericName=Grip 2 CD Ripper
-Categories=AudioVideo;Audio;
diff --git a/audio/grip2/grip2.info b/audio/grip2/grip2.info
deleted file mode 100644
index b3e9c3e959..0000000000
--- a/audio/grip2/grip2.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="grip2"
-VERSION="2.96"
-HOMEPAGE="https://sourceforge.net/projects/grip/"
-DOWNLOAD="https://downloads.sourceforge.net/grip/grip-2.96.tgz"
-MD5SUM="29d03b2874c5cb60096ac3051fbbc4e3"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
diff --git a/audio/grip2/patches/grip2-nptl.diff b/audio/grip2/patches/grip2-nptl.diff
deleted file mode 100644
index 36968fc3fd..0000000000
--- a/audio/grip2/patches/grip2-nptl.diff
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur grip-2.93.orig/grip.c grip-2.93/grip.c
---- grip-2.93.orig/grip.c 2007-04-19 01:15:23.000000000 -0400
-+++ grip-2.93/grip.c 2007-04-19 01:34:39.000000000 -0400
-@@ -1637,7 +1637,7 @@
- #if defined(SOLARIS) || defined(__FreeBSD__)
- pthread_exit(&status);
- #else
-- pthread_kill_other_threads_np();
-+ /* pthread_kill_other_threads_np(); */
- #endif
- Debug("Aborted\n");
- looking_up=FALSE;
diff --git a/audio/grip2/patches/grip2.diff b/audio/grip2/patches/grip2.diff
deleted file mode 100644
index e62fdd2777..0000000000
--- a/audio/grip2/patches/grip2.diff
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -Naur grip-2.96/Makefile grip-2.96.patched//Makefile
---- grip-2.96/Makefile 2001-07-16 12:15:32.000000000 -0400
-+++ grip-2.96.patched//Makefile 2011-06-27 08:42:13.000000000 -0400
-@@ -72,11 +72,11 @@
-
- install:
- $(INSTALL) -d $(INSTALLDIR)
-- $(INSTALL) grip $(INSTALLDIR)
-- $(INSTALL) gcd $(INSTALLDIR)
-+ $(INSTALL) grip $(INSTALLDIR)/grip$(EXE_SUFFIX)
-+ $(INSTALL) gcd $(INSTALLDIR)/gcd$(EXE_SUFFIX)
- $(INSTALL) -d $(AUXDIR)
- $(INSTALL) -d $(PREFIX)/man/man1
-- $(INSTALL) grip.1 $(PREFIX)/man/man1
-+ $(INSTALL) grip.1 $(PREFIX)/man/man1/grip$(EXE_SUFFIX).1
- $(INSTALL) grip.1 $(PREFIX)/man/man1/gcd.1
-
- gcdinstall:
diff --git a/audio/grip2/patches/system_cdparanoia_libs.diff b/audio/grip2/patches/system_cdparanoia_libs.diff
deleted file mode 100644
index 7656af8107..0000000000
--- a/audio/grip2/patches/system_cdparanoia_libs.diff
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -Naur grip-2.96.orig/Makefile grip-2.96/Makefile
---- grip-2.96.orig/Makefile 2001-07-16 12:15:32.000000000 -0400
-+++ grip-2.96/Makefile 2009-02-05 00:38:28.000000000 -0500
-@@ -28,8 +28,8 @@
- ifeq ($(OS), FreeBSD)
- LIBS+= -pthread
- endif
--PARLIBS= cdparanoia/interface/libcdda_interface.a \
-- cdparanoia/paranoia/libcdda_paranoia.a
-+PARLIBS= -lcdda_interface \
-+ -lcdda_paranoia
-
- # This is needed for "make install"
- OWNER = root
-diff -Naur grip-2.96.orig/cdpar.c grip-2.96/cdpar.c
---- grip-2.96.orig/cdpar.c 2001-07-16 12:15:32.000000000 -0400
-+++ grip-2.96/cdpar.c 2009-02-05 00:39:02.000000000 -0500
-@@ -36,9 +36,9 @@
- #define size16 short
- #define size32 int
-
--#include "cdparanoia/interface/cdda_interface.h"
--#include "cdparanoia/paranoia/cdda_paranoia.h"
--#include "cdparanoia/utils.h"
-+#include <cdda_interface.h>
-+#include <cdda_paranoia.h>
-+#include <utils.h>
-
- static void PutNum(long num,int f,int endianness,int bytes);
- static void WriteWav(int f,long bytes);
-diff -Naur grip-2.96.orig/grip.c grip-2.96/grip.c
---- grip-2.96.orig/grip.c 2001-07-16 12:15:32.000000000 -0400
-+++ grip-2.96/grip.c 2009-02-05 00:42:26.000000000 -0500
-@@ -57,8 +57,8 @@
- #ifdef CDPAR
- #define size16 short
- #define size32 int
--#include "cdparanoia/interface/cdda_interface.h"
--#include "cdparanoia/paranoia/cdda_paranoia.h"
-+#include <cdda_interface.h>
-+#include <cdda_paranoia.h>
- #endif
-
- void ShutDownCB(void);
diff --git a/audio/grip2/slack-desc b/audio/grip2/slack-desc
deleted file mode 100644
index 9bb62fb721..0000000000
--- a/audio/grip2/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-grip2: grip2 (graphical CD player and ripper)
-grip2:
-grip2: Grip is a gtk-based cd-player and cd-ripper. It has the ripping
-grip2: capabilities of cdparanoia builtin, but can also use external
-grip2: rippers (such as cdda2wav).
-grip2:
-grip2: This is an older version of Grip that does not require GNOME.
-grip2:
-grip2: homepage: http://sourceforge.net/projects/grip/
-grip2:
-grip2: