summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis2020-09-18 20:15:19 +0200
committer Willy Sudiarto Raharjo2020-09-18 20:15:19 +0200
commit8636b30a153caca3fa7eeb1c56a0ac81ff239231 (patch)
tree3dc219ffd11e8c16d71e92a42897f4d20ca419a3
parente15590ead80cd9e6c8e16d737f34341e0aa39d8e (diff)
downloadslackbuilds-8636b30a153caca3fa7eeb1c56a0ac81ff239231.tar.gz
python/python3-rsa: Added (pure-Python RSA implementation).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-rsa/README3
-rw-r--r--python/python3-rsa/python3-rsa.SlackBuild86
-rw-r--r--python/python3-rsa/python3-rsa.info10
-rw-r--r--python/python3-rsa/slack-desc19
4 files changed, 118 insertions, 0 deletions
diff --git a/python/python3-rsa/README b/python/python3-rsa/README
new file mode 100644
index 0000000000..3507fb1355
--- /dev/null
+++ b/python/python3-rsa/README
@@ -0,0 +1,3 @@
+Python-RSA is a pure-Python RSA implementation.
+It supports encryption and decryption, signing and verifying signatures,
+and key generation according to PKCS#1 version 1.5.
diff --git a/python/python3-rsa/python3-rsa.SlackBuild b/python/python3-rsa/python3-rsa.SlackBuild
new file mode 100644
index 0000000000..149f33f998
--- /dev/null
+++ b/python/python3-rsa/python3-rsa.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for python3-rsa
+
+# Copyright 2020 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python3-rsa
+SRCNAM=rsa
+VERSION=${VERSION:-4.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-rsa/python3-rsa.info b/python/python3-rsa/python3-rsa.info
new file mode 100644
index 0000000000..c4c3b72723
--- /dev/null
+++ b/python/python3-rsa/python3-rsa.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-rsa"
+VERSION="4.6"
+HOMEPAGE="https://stuvel.eu/software/rsa/"
+DOWNLOAD="https://files.pythonhosted.org/packages/a2/d5/04b8a9719149583fec76efdff2e7a81c6e3cc34909ee818d3fbf115edc2e/rsa-4.6.tar.gz"
+MD5SUM="bbf1c954865319bd542600ab07f92aca"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pyasn1 python3"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/python3-rsa/slack-desc b/python/python3-rsa/slack-desc
new file mode 100644
index 0000000000..dffa3239e7
--- /dev/null
+++ b/python/python3-rsa/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-rsa: python3-rsa (pure-Python RSA implementation)
+python3-rsa:
+python3-rsa: It supports encryption and decryption, signing and verifying
+python3-rsa: signatures, and key generation according to PKCS#1 version 1.5.
+python3-rsa: It can be used as a Python library as well as on the commandline.
+python3-rsa: The code was mostly written by Sybren A. Stüvel
+python3-rsa:
+python3-rsa: Homepage: https://stuvel.eu/software/rsa/
+python3-rsa:
+python3-rsa:
+python3-rsa: