summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Alexander Verbovetsky2020-09-18 19:31:53 +0200
committer Willy Sudiarto Raharjo2020-09-18 19:31:53 +0200
commit49625f5aff5e83cc1cc3afc091fea9de74819abb (patch)
tree86db5f5d6e6d01f5a0bd8b7c730e080db65f188f
parent421ba2d55d4eed401eca7f1abfdd1499bc7e5e24 (diff)
downloadslackbuilds-49625f5aff5e83cc1cc3afc091fea9de74819abb.tar.gz
desktop/fvwm3: Added (fvwm window manager).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--desktop/fvwm3/README18
-rw-r--r--desktop/fvwm3/fvwm3.SlackBuild157
-rw-r--r--desktop/fvwm3/fvwm3.info26
-rw-r--r--desktop/fvwm3/slack-desc19
-rw-r--r--desktop/fvwm3/startfvwm3.gzbin0 -> 218 bytes
-rw-r--r--desktop/fvwm3/xinitrc.fvwm3.gzbin0 -> 360 bytes
6 files changed, 220 insertions, 0 deletions
diff --git a/desktop/fvwm3/README b/desktop/fvwm3/README
new file mode 100644
index 0000000000..b3b2977903
--- /dev/null
+++ b/desktop/fvwm3/README
@@ -0,0 +1,18 @@
+Fvwm3 is the newest version of the fvwm window manager, the successor to
+fvwm2.
+
+Fvwm3 is a multiple large virtual desktop window manager, originally (a
+looooong time ago!) derived from twm.
+
+Fvwm3 is intended to have a small memory footprint but a rich feature
+set, be extremely customizable and extendible, and have a high degree of
+Motif mwm compatibility.
+
+This package does not conflict with the stock fvwm package.
+
+Manpages for fvwm3 modules were moved as follows:
+FvwmAnimate --> Fvwm3Animate
+FvwmAuto --> Fvwm3Auto
+...
+
+google-go-lang is needed only at build time.
diff --git a/desktop/fvwm3/fvwm3.SlackBuild b/desktop/fvwm3/fvwm3.SlackBuild
new file mode 100644
index 0000000000..5f91166f30
--- /dev/null
+++ b/desktop/fvwm3/fvwm3.SlackBuild
@@ -0,0 +1,157 @@
+#!/bin/sh
+
+# Slackware build script for fvwm3
+
+# Copyright 2020, Alexander Verbovetsky, Moscow, Russia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=fvwm3
+VERSION=${VERSION:-1.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+sed -i '/^@FVWM_BUILD_GOLANG_TRUE@GOBUILD = $(GOCMD) build/s/$/ -mod=vendor/' \
+ bin/FvwmPrompt/Makefile.in
+
+sed -i 's/go1.14\*)/go1.13\* | go1.14\*)/' configure
+
+mkdir -p bin/FvwmPrompt/vendor/golang.org/x
+for DEPENDENCY in \
+ abiosoft/ishell/2.0.0 \
+ abiosoft/readline/155bce2042db95a783081fab225e74dd879055b0 \
+ fatih/color/1.9.0 \
+ flynn-archive/go-shlex/3f9db97f856818214da2e1057f8ad84803971cff \
+ mattn/go-colorable/0.1.4 \
+ mattn/go-isatty/0.0.12 \
+ sirupsen/logrus/1.6.0 \
+ golang/sys/12a6c2dcc1e4cb348b57847c73987099e261714b
+do
+ DEPENDENCY_OWNER="$(echo "$DEPENDENCY" | cut -d/ -f1)"
+ DEPENDENCY_NAME="$(echo "$DEPENDENCY" | cut -d/ -f2)"
+ DEPENDENCY_REV="$(echo "$DEPENDENCY" | cut -d/ -f3)"
+ mkdir -p "bin/FvwmPrompt/vendor/github.com/$DEPENDENCY_OWNER"
+ tar xvf "$CWD/$DEPENDENCY_NAME-$DEPENDENCY_REV.tar.gz"
+ if [ "$DEPENDENCY_OWNER" = "golang" ]; then
+ mv "$DEPENDENCY_NAME-$DEPENDENCY_REV" \
+ "bin/FvwmPrompt/vendor/golang.org/x/$DEPENDENCY_NAME"
+ else
+ mv "$DEPENDENCY_NAME-$DEPENDENCY_REV" \
+ "bin/FvwmPrompt/vendor/github.com/$DEPENDENCY_OWNER/$DEPENDENCY_NAME"
+ fi
+done
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --enable-mandoc \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-golang \
+ --program-prefix= \
+ --program-suffix= \
+ --program-transform-name='s/^fvwm-/fvwm3-/' \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+zcat $CWD/startfvwm3.gz > $PKG/usr/bin/startfvwm3
+chmod 755 $PKG/usr/bin/startfvwm3
+
+mkdir -p $PKG/etc/X11/xinit
+zcat $CWD/xinitrc.fvwm3.gz > $PKG/etc/X11/xinit/xinitrc.fvwm3
+chmod 755 $PKG/etc/X11/xinit/xinitrc.fvwm3
+
+rm -rf $PKG/usr/share/doc
+
+rm -rf $PKG/usr/share/locale
+
+rm -rf $PKG/usr/bin/fvwm3-convert-2.6
+rm -rf $PKG/usr/man/man1/fvwm3-convert-2.6.1.gz
+
+mv $PKG/usr/bin/xpmroot $PKG/usr/bin/xpmroot3
+mv $PKG/usr/man/man1/xpmroot.1 $PKG/usr/man/man1/xpmroot3.1
+
+for m in $PKG/usr/man/man1/Fvwm* ; do
+ mv $m ${m/Fvwm/Fvwm3}
+done
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a NEWS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/fvwm3/fvwm3.info b/desktop/fvwm3/fvwm3.info
new file mode 100644
index 0000000000..834bb54491
--- /dev/null
+++ b/desktop/fvwm3/fvwm3.info
@@ -0,0 +1,26 @@
+PRGNAM="fvwm3"
+VERSION="1.0.0"
+HOMEPAGE="https://github.com/fvwmorg/fvwm3"
+DOWNLOAD="https://github.com/fvwmorg/fvwm3/releases/download/1.0.0/fvwm3-1.0.0.tar.gz \
+ https://github.com/abiosoft/ishell/archive/v2.0.0/ishell-2.0.0.tar.gz \
+ https://github.com/abiosoft/readline/archive/155bce2042db95a783081fab225e74dd879055b0/readline-155bce2042db95a783081fab225e74dd879055b0.tar.gz \
+ https://github.com/fatih/color/archive/v1.9.0/color-1.9.0.tar.gz \
+ https://github.com/flynn-archive/go-shlex/archive/3f9db97f856818214da2e1057f8ad84803971cff/go-shlex-3f9db97f856818214da2e1057f8ad84803971cff.tar.gz \
+ https://github.com/mattn/go-colorable/archive/v0.1.4/go-colorable-0.1.4.tar.gz \
+ https://github.com/mattn/go-isatty/archive/v0.0.12/go-isatty-0.0.12.tar.gz \
+ https://github.com/sirupsen/logrus/archive/v1.6.0/logrus-1.6.0.tar.gz \
+ https://github.com/golang/sys/archive/12a6c2dcc1e4cb348b57847c73987099e261714b/sys-12a6c2dcc1e4cb348b57847c73987099e261714b.tar.gz"
+MD5SUM="76949120b69a66141e2121ace8d3b6db \
+ 3058feb8c64ce23c122c212673a769fc \
+ 5f9283762aece4866ec12481c911dc04 \
+ 63c08b74df39b3df587594710c13d543 \
+ 73c1c839e2866ecfe7ad25aa21dd74d6 \
+ c67b2200da0ec27b69b62afc308b6d0c \
+ 56a6121ba7ae8a13dad2925edd9f11b5 \
+ 7e9bd1531d38f1994307cc2cd9435cb9 \
+ 62bb00c7e07850c8fa836a3614667ded"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="libbson google-go-lang"
+MAINTAINER="Alexander Verbovetsky"
+EMAIL="alik@ejik.org"
diff --git a/desktop/fvwm3/slack-desc b/desktop/fvwm3/slack-desc
new file mode 100644
index 0000000000..5c368a484d
--- /dev/null
+++ b/desktop/fvwm3/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+fvwm3: fvwm3 (the newest version of the fvwm window manager)
+fvwm3:
+fvwm3: Fvwm3 is a multiple large virtual desktop window manager, originally
+fvwm3: (a looooong time ago!) derived from twm. The successor to fvwm2.
+fvwm3: Fvwm3 is intended to have a small memory footprint but a rich feature
+fvwm3: set, be extremely customizable and extendible, and have a high degree
+fvwm3: of Motif mwm compatibility.
+fvwm3:
+fvwm3: Homepage: https://github.com/fvwmorg/fvwm3
+fvwm3:
+fvwm3:
diff --git a/desktop/fvwm3/startfvwm3.gz b/desktop/fvwm3/startfvwm3.gz
new file mode 100644
index 0000000000..6c1aed5d31
--- /dev/null
+++ b/desktop/fvwm3/startfvwm3.gz
Binary files differ
diff --git a/desktop/fvwm3/xinitrc.fvwm3.gz b/desktop/fvwm3/xinitrc.fvwm3.gz
new file mode 100644
index 0000000000..269016347b
--- /dev/null
+++ b/desktop/fvwm3/xinitrc.fvwm3.gz
Binary files differ