summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Hunter Sezen2019-08-24 18:39:48 +0200
committer Willy Sudiarto Raharjo2019-08-24 18:39:48 +0200
commit206471ef62d70a606d922385dbd9b1e1d5ee38ab (patch)
tree9628bdf34fe06defbf835d56989ec184d45804ac
parentac90c0b4092f40be2ca4f68779faa69d6a73e360 (diff)
downloadslackbuilds-206471ef62d70a606d922385dbd9b1e1d5ee38ab.tar.gz
libraries/spdlog: Updated for version 1.3.1, moved from development.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/spdlog/README20
-rw-r--r--development/spdlog/spdlog.info10
-rw-r--r--development/spdlog/spdlog.patch15
-rw-r--r--libraries/spdlog/README3
-rw-r--r--libraries/spdlog/slack-desc (renamed from development/spdlog/slack-desc)12
-rw-r--r--libraries/spdlog/spdlog.SlackBuild (renamed from development/spdlog/spdlog.SlackBuild)44
-rw-r--r--libraries/spdlog/spdlog.info10
7 files changed, 35 insertions, 79 deletions
diff --git a/development/spdlog/README b/development/spdlog/README
deleted file mode 100644
index 4534bd5cba..0000000000
--- a/development/spdlog/README
+++ /dev/null
@@ -1,20 +0,0 @@
-spdlog is very fast, header only, C++ logging library.
-
-Features:
-- Very fast - performance is the primary goal (see benchmarks below).
-- Headers only, just copy and use.
-- Feature rich call style using the excellent fmt library.
-- Extremely fast asynchronous mode (optional) - using lockfree queues
- and other tricks to reach millions of calls/sec.
-- Custom formatting.
-- Multi/Single threaded loggers.
-- Various log targets:
- - Rotating log files.
- - Daily log files.
- - Console logging (colors supported).
- - syslog.
- - Windows debugger (OutputDebugString(..))
- - Easily extendable with custom log targets (just implement a single
- function in the sink interface).
-- Severity based filtering - threshold levels can be modified in
- runtime as well as in compile time.
diff --git a/development/spdlog/spdlog.info b/development/spdlog/spdlog.info
deleted file mode 100644
index 9f24851188..0000000000
--- a/development/spdlog/spdlog.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="spdlog"
-VERSION="0.13.0"
-HOMEPAGE="https://github.com/gabime/spdlog"
-DOWNLOAD="https://github.com/gabime/spdlog/archive/v0.13.0/spdlog-0.13.0.tar.gz"
-MD5SUM="a0903d50ae1d58b484d9fc1a6ddf02f4"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Andre Barboza"
-EMAIL="bmg.andre@gmail.com"
diff --git a/development/spdlog/spdlog.patch b/development/spdlog/spdlog.patch
deleted file mode 100644
index a061436573..0000000000
--- a/development/spdlog/spdlog.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -ur spdlog-0.11.0.old/CMakeLists.txt spdlog-0.11.0/CMakeLists.txt
---- spdlog-0.11.0.old/CMakeLists.txt 2016-09-17 20:28:41.000000000 -0300
-+++ spdlog-0.11.0/CMakeLists.txt 2017-01-09 16:01:16.795518326 -0200
-@@ -36,9 +36,9 @@
- # * https://github.com/forexample/package-example
- set(generated_dir "${CMAKE_CURRENT_BINARY_DIR}/generated")
-
--set(config_install_dir "lib/cmake/${PROJECT_NAME}")
-+set(config_install_dir "lib${LIB_SUFFIX}/cmake/${PROJECT_NAME}")
- set(include_install_dir "include")
--set(pkgconfig_install_dir "lib/pkgconfig")
-+set(pkgconfig_install_dir "lib${LIB_SUFFIX}/pkgconfig")
-
- set(version_config "${generated_dir}/${PROJECT_NAME}ConfigVersion.cmake")
- set(project_config "${generated_dir}/${PROJECT_NAME}Config.cmake")
diff --git a/libraries/spdlog/README b/libraries/spdlog/README
new file mode 100644
index 0000000000..0afd9e64a1
--- /dev/null
+++ b/libraries/spdlog/README
@@ -0,0 +1,3 @@
+Very fast, header-only/compiled, C++ logging library.
+
+fmt is an optional dependency.
diff --git a/development/spdlog/slack-desc b/libraries/spdlog/slack-desc
index 2468d87881..12a47c8e36 100644
--- a/development/spdlog/slack-desc
+++ b/libraries/spdlog/slack-desc
@@ -6,14 +6,14 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-spdlog: spdlog (Very fast, header only, C++ logging library)
+spdlog: spdlog (Fast C++ logging library)
+spdlog:
+spdlog: Very fast, header-only/compiled, C++ logging library.
+spdlog:
+spdlog: https://github.com/gabime/spdlog
+spdlog:
spdlog:
-spdlog: spdlog is very fast, header only, C++ logging library. Key features:
-spdlog: Very fast, headers only, asynchronous mode, custom formatting,
-spdlog: multi/single threaded loggers, various log targets, severity based
-spdlog: filtering.
spdlog:
spdlog:
spdlog:
-spdlog: https://github.com/gabime/spdlog
spdlog:
diff --git a/development/spdlog/spdlog.SlackBuild b/libraries/spdlog/spdlog.SlackBuild
index 2905dd1408..5b4d186587 100644
--- a/development/spdlog/spdlog.SlackBuild
+++ b/libraries/spdlog/spdlog.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for spdlog
# Copyright 2017 Andre Barboza, Belo Horizonte - Brazil
+# Copyright 2019 Hunter Sezen California, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,38 +24,18 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=spdlog
-VERSION=${VERSION:-0.13.0}
+VERSION=${VERSION:-1.3.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
+ARCH=noarch
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
+set -eu
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -69,21 +50,28 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 < $CWD/spdlog.patch
+FMT=OFF
+pkg-config --exists fmt && FMT=ON
+
+# cmake: Use DATAROOTDIR for pkg-config and cmake files.
+# This is not true in the master or in the upcomining 1.4 release.
+# https://github.com/gabime/spdlog/pull/1192
+sed -i 's/CMAKE_INSTALL_LIBDIR/CMAKE_INSTALL_DATAROOTDIR/' CMakeLists.txt
+
mkdir -p build
cd build
cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DSPDLOG_BUILD_BENCH=OFF \
+ -DSPDLOG_BUILD_EXAMPLES=OFF \
+ -DSPDLOG_FMT_EXTERNAL=$FMT \
-DCMAKE_BUILD_TYPE=Release ..
make
make install DESTDIR=$PKG
cd ..
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/libraries/spdlog/spdlog.info b/libraries/spdlog/spdlog.info
new file mode 100644
index 0000000000..2e24f627c1
--- /dev/null
+++ b/libraries/spdlog/spdlog.info
@@ -0,0 +1,10 @@
+PRGNAM="spdlog"
+VERSION="1.3.1"
+HOMEPAGE="https://github.com/gabime/spdlog"
+DOWNLOAD="https://github.com/gabime/spdlog/archive/v1.3.1/spdlog-1.3.1.tar.gz"
+MD5SUM="f700fa3acb0a06fbe91c392723370f70"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Hunter Sezen"
+EMAIL="orbea@riseup.net"