summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author CRTS2019-06-29 03:01:00 +0200
committer Willy Sudiarto Raharjo2019-06-29 03:01:00 +0200
commit1a24bd0bc853406e0b0757d190e6eab76f8410cb (patch)
tree00552b2382bcf04439bfabb4ccd06a97fd2e3bb8
parent377171575bcf191c26a95869e11ff1d4af2d0900 (diff)
downloadslackbuilds-1a24bd0bc853406e0b0757d190e6eab76f8410cb.tar.gz
games/dfarc: Added (frontend for freedink).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--games/dfarc/README24
-rw-r--r--games/dfarc/dfarc.SlackBuild114
-rw-r--r--games/dfarc/dfarc.info10
-rw-r--r--games/dfarc/slack-desc19
4 files changed, 167 insertions, 0 deletions
diff --git a/games/dfarc/README b/games/dfarc/README
new file mode 100644
index 0000000000..6aeced9ec6
--- /dev/null
+++ b/games/dfarc/README
@@ -0,0 +1,24 @@
+DFArc is a frontend for freedink. It lets you install and manage
+additional D-Mods for freedink.
+
+Known issues:
+- Freedink might start in a maximized, not resizable window. Parts of
+ it may be outside the Desktop. If this happens then start the
+ program windowed mode by ticking the corresponding checkbox in DFArc.
+ Afterwards you can switch to fullscreen by pressing Alt+Enter.
+
+Optional dependency:
+- upx
+ If upx is installed on the system then it is automatically
+ detected and considered at compile time.
+
+ If for some reason this is not desired then the script
+ should be called as
+
+ ENABLE_UPX=no ./dfarc.Slackbuild
+
+ If UPX resides in a non-standard location then it
+ can be provided by setting
+
+ UPX=/path/to/upx ./dfarc.Slackbuild
+
diff --git a/games/dfarc/dfarc.SlackBuild b/games/dfarc/dfarc.SlackBuild
new file mode 100644
index 0000000000..bff706b975
--- /dev/null
+++ b/games/dfarc/dfarc.SlackBuild
@@ -0,0 +1,114 @@
+#!/bin/sh
+
+# Slackware build script for dfarc
+
+# Copyright 2019- CRTS
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=dfarc
+VERSION=${VERSION:-3.14}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+CONFIGURE_OPTIONS=
+
+PATH=${UPX:+${UPX%/*}:}$PATH
+if which upx;then
+ CONFIGURE_OPTIONS="$CONFIGURE_OPTIONS --enable-upx=${ENABLE_UPX:-yes}"
+else
+ CONFIGURE_OPTIONS="$CONFIGURE_OPTIONS --enable-upx=no"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# ignore woeres.rc; do not install menu items
+sed -i '/AC_CHECK_TOOL(WINDRES, windres)/d;/^[[:blank:]]*ac_desktopfiles=yes/s/.*/ac_desktopfiles=no/' configure.ac
+
+autoreconf --install --symlink --warnings=all && intltoolize --force
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure $CONFIGURE_OPTIONS \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-static=no \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp ABOUT-NLS AUTHORS BUILD COPYING COPYING.DFArc COPYING.DFArc-2.0 ChangeLog NEWS README* \
+ TRANSLATIONS.txt $PKG/usr/doc/$PRGNAM-$VERSION
+
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/dfarc/dfarc.info b/games/dfarc/dfarc.info
new file mode 100644
index 0000000000..400c56ef4e
--- /dev/null
+++ b/games/dfarc/dfarc.info
@@ -0,0 +1,10 @@
+PRGNAM="dfarc"
+VERSION="3.14"
+HOMEPAGE="https://www.gnu.org/software/freedink"
+DOWNLOAD="https://ftp.gnu.org/pub/gnu/freedink/dfarc-3.14.tar.gz"
+MD5SUM="3ffe4d047eadeb1b335cbd2ec9e824f9"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="wxGTK3"
+MAINTAINER="CRTS"
+EMAIL="crts [at] gmx [dot] net"
diff --git a/games/dfarc/slack-desc b/games/dfarc/slack-desc
new file mode 100644
index 0000000000..40b8652e4f
--- /dev/null
+++ b/games/dfarc/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+dfarc: dfarc (frontend for freedink)
+dfarc:
+dfarc: DFArc is a frontend for freedink. It lets you install and
+dfarc: manage dmods.
+dfarc:
+dfarc: Homepage: https://www.gnu.org/software/freedink
+dfarc:
+dfarc:
+dfarc:
+dfarc:
+dfarc: