summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2019-05-30 18:08:07 +0200
committer Willy Sudiarto Raharjo2019-06-01 02:04:24 +0200
commit5d0a66fcc3d2099430eadf0b21d2a4db3ce08f3d (patch)
tree575b0873cab17c62e2c5030b02636dbaa869fc42
parentee77244d932b9ebf4fd84fea20ec432efccd78f1 (diff)
downloadslackbuilds-5d0a66fcc3d2099430eadf0b21d2a4db3ce08f3d.tar.gz
python/python3-MarkupSafe: Removed (merged with python/MarkupSafe).
-rw-r--r--python/python3-MarkupSafe/README4
-rw-r--r--python/python3-MarkupSafe/python3-MarkupSafe.SlackBuild88
-rw-r--r--python/python3-MarkupSafe/python3-MarkupSafe.info10
-rw-r--r--python/python3-MarkupSafe/slack-desc19
4 files changed, 0 insertions, 121 deletions
diff --git a/python/python3-MarkupSafe/README b/python/python3-MarkupSafe/README
deleted file mode 100644
index bf96b95a52..0000000000
--- a/python/python3-MarkupSafe/README
+++ /dev/null
@@ -1,4 +0,0 @@
-MarkupSafe implements a text object that escapes characters so it is safe to
-use in HTML and XML. Characters that have special meanings are replaced so that
-they display as the actual characters. This mitigates injection attacks,
-meaning untrusted user input can safely be displayed on a page.
diff --git a/python/python3-MarkupSafe/python3-MarkupSafe.SlackBuild b/python/python3-MarkupSafe/python3-MarkupSafe.SlackBuild
deleted file mode 100644
index 25fe2d27a7..0000000000
--- a/python/python3-MarkupSafe/python3-MarkupSafe.SlackBuild
+++ /dev/null
@@ -1,88 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python3-MarkupSafe
-
-# Copyright 2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-SRCNAM=MarkupSafe
-PRGNAM=python3-$SRCNAM
-VERSION=${VERSION:-1.1.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CHANGES.rst LICENSE.rst README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-MarkupSafe/python3-MarkupSafe.info b/python/python3-MarkupSafe/python3-MarkupSafe.info
deleted file mode 100644
index bf11f3bed9..0000000000
--- a/python/python3-MarkupSafe/python3-MarkupSafe.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-MarkupSafe"
-VERSION="1.1.1"
-HOMEPAGE="https://github.com/pypa/python3-MarkupSafe"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/M/MarkupSafe/MarkupSafe-1.1.1.tar.gz"
-MD5SUM="43fd756864fe42063068e092e220c57b"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/python3-MarkupSafe/slack-desc b/python/python3-MarkupSafe/slack-desc
deleted file mode 100644
index 16f2a407a3..0000000000
--- a/python/python3-MarkupSafe/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-MarkupSafe: python3-MarkupSafe (untrusted strings in HTML/XML markup)
-python3-MarkupSafe:
-python3-MarkupSafe: MarkupSafe implements a text object that escapes characters so it is
-python3-MarkupSafe: safe to use in HTML and XML. Characters that have special meanings
-python3-MarkupSafe: are replaced so that they display as the actual characters. This
-python3-MarkupSafe: mitigates injection attacks, meaning untrusted user input can safely
-python3-MarkupSafe: be displayed on a page.
-python3-MarkupSafe:
-python3-MarkupSafe:
-python3-MarkupSafe:
-python3-MarkupSafe: