summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2019-04-26 23:47:54 +0200
committer Willy Sudiarto Raharjo2019-04-26 23:47:54 +0200
commitacd3e150e2dfb7732bca61476e8ea4701d036fcc (patch)
tree3c535011e00d8f4d071262f39bdc777663f1fda1
parenta33ac1696804717e0b86093f1aa4cfe8bb4e0c4a (diff)
downloadslackbuilds-acd3e150e2dfb7732bca61476e8ea4701d036fcc.tar.gz
python/python-PySnooper: Added (simple debugger for Python).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-PySnooper/README7
-rw-r--r--python/python-PySnooper/python-PySnooper.SlackBuild89
-rw-r--r--python/python-PySnooper/python-PySnooper.info10
-rw-r--r--python/python-PySnooper/slack-desc19
4 files changed, 125 insertions, 0 deletions
diff --git a/python/python-PySnooper/README b/python/python-PySnooper/README
new file mode 100644
index 0000000000..87440bc63a
--- /dev/null
+++ b/python/python-PySnooper/README
@@ -0,0 +1,7 @@
+PySnooper is a poor man's debugger for Python.
+
+PySnooper lets you inspect variables and see which lines are running without
+the need for a debugger, breakpoints or print statements. To use PySnooper, add
+one decorator line to the function you're interested in. You'll get a
+play-by-play log of your function, including which lines ran and when, and
+exactly when local variables were changed.
diff --git a/python/python-PySnooper/python-PySnooper.SlackBuild b/python/python-PySnooper/python-PySnooper.SlackBuild
new file mode 100644
index 0000000000..b19024f532
--- /dev/null
+++ b/python/python-PySnooper/python-PySnooper.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for python-PySnooper
+
+# Copyright 2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+SRCNAM=PySnooper
+PRGNAM=python-$SRCNAM
+VERSION=${VERSION:-0.0.22}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-PySnooper/python-PySnooper.info b/python/python-PySnooper/python-PySnooper.info
new file mode 100644
index 0000000000..b807b19130
--- /dev/null
+++ b/python/python-PySnooper/python-PySnooper.info
@@ -0,0 +1,10 @@
+PRGNAM="python-PySnooper"
+VERSION="0.0.22"
+HOMEPAGE="https://github.com/cool-RR/PySnooper"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/P/PySnooper/PySnooper-0.0.22.tar.gz"
+MD5SUM="a2e15de16feac66dc2b5f97d20aff0f8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/python-PySnooper/slack-desc b/python/python-PySnooper/slack-desc
new file mode 100644
index 0000000000..0cdb244442
--- /dev/null
+++ b/python/python-PySnooper/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-PySnooper: python-PySnooper (simple debugger for Python)
+python-PySnooper:
+python-PySnooper: PySnooper is a poor man's debugger for Python.
+python-PySnooper:
+python-PySnooper: PySnooper lets you inspect variables and see which lines are running
+python-PySnooper: without the need for a debugger, breakpoints or print statements. To
+python-PySnooper: use PySnooper, add one decorator line to the function you're
+python-PySnooper: interested in. You'll get a play-by-play log of your function,
+python-PySnooper: including which lines ran and when, and exactly when local variables
+python-PySnooper: were changed.
+python-PySnooper: