summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2019-04-29 11:34:59 +0200
committer Willy Sudiarto Raharjo2019-05-04 04:06:49 +0200
commit4a4c27a8a0e4005789105d5e5c4b587ffa7f84d4 (patch)
tree85dab58ae8a1bf2d36aeed6e4508e6f6fa9870df
parentdc28fd1e92af9ae0a68478cd0e640b5d0f34e6b3 (diff)
downloadslackbuilds-4a4c27a8a0e4005789105d5e5c4b587ffa7f84d4.tar.gz
libraries/uriparser: Updated for version 0.9.3, switch to cmake.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--libraries/uriparser/uriparser.SlackBuild37
-rw-r--r--libraries/uriparser/uriparser.info6
2 files changed, 20 insertions, 23 deletions
diff --git a/libraries/uriparser/uriparser.SlackBuild b/libraries/uriparser/uriparser.SlackBuild
index 00b9142000..32944960ac 100644
--- a/libraries/uriparser/uriparser.SlackBuild
+++ b/libraries/uriparser/uriparser.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for uriparser
-# Copyright 2015-2018 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# Copyright 2015-2019 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=uriparser
-VERSION=${VERSION:-0.9.1}
+VERSION=${VERSION:-0.9.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,24 +71,21 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# fix docs installation errors - thanks fedora!
-sed -i -e 's,html/\*.map\ ,,g' doc/Makefile.in || exit 1
-sed -i -e 's,-\$(INSTALL_DATA) \*.qch "$(DESTDIR)\$(docdir)/",,g' doc/Makefile.in || exit 1
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --disable-test \
- --disable-static \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
+# Test building is disabled ATM because we haven't an up2date gtest
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DMAN_INSTALL_DIR=/usr/man \
+ -DCMAKE_INSTALL_DOCDIR=/usr/doc/$PRGNAM-$VERSION \
+ -DURIPARSER_BUILD_TESTS=OFF \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/libraries/uriparser/uriparser.info b/libraries/uriparser/uriparser.info
index 2d0fe74ae3..683158a09e 100644
--- a/libraries/uriparser/uriparser.info
+++ b/libraries/uriparser/uriparser.info
@@ -1,8 +1,8 @@
PRGNAM="uriparser"
-VERSION="0.9.1"
+VERSION="0.9.3"
HOMEPAGE="https://uriparser.github.io"
-DOWNLOAD="https://github.com/uriparser/uriparser/releases/download/uriparser-0.9.1/uriparser-0.9.1.tar.bz2"
-MD5SUM="c00ac34aaf4ab66c69d1100db3b79a62"
+DOWNLOAD="https://github.com/uriparser/uriparser/releases/download/uriparser-0.9.3/uriparser-0.9.3.tar.xz"
+MD5SUM="e857bf458b3aca5ea338d1e4b1f74c1a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="graphviz"