summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Heinz Wiesinger2019-02-03 21:43:56 +0100
committer Willy Sudiarto Raharjo2019-02-09 04:30:08 +0100
commitc6f0bfbc4637ee1ef82a8445acd8f5565f8059cc (patch)
treebfce85268b8305d3edce3ca03c42b313d3bf12c8
parent631ea3402f20b5940202d4cfd6ead182867572cd (diff)
downloadslackbuilds-c6f0bfbc4637ee1ef82a8445acd8f5565f8059cc.tar.gz
system/virtualbox-kernel: Fix building against kernel >= 4.4.168.
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org>
-rw-r--r--system/virtualbox-kernel/virtualbox-kernel.SlackBuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/system/virtualbox-kernel/virtualbox-kernel.SlackBuild b/system/virtualbox-kernel/virtualbox-kernel.SlackBuild
index 2ded2d2429..d6c0e8a584 100644
--- a/system/virtualbox-kernel/virtualbox-kernel.SlackBuild
+++ b/system/virtualbox-kernel/virtualbox-kernel.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for virtualbox-kernel
-# Copyright 2008-2017 Heinz Wiesinger, Amsterdam, The Netherlands
+# Copyright 2008-2019 Heinz Wiesinger, Amsterdam, The Netherlands
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
PRGNAM=virtualbox-kernel
VERSION=${VERSION:-5.0.40}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
KERNEL=${KERNEL:-$(uname -r)}
@@ -70,6 +70,14 @@ if ! [ "${HARDENING:-yes}" = "yes" ]; then
{vboxdrv,vboxnetadp,vboxnetflt,vboxpci}/Makefile
fi
+KERNEL_MINOR=$(echo $KERNEL | cut -d "." -f 2)
+KERNEL_PATCH=$(echo $KERNEL | cut -d "." -f 3)
+
+# Work around API break introduced in kernel 4.4.168
+if [ "$KERNEL_MINOR" = 4 -a "$KERNEL_PATCH" -ge 168 ]; then
+ sed -i "s|KERNEL_VERSION(4, 9, 0)|KERNEL_VERSION(4, 4, 168)|" vboxdrv/r0drv/linux/memobj-r0drv-linux.c
+fi
+
make KERN_DIR=${KERNELPATH}
mkdir -p $PKG/lib/modules/$KERNEL/misc